diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2016-01-18 14:51:29 +0100 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2016-01-18 14:54:45 +0100 |
commit | 0d310c2324d0fddcf306c406849158d84a6bd608 (patch) | |
tree | 55df39f628c52403315e7955eb387a44dc24076c /documentation/docsrc_common | |
download | meta-enea-base-ppc-dizzy-enea.tar.gz |
initial commit for Enea Linux 5.0-ppcdizzy-enea
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'documentation/docsrc_common')
-rw-r--r-- | documentation/docsrc_common/conditions.mk | 33 | ||||
-rw-r--r-- | documentation/docsrc_common/feature_matrix.xml | 185 | ||||
-rw-r--r-- | documentation/docsrc_common/pardoc-distro.xml | 112 |
3 files changed, 330 insertions, 0 deletions
diff --git a/documentation/docsrc_common/conditions.mk b/documentation/docsrc_common/conditions.mk new file mode 100644 index 0000000..13acb32 --- /dev/null +++ b/documentation/docsrc_common/conditions.mk | |||
@@ -0,0 +1,33 @@ | |||
1 | ############################################################################### | ||
2 | # XML conditions, by default set for all books built from this clone. | ||
3 | # When building, conditional XML elements are | ||
4 | # - shown only if the condition is SET | ||
5 | # - hidden if the condition is NOT set | ||
6 | # Book-specific conditions may set in book-xxx/swcomp.mk, or in runtime by | ||
7 | # make doc or makethisdoc. Run make docusage or makethisdoc -h for further info. | ||
8 | ############################################################################### | ||
9 | X_MISC:=\ | ||
10 | eclipse\ | ||
11 | general\ | ||
12 | pm_smart | ||
13 | |||
14 | X_TARGETS:=\ | ||
15 | t_t4240\ | ||
16 | t_p2041\ | ||
17 | t_p3041 | ||
18 | |||
19 | X_FEATURES:=\ | ||
20 | f_any;f_any_nw;f_ovs;f_any_vt;f_kvm;f_lxc;f_any_rt;f_ci | ||
21 | |||
22 | empty= | ||
23 | space=$(empty) $(empty) | ||
24 | MISC:=$(subst $(space),;,$(strip $(X_MISC))) | ||
25 | TARGETS:=$(subst $(space),;,$(strip $(X_TARGETS))) | ||
26 | FEATURES:=$(subst $(space),;,$(strip $(X_FEATURES))) | ||
27 | |||
28 | DEFAULTCONDITIONS:=$(MISC);$(TARGETS);$(FEATURES) | ||
29 | |||
30 | ############################################################################### | ||
31 | # Available conditions are listed in docsrc_common/conditions_template.mk | ||
32 | # in linux/documentation.git. | ||
33 | ############################################################################### | ||
diff --git a/documentation/docsrc_common/feature_matrix.xml b/documentation/docsrc_common/feature_matrix.xml new file mode 100644 index 0000000..0fd2b79 --- /dev/null +++ b/documentation/docsrc_common/feature_matrix.xml | |||
@@ -0,0 +1,185 @@ | |||
1 | <?xml version="1.0" encoding="ISO-8859-1"?> | ||
2 | <!DOCTYPE section PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" | ||
3 | "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"> | ||
4 | <section id="feature-matrix"> | ||
5 | <title>Feature Compatibility Matrix</title> | ||
6 | |||
7 | <para>The following features are supported in Enea Linux. Limitations are | ||
8 | explained below the table.</para> | ||
9 | |||
10 | <informaltable> | ||
11 | <tgroup cols="9"> | ||
12 | <colspec colname="c1" colwidth="4*" /> | ||
13 | |||
14 | <colspec align="center" colname="c2" /> | ||
15 | |||
16 | <colspec align="center" colname="c3" /> | ||
17 | |||
18 | <colspec align="center" colname="c4" /> | ||
19 | |||
20 | <colspec align="center" colname="c5" /> | ||
21 | |||
22 | <colspec align="center" colname="c6" /> | ||
23 | |||
24 | <colspec align="center" colname="c7" /> | ||
25 | |||
26 | <colspec align="center" colname="c8" /> | ||
27 | |||
28 | <colspec align="center" colname="c9" colwidth="1.5*" /> | ||
29 | |||
30 | <thead valign="bottom"> | ||
31 | <row> | ||
32 | <entry align="left" morerows="1">Targets</entry> | ||
33 | |||
34 | <entry align="center" nameend="c4" namest="c2">Networking | ||
35 | Features</entry> | ||
36 | |||
37 | <entry align="center" nameend="c6" namest="c5">Virtualization | ||
38 | Features</entry> | ||
39 | |||
40 | <entry align="center" nameend="c8" namest="c7">Real-Time | ||
41 | Features</entry> | ||
42 | |||
43 | <entry align="center">Memory Features</entry> | ||
44 | </row> | ||
45 | |||
46 | <row> | ||
47 | <entry align="center">OVS</entry> | ||
48 | |||
49 | <entry align="center"><superscript>a) </superscript>DVS</entry> | ||
50 | |||
51 | <entry align="center"><superscript>a) </superscript>DPDK</entry> | ||
52 | |||
53 | <entry align="center"><superscript>b)</superscript>KVM</entry> | ||
54 | |||
55 | <entry align="center"><superscript>c)</superscript>LXC</entry> | ||
56 | |||
57 | <entry align="center"><superscript>d)</superscript>CI</entry> | ||
58 | |||
59 | <entry align="center">FPK</entry> | ||
60 | |||
61 | <entry align="center"><superscript>e) </superscript>NUMA</entry> | ||
62 | </row> | ||
63 | </thead> | ||
64 | |||
65 | <tbody> | ||
66 | <row condition="t_p2041" valign="middle"> | ||
67 | <entry><xi:include href="pardoc-distro.xml" | ||
68 | xmlns:xi="http://www.w3.org/2001/XInclude" | ||
69 | xpointer="element(EneaLinux_TARGET_NAME_P2041/1)" /></entry> | ||
70 | |||
71 | <entry>✔</entry> | ||
72 | |||
73 | <entry>✗</entry> | ||
74 | |||
75 | <entry>✗</entry> | ||
76 | |||
77 | <entry>✔</entry> | ||
78 | |||
79 | <entry>✔</entry> | ||
80 | |||
81 | <entry>✔</entry> | ||
82 | |||
83 | <entry>✗</entry> | ||
84 | |||
85 | <entry>✗</entry> | ||
86 | </row> | ||
87 | |||
88 | <row condition="t_p3041" valign="middle"> | ||
89 | <entry><xi:include href="pardoc-distro.xml" | ||
90 | xmlns:xi="http://www.w3.org/2001/XInclude" | ||
91 | xpointer="element(EneaLinux_TARGET_NAME_P3041/1)" /></entry> | ||
92 | |||
93 | <entry>✔</entry> | ||
94 | |||
95 | <entry>✗</entry> | ||
96 | |||
97 | <entry>✗</entry> | ||
98 | |||
99 | <entry>✔</entry> | ||
100 | |||
101 | <entry>✔</entry> | ||
102 | |||
103 | <entry>✔</entry> | ||
104 | |||
105 | <entry>✗</entry> | ||
106 | |||
107 | <entry>✗</entry> | ||
108 | </row> | ||
109 | |||
110 | <row condition="t_t4240" valign="middle"> | ||
111 | <entry><xi:include href="pardoc-distro.xml" | ||
112 | xmlns:xi="http://www.w3.org/2001/XInclude" | ||
113 | xpointer="element(EneaLinux_TARGET_NAME_T4240/1)" /></entry> | ||
114 | |||
115 | <entry>✔</entry> | ||
116 | |||
117 | <entry>✗</entry> | ||
118 | |||
119 | <entry>✗</entry> | ||
120 | |||
121 | <entry>✔</entry> | ||
122 | |||
123 | <entry>✔</entry> | ||
124 | |||
125 | <entry>✔</entry> | ||
126 | |||
127 | <entry>✗</entry> | ||
128 | |||
129 | <entry>✗</entry> | ||
130 | </row> | ||
131 | <row condition="qemu" valign="middle"> | ||
132 | <entry>QEMU</entry> | ||
133 | |||
134 | <entry>✗</entry> | ||
135 | |||
136 | <entry>✗</entry> | ||
137 | |||
138 | <entry>✗</entry> | ||
139 | |||
140 | <entry>✗</entry> | ||
141 | |||
142 | <entry>✗</entry> | ||
143 | |||
144 | <entry>✗</entry> | ||
145 | |||
146 | <entry>✗</entry> | ||
147 | |||
148 | <entry>✗</entry> | ||
149 | </row> | ||
150 | </tbody> | ||
151 | </tgroup> | ||
152 | </informaltable> | ||
153 | |||
154 | <epigraph> | ||
155 | <para>✔ = supported, ✗ = not supported</para> | ||
156 | </epigraph> | ||
157 | |||
158 | <orderedlist numeration="loweralpha" spacing="compact"> | ||
159 | <listitem> | ||
160 | <para>DPDK and DPDK vSwitch are supported in x86 architectures | ||
161 | only.</para> | ||
162 | </listitem> | ||
163 | |||
164 | <listitem> | ||
165 | <para>Support for KVM is included in the kernel, but necessary | ||
166 | user-space functionality is not part of this release.</para> | ||
167 | </listitem> | ||
168 | |||
169 | <listitem> | ||
170 | <para>Limited LXC support. LXC feature "user namespace" is not supported | ||
171 | in Power architectures.</para> | ||
172 | </listitem> | ||
173 | |||
174 | <listitem> | ||
175 | <para>Limited CPU Isolation support. Full tickless environment is not | ||
176 | achievable in these targets. Isolated CPUs will be disturbed by ticks | ||
177 | once a second (1 Hz). The meta-nohz layer is not part of the | ||
178 | image.</para> | ||
179 | </listitem> | ||
180 | |||
181 | <listitem> | ||
182 | <para>NUMA is not supported by ARM architectures.</para> | ||
183 | </listitem> | ||
184 | </orderedlist> | ||
185 | </section> | ||
diff --git a/documentation/docsrc_common/pardoc-distro.xml b/documentation/docsrc_common/pardoc-distro.xml new file mode 100644 index 0000000..edc4142 --- /dev/null +++ b/documentation/docsrc_common/pardoc-distro.xml | |||
@@ -0,0 +1,112 @@ | |||
1 | <?xml version="1.0" encoding="ISO-8859-1"?> | ||
2 | <!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" | ||
3 | "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [ | ||
4 | <!-- Version and name entities | ||
5 | ============================== | ||
6 | --> | ||
7 | <!-- Distribution and release --> | ||
8 | <!ENTITY ENEA_LINUX_REL_VER "5.0-ppc"> | ||
9 | <!ENTITY ENEA_LINUX_PROD_VER "5"> | ||
10 | <!ENTITY ENEA_LINUX_BRANCH "dizzy-enea"> | ||
11 | <!ENTITY ENEA_LINUX_DISTRO "enea"> | ||
12 | <!-- Yocto and Poky --> | ||
13 | <!ENTITY YOCTO_VER "1.7.2"> | ||
14 | <!ENTITY YOCTO_VER_MINOR "1.7"> | ||
15 | <!ENTITY YOCTO_VER_DOWN "172"> | ||
16 | <!ENTITY YOCTO_VER_DOWN_MINOR "17"> | ||
17 | <!ENTITY POKY_NAME "Dizzy"> | ||
18 | <!ENTITY POKY_VER "dizzy-12.0.2"> | ||
19 | <!-- Host --> | ||
20 | <!ENTITY ENEA_LINUX_HOST_VER "64-bit Ubuntu 14.04 LTS"> | ||
21 | <!-- Target --> | ||
22 | <!ENTITY ENEA_LINUX_TARGET_NAME_P2041 "Freescale P2041RDB"> | ||
23 | <!ENTITY ENEA_LINUX_TARGET_NAME_P3041 "Freescale P3041DS"> | ||
24 | <!ENTITY ENEA_LINUX_TARGET_NAME_T4240 "Freescale T4240RDB"> | ||
25 | <!ENTITY ENEA_LINUX_KERNEL_VER "3.12"> | ||
26 | <!-- SDK --> | ||
27 | <!ENTITY ENEA_LINUX_GCC_VER "4.9"> | ||
28 | <!ENTITY ENEA_LINUX_SDK_VER "&ENEA_LINUX_REL_VER;"> | ||
29 | <!ENTITY ENEA_LINUX_SDK_IMAGE "enea-image-featured"> | ||
30 | <!ENTITY ENEA_LINUX_SDK_HOST_ARCH "x86_64"> | ||
31 | <!ENTITY ENEA_LINUX_SDK_TARGET_ARCH_32 "ppce6500mc"> | ||
32 | <!ENTITY ENEA_LINUX_SDK_TARGET_ARCH_64 "ppc64e6500"> | ||
33 | <!ENTITY ENEA_LINUX_SDK_LIBC "glibc"> | ||
34 | <!ENTITY ENEA_LINUX_SDK_GNUTAIL ""> | ||
35 | <!-- Eclipse --> | ||
36 | <!ENTITY ENEA_LINUX_REL_VER_ECLIPSE "4.0"> | ||
37 | <!ENTITY ECLIPSE_VER "4.3"> | ||
38 | <!ENTITY ECLIPSE_NAME "Kepler"> | ||
39 | <!ENTITY ECLIPSE_REL "kepler"> | ||
40 | |||
41 | <!-- URL entities | ||
42 | =================== --> | ||
43 | <!ENTITY ENEA_LINUX_URL "https://linux.enea.com/&ENEA_LINUX_REL_VER;"> | ||
44 | <!ENTITY EL_RTGUIDE_URL "http://www.enea.com/Embedded-hub/whitepapers/white-papers/Linux-Real-Time-Guide"> | ||
45 | <!ENTITY YOCTO_HOME_URL "https://www.yoctoproject.org"> | ||
46 | <!ENTITY YOCTO_DOCS_URL "&YOCTO_HOME_URL;/docs/&YOCTO_VER;"> | ||
47 | <!ENTITY YOCTO_DOCU_URL "&YOCTO_HOME_URL;/documentation"> | ||
48 | <!ENTITY YOCTO_CORE_URL "&YOCTO_HOME_URL;/downloads/core"> | ||
49 | <!ENTITY YOCTO_DOWN_URL "&YOCTO_CORE_URL;/&POKY_NAME;&YOCTO_VER_DOWN;"> | ||
50 | <!ENTITY YOCTO_DOWN_MINOR_URL "&YOCTO_CORE_URL;/&POKY_NAME;&YOCTO_VER_DOWN_MINOR;"> | ||
51 | <!ENTITY YOCTO_ADT_URL "&YOCTO_DOCS_URL;/adt-manual/adt-manual.html"> | ||
52 | <!ENTITY YOCTO_REF_URL "&YOCTO_DOCS_URL;/ref-manual/ref-manual.html"> | ||
53 | ]> | ||
54 | |||
55 | <!-- Declarations to inherit by xi:include | ||
56 | ========================================== --> | ||
57 | <section id="pardoc_names"> | ||
58 | <title>Common Enea Linux DocBook XML Based UserDoc Names and Parameters</title> | ||
59 | |||
60 | <para>NOTE: DO NOT EDIT THIS FILE IN xmlmind !!!</para> | ||
61 | |||
62 | <para>NOTE: Use xi:include to include parameters into a docbook XML file. | ||
63 | Note: Only full elements can be included and the included element must | ||
64 | be allowed in that place. Example: For ulink, entire ulink elements | ||
65 | must be included, not just parts of them.</para> | ||
66 | |||
67 | <para>**** The phrase elements below can be used as variables in several | ||
68 | places in XML files ****</para> | ||
69 | <para>**** Makefile parses variable REL_VER from entity ENEA_LINUX_REL_VER, | ||
70 | swcomp.mk extracts BOOK_VER from variable REL_VER ****</para> | ||
71 | |||
72 | <!-- Distribution and release --> | ||
73 | <para id="EneaLinux_PROD_VER"><phrase>&ENEA_LINUX_PROD_VER;</phrase></para> | ||
74 | <para id="EneaLinux_REL_VER"><phrase>&ENEA_LINUX_REL_VER;</phrase></para> | ||
75 | <para id="EneaLinux_REL_NAME"><phrase>Enea Linux &ENEA_LINUX_PROD_VER; for PPC</phrase></para> | ||
76 | <para id="EneaLinux_BRANCH"><phrase>&ENEA_LINUX_BRANCH;</phrase></para> | ||
77 | <para id="EneaLinux_DISTRO"><phrase>&ENEA_LINUX_DISTRO;</phrase></para> | ||
78 | <!-- Yocto and Poky --> | ||
79 | <para id="Yocto_VER"><phrase>&YOCTO_VER;</phrase></para> | ||
80 | <para id="Poky_NAME"><phrase>&POKY_NAME;</phrase></para> | ||
81 | <para id="Poky_VER"><phrase>&POKY_VER;</phrase></para> | ||
82 | <!-- Host --> | ||
83 | <para id="EneaLinux_HOST_VER"><phrase>&ENEA_LINUX_HOST_VER;</phrase></para> | ||
84 | <!-- Target --> | ||
85 | <para id="EneaLinux_TARGET_NAME_P2041"><phrase>&ENEA_LINUX_TARGET_NAME_P2041;</phrase></para> | ||
86 | <para id="EneaLinux_TARGET_NAME_P3041"><phrase>&ENEA_LINUX_TARGET_NAME_P3041;</phrase></para> | ||
87 | <para id="EneaLinux_TARGET_NAME_T4240"><phrase>&ENEA_LINUX_TARGET_NAME_T4240;</phrase></para> | ||
88 | <para id="EneaLinux_KERNEL_VER"><phrase>&ENEA_LINUX_KERNEL_VER;</phrase></para> | ||
89 | <!-- SDK --> | ||
90 | <para id="EneaLinux_SDK_INSTALLER"><phrase>&ENEA_LINUX_DISTRO;-&ENEA_LINUX_SDK_LIBC;-&ENEA_LINUX_SDK_HOST_ARCH;-&ENEA_LINUX_SDK_IMAGE;-&ENEA_LINUX_SDK_TARGET_ARCH_64;-toolchain-&ENEA_LINUX_SDK_VER;.sh</phrase></para> | ||
91 | <para id="EneaLinux_SDK_ENV_SCRIPT_32"><phrase>environment-setup-&ENEA_LINUX_SDK_TARGET_ARCH_32;-eneamllib32-linux</phrase></para> | ||
92 | <para id="EneaLinux_SDK_ENV_SCRIPT_64"><phrase>environment-setup-&ENEA_LINUX_SDK_TARGET_ARCH_64;-enea-linux</phrase></para> | ||
93 | <para id="EneaLinux_GCC_VER"><phrase>&ENEA_LINUX_GCC_VER;</phrase></para> | ||
94 | <para id="EneaLinux_SDK_IMAGE"><phrase>&ENEA_LINUX_SDK_IMAGE;</phrase></para> | ||
95 | <para id="EneaLinux_SDK_HOST_ARCH"><phrase>&ENEA_LINUX_SDK_HOST_ARCH;</phrase></para> | ||
96 | <para id="EneaLinux_SDK_TARGET_ARCH_32"><phrase>&ENEA_LINUX_SDK_TARGET_ARCH_32;</phrase></para> | ||
97 | <para id="EneaLinux_SDK_TARGET_ARCH_64"><phrase>&ENEA_LINUX_SDK_TARGET_ARCH_64;</phrase></para> | ||
98 | <!-- Eclipse --> | ||
99 | <para id="EneaLinux_REL_VER_ECLIPSE"><phrase>&ENEA_LINUX_REL_VER_ECLIPSE;</phrase></para> | ||
100 | <para id="Eclipse_VER"><phrase>&ECLIPSE_VER;</phrase></para> | ||
101 | <para id="Eclipse_NAME"><phrase>&ECLIPSE_NAME;</phrase></para> | ||
102 | |||
103 | <para>**** The complete ulink elements below can be used as web links ****</para> | ||
104 | <para id="ULINK_ENEA_LINUX_URL"><ulink url='&ENEA_LINUX_URL;'>&ENEA_LINUX_URL;</ulink></para> | ||
105 | <para id="ULINK_ENEA_LINUX_RTGUIDE"><ulink url='&EL_RTGUIDE_URL;'><trademark class="registered">Enea</trademark> Linux Real-Time Guide</ulink></para> | ||
106 | <para id="ULINK_YOCTO_DOCS_ARCHIVED_URL"><ulink url='&YOCTO_DOCU_URL;/archived'>Yocto Project Documentation</ulink></para> | ||
107 | <para id="ULINK_YOCTO_ADT_TOOLCHAIN_URL"><ulink url='&YOCTO_ADT_URL;#using-an-existing-toolchain-tarball'><emphasis>Using a Cross-Toolchain Tarball</emphasis> in the Yocto Project Application Development Toolkit (ADT) User's Guide</ulink></para> | ||
108 | <para id="ULINK_YOCTO_QUICK_URL"><ulink url="&YOCTO_DOCS_URL;/yocto-project-qs/yocto-project-qs.html">Yocto Project Quick Start</ulink></para> | ||
109 | <para id="ULINK_YOCTO_REF_DEBUG_BUILD_URL"><ulink url='&YOCTO_REF_URL;#usingpoky-debugging'><emphasis>Debugging Build Failures</emphasis> in the Yocto Project Reference Manual</ulink></para> | ||
110 | <para id="ULINK_YOCTO_DOWN_URL"><ulink url='&YOCTO_DOWN_URL;'>Yocto &YOCTO_VER; (&POKY_NAME;) download page</ulink></para> | ||
111 | <para id="ULINK_YOCTO_DOWN_MINOR_URL"><ulink url='&YOCTO_DOWN_MINOR_URL;'>Yocto &YOCTO_VER_MINOR; (&POKY_NAME;) minor version download page</ulink></para> | ||
112 | </section> | ||