diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 13:49:50 +0200 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 13:49:50 +0200 |
commit | bdb04bfd80f4313d14cba8b3d857586da8b65ad2 (patch) | |
tree | abc7e217ce709456879d0918c6ed5b03e54f9aba | |
download | meta-ltp-dev-daisy-enea.tar.gz |
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r-- | conf/layer.conf | 13 | ||||
-rw-r--r-- | recipes-extended/ltp/files/periodic_output.patch | 31 | ||||
-rw-r--r-- | recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch | 202 | ||||
-rw-r--r-- | recipes-extended/ltp/ltp/ltp-Do-not-link-against-libfl.patch | 31 | ||||
-rw-r--r-- | recipes-extended/ltp/ltp/regen-makefile.patch | 22 | ||||
-rw-r--r-- | recipes-extended/ltp/ltp_20140508.bb | 82 |
6 files changed, 381 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf new file mode 100644 index 0000000..3582c42 --- /dev/null +++ b/conf/layer.conf | |||
@@ -0,0 +1,13 @@ | |||
1 | # We have a packages directory, add to BBFILES | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*" | ||
5 | BBFILES += "${LAYERDIR}/images/*.bb*" | ||
6 | BBFILES += "${LAYERDIR}/images-append/*.bb*" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "enea-ltp-dev" | ||
9 | BBFILE_PATTERN_enea-ltp-dev := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_enea-ltp-dev = "7" | ||
11 | LAYERDEPENDS_enea-ltp-dev = "core" | ||
12 | |||
13 | BB_DANGLINGAPPENDS_WARNONLY = "yes" | ||
diff --git a/recipes-extended/ltp/files/periodic_output.patch b/recipes-extended/ltp/files/periodic_output.patch new file mode 100644 index 0000000..153fe83 --- /dev/null +++ b/recipes-extended/ltp/files/periodic_output.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Add periodic output for long time test. | ||
2 | |||
3 | Signed-off-by: Tudor Florea <tudor.florea@enea.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | diff -ruN a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh | ||
7 | --- a/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh 2013-11-08 15:54:09.515049081 +0100 | ||
8 | +++ b/testcases/kernel/controllers/memcg/stress/memcg_stress_test.sh 2013-11-08 22:32:15.587370406 +0100 | ||
9 | @@ -37,7 +37,8 @@ | ||
10 | exit 0 | ||
11 | fi | ||
12 | |||
13 | -RUN_TIME=$(( 60 * 60 )) | ||
14 | +ONE_MINUTE=60 | ||
15 | +RUN_TIME=60 | ||
16 | |||
17 | cleanup() | ||
18 | { | ||
19 | @@ -81,7 +82,11 @@ | ||
20 | eval /bin/kill -s SIGUSR1 \$pid$i 2> /dev/null | ||
21 | done | ||
22 | |||
23 | - sleep $4 | ||
24 | + for i in $(seq 0 $RUN_TIME-1) | ||
25 | + do | ||
26 | + eval echo "Started $i min ago. Still alive... " | ||
27 | + sleep $ONE_MINUTE | ||
28 | + done | ||
29 | |||
30 | for i in $(seq 0 $(($1-1))) | ||
31 | do | ||
diff --git a/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch b/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch new file mode 100644 index 0000000..1b4d232 --- /dev/null +++ b/recipes-extended/ltp/ltp/0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch | |||
@@ -0,0 +1,202 @@ | |||
1 | From 9751a6526cffcdf4e3dc2cb33641259a7be00e19 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Sat, 7 Dec 2013 18:24:32 +0100 | ||
4 | Subject: [PATCH] Rename runtests_noltp.sh script so have unique name | ||
5 | |||
6 | * they are installed in the same target path | ||
7 | /opt/ltp/testcases/bin/runtests_noltp.sh | ||
8 | and overwrite each other in non-deterministic way | ||
9 | when multiple processes are used in "make install" | ||
10 | |||
11 | ./temp/log.do_install:install -m 00775 | ||
12 | "ltp/20120903-r2/ltp-20120903/testcases/kernel/containers/sysvipc/runtests_noltp.sh" | ||
13 | "ltp/20120903-r2/image/opt/ltp/testcases/bin/runtests_noltp.sh" | ||
14 | ./temp/log.do_install:install -m 00775 | ||
15 | "ltp/20120903-r2/ltp-20120903/testcases/kernel/containers/utsname/runtests_noltp.sh" | ||
16 | "ltp/20120903-r2/image/opt/ltp/testcases/bin/runtests_noltp.sh" | ||
17 | |||
18 | Upstream-Status: Pending | ||
19 | |||
20 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
21 | --- | ||
22 | .../kernel/containers/sysvipc/runipctests_noltp.sh | 31 ++++++++++++++++ | ||
23 | .../kernel/containers/sysvipc/runtests_noltp.sh | 31 ---------------- | ||
24 | .../kernel/containers/utsname/runtests_noltp.sh | 41 ---------------------- | ||
25 | .../kernel/containers/utsname/runutstests_noltp.sh | 41 ++++++++++++++++++++++ | ||
26 | 4 files changed, 72 insertions(+), 72 deletions(-) | ||
27 | create mode 100644 testcases/kernel/containers/sysvipc/runipctests_noltp.sh | ||
28 | delete mode 100644 testcases/kernel/containers/sysvipc/runtests_noltp.sh | ||
29 | delete mode 100755 testcases/kernel/containers/utsname/runtests_noltp.sh | ||
30 | create mode 100755 testcases/kernel/containers/utsname/runutstests_noltp.sh | ||
31 | |||
32 | diff --git a/testcases/kernel/containers/sysvipc/runipctests_noltp.sh b/testcases/kernel/containers/sysvipc/runipctests_noltp.sh | ||
33 | new file mode 100644 | ||
34 | index 0000000..84f398f | ||
35 | --- /dev/null | ||
36 | +++ b/testcases/kernel/containers/sysvipc/runipctests_noltp.sh | ||
37 | @@ -0,0 +1,31 @@ | ||
38 | +#!/bin/sh | ||
39 | +################################################################################ | ||
40 | +## ## | ||
41 | +## Copyright (c) International Business Machines Corp., 2007 ## | ||
42 | +## ## | ||
43 | +## This program is free software; you can redistribute it and#or modify ## | ||
44 | +## it under the terms of the GNU General Public License as published by ## | ||
45 | +## the Free Software Foundation; either version 2 of the License, or ## | ||
46 | +## (at your option) any later version. ## | ||
47 | +## ## | ||
48 | +## This program is distributed in the hope that it will be useful, but ## | ||
49 | +## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ## | ||
50 | +## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ## | ||
51 | +## for more details. ## | ||
52 | +## ## | ||
53 | +## You should have received a copy of the GNU General Public License ## | ||
54 | +## along with this program; if not, write to the Free Software ## | ||
55 | +## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ## | ||
56 | +## ## | ||
57 | +################################################################################ | ||
58 | + | ||
59 | +exit_code=0 | ||
60 | +echo "sysvipc tests" | ||
61 | +for type in none clone unshare; do | ||
62 | + echo "**sysvipc $type" | ||
63 | + ./shmnstest_noltp $type | ||
64 | + if [ $? -ne 0 ]; then | ||
65 | + exit_code=$? | ||
66 | + fi | ||
67 | +done | ||
68 | +exit $exit_code | ||
69 | diff --git a/testcases/kernel/containers/sysvipc/runtests_noltp.sh b/testcases/kernel/containers/sysvipc/runtests_noltp.sh | ||
70 | deleted file mode 100644 | ||
71 | index 84f398f..0000000 | ||
72 | --- a/testcases/kernel/containers/sysvipc/runtests_noltp.sh | ||
73 | +++ /dev/null | ||
74 | @@ -1,31 +0,0 @@ | ||
75 | -#!/bin/sh | ||
76 | -################################################################################ | ||
77 | -## ## | ||
78 | -## Copyright (c) International Business Machines Corp., 2007 ## | ||
79 | -## ## | ||
80 | -## This program is free software; you can redistribute it and#or modify ## | ||
81 | -## it under the terms of the GNU General Public License as published by ## | ||
82 | -## the Free Software Foundation; either version 2 of the License, or ## | ||
83 | -## (at your option) any later version. ## | ||
84 | -## ## | ||
85 | -## This program is distributed in the hope that it will be useful, but ## | ||
86 | -## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ## | ||
87 | -## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ## | ||
88 | -## for more details. ## | ||
89 | -## ## | ||
90 | -## You should have received a copy of the GNU General Public License ## | ||
91 | -## along with this program; if not, write to the Free Software ## | ||
92 | -## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ## | ||
93 | -## ## | ||
94 | -################################################################################ | ||
95 | - | ||
96 | -exit_code=0 | ||
97 | -echo "sysvipc tests" | ||
98 | -for type in none clone unshare; do | ||
99 | - echo "**sysvipc $type" | ||
100 | - ./shmnstest_noltp $type | ||
101 | - if [ $? -ne 0 ]; then | ||
102 | - exit_code=$? | ||
103 | - fi | ||
104 | -done | ||
105 | -exit $exit_code | ||
106 | diff --git a/testcases/kernel/containers/utsname/runtests_noltp.sh b/testcases/kernel/containers/utsname/runtests_noltp.sh | ||
107 | deleted file mode 100755 | ||
108 | index 43cb7e2..0000000 | ||
109 | --- a/testcases/kernel/containers/utsname/runtests_noltp.sh | ||
110 | +++ /dev/null | ||
111 | @@ -1,41 +0,0 @@ | ||
112 | -#!/bin/sh | ||
113 | -################################################################################ | ||
114 | -## ## | ||
115 | -## Copyright (c) International Business Machines Corp., 2007 ## | ||
116 | -## ## | ||
117 | -## This program is free software; you can redistribute it and#or modify ## | ||
118 | -## it under the terms of the GNU General Public License as published by ## | ||
119 | -## the Free Software Foundation; either version 2 of the License, or ## | ||
120 | -## (at your option) any later version. ## | ||
121 | -## ## | ||
122 | -## This program is distributed in the hope that it will be useful, but ## | ||
123 | -## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ## | ||
124 | -## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ## | ||
125 | -## for more details. ## | ||
126 | -## ## | ||
127 | -## You should have received a copy of the GNU General Public License ## | ||
128 | -## along with this program; if not, write to the Free Software ## | ||
129 | -## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ## | ||
130 | -## ## | ||
131 | -################################################################################ | ||
132 | - | ||
133 | -oldhostname=`hostname` | ||
134 | -exit_code=0 | ||
135 | -echo "unshare tests" | ||
136 | -for i in `seq 1 5`; do | ||
137 | - echo "test $i (unshare)" | ||
138 | - ./utstest_noltp unshare $i | ||
139 | - if [ $? -ne 0 ]; then | ||
140 | - exit_code=$? | ||
141 | - fi | ||
142 | -done | ||
143 | -echo "clone tests" | ||
144 | -for i in `seq 1 5`; do | ||
145 | - echo "test $i (clone)" | ||
146 | - ./utstest_noltp clone $i | ||
147 | - if [ $? -ne 0 ]; then | ||
148 | - exit_code=$? | ||
149 | - fi | ||
150 | -done | ||
151 | -hostname "$oldhostname" | ||
152 | -exit $exit_code | ||
153 | diff --git a/testcases/kernel/containers/utsname/runutstests_noltp.sh b/testcases/kernel/containers/utsname/runutstests_noltp.sh | ||
154 | new file mode 100755 | ||
155 | index 0000000..43cb7e2 | ||
156 | --- /dev/null | ||
157 | +++ b/testcases/kernel/containers/utsname/runutstests_noltp.sh | ||
158 | @@ -0,0 +1,41 @@ | ||
159 | +#!/bin/sh | ||
160 | +################################################################################ | ||
161 | +## ## | ||
162 | +## Copyright (c) International Business Machines Corp., 2007 ## | ||
163 | +## ## | ||
164 | +## This program is free software; you can redistribute it and#or modify ## | ||
165 | +## it under the terms of the GNU General Public License as published by ## | ||
166 | +## the Free Software Foundation; either version 2 of the License, or ## | ||
167 | +## (at your option) any later version. ## | ||
168 | +## ## | ||
169 | +## This program is distributed in the hope that it will be useful, but ## | ||
170 | +## WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY ## | ||
171 | +## or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License ## | ||
172 | +## for more details. ## | ||
173 | +## ## | ||
174 | +## You should have received a copy of the GNU General Public License ## | ||
175 | +## along with this program; if not, write to the Free Software ## | ||
176 | +## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA ## | ||
177 | +## ## | ||
178 | +################################################################################ | ||
179 | + | ||
180 | +oldhostname=`hostname` | ||
181 | +exit_code=0 | ||
182 | +echo "unshare tests" | ||
183 | +for i in `seq 1 5`; do | ||
184 | + echo "test $i (unshare)" | ||
185 | + ./utstest_noltp unshare $i | ||
186 | + if [ $? -ne 0 ]; then | ||
187 | + exit_code=$? | ||
188 | + fi | ||
189 | +done | ||
190 | +echo "clone tests" | ||
191 | +for i in `seq 1 5`; do | ||
192 | + echo "test $i (clone)" | ||
193 | + ./utstest_noltp clone $i | ||
194 | + if [ $? -ne 0 ]; then | ||
195 | + exit_code=$? | ||
196 | + fi | ||
197 | +done | ||
198 | +hostname "$oldhostname" | ||
199 | +exit $exit_code | ||
200 | -- | ||
201 | 1.8.4.3 | ||
202 | |||
diff --git a/recipes-extended/ltp/ltp/ltp-Do-not-link-against-libfl.patch b/recipes-extended/ltp/ltp/ltp-Do-not-link-against-libfl.patch new file mode 100644 index 0000000..3e4aa73 --- /dev/null +++ b/recipes-extended/ltp/ltp/ltp-Do-not-link-against-libfl.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 5bda9c0af56869c6ff2c25d38ea087179c946bc6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chong Lu <Chong.Lu@windriver.com> | ||
3 | Date: Tue, 11 Mar 2014 14:47:22 +0800 | ||
4 | Subject: [PATCH] ltp: Don't link against libfl | ||
5 | |||
6 | We have already defined yywrap function in scan.l file. After this, we no longer need to | ||
7 | link against libfl and so no longer get errors about undefined references to yylex. | ||
8 | |||
9 | Upstream-status: Pending | ||
10 | |||
11 | Signed-off-by: Chong Lu <Chong.Lu@windriver.com> | ||
12 | --- | ||
13 | pan/Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/pan/Makefile b/pan/Makefile | ||
17 | index 4cc6466..a4b575b 100644 | ||
18 | --- a/pan/Makefile | ||
19 | +++ b/pan/Makefile | ||
20 | @@ -31,7 +31,7 @@ CPPFLAGS += -Wno-error | ||
21 | |||
22 | CPPFLAGS += -I$(abs_srcdir) | ||
23 | |||
24 | -LDLIBS += -lm $(LEXLIB) | ||
25 | +LDLIBS += -lm | ||
26 | |||
27 | LFLAGS += -l | ||
28 | |||
29 | -- | ||
30 | 1.7.9.5 | ||
31 | |||
diff --git a/recipes-extended/ltp/ltp/regen-makefile.patch b/recipes-extended/ltp/ltp/regen-makefile.patch new file mode 100644 index 0000000..3e114a1 --- /dev/null +++ b/recipes-extended/ltp/ltp/regen-makefile.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | Fix the dependencies for linux_syscall_numbers.h where in a parallel build it was | ||
2 | finding the temporary file linux_syscall_numbers.h.[pid].sh (where sh is an | ||
3 | architecture name). Instead don't wildcard *.sh as the only .sh we care about | ||
4 | here is regen.sh, so hard-code that. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
8 | |||
9 | diff --git a/testcases/kernel/include/Makefile b/testcases/kernel/include/Makefile | ||
10 | index db21a2a..585eb5e 100644 | ||
11 | --- a/testcases/kernel/include/Makefile | ||
12 | +++ b/testcases/kernel/include/Makefile | ||
13 | @@ -28,7 +28,7 @@ INSTALL_DIR := $(includedir) | ||
14 | |||
15 | MAKE_TARGETS := linux_syscall_numbers.h | ||
16 | |||
17 | -linux_syscall_numbers.h: $(wildcard $(abs_srcdir)/*.sh $(abs_srcdir)/*.in) | ||
18 | - $(SHELL) "$(abs_srcdir)/regen.sh" | ||
19 | +linux_syscall_numbers.h: $(abs_srcdir)/regen.sh $(wildcard $(abs_srcdir)/*.in) | ||
20 | + $(SHELL) "$<" | ||
21 | |||
22 | include $(top_srcdir)/include/mk/generic_leaf_target.mk | ||
diff --git a/recipes-extended/ltp/ltp_20140508.bb b/recipes-extended/ltp/ltp_20140508.bb new file mode 100644 index 0000000..29057b6 --- /dev/null +++ b/recipes-extended/ltp/ltp_20140508.bb | |||
@@ -0,0 +1,82 @@ | |||
1 | SUMMARY = "Linux Test Project" | ||
2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." | ||
3 | HOMEPAGE = "http://ltp.sourceforge.net" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
8 | file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
9 | file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \ | ||
10 | file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
11 | file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
12 | file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \ | ||
13 | file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ | ||
14 | file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \ | ||
15 | file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \ | ||
16 | file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \ | ||
17 | file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
18 | file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
19 | file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \ | ||
20 | " | ||
21 | |||
22 | DEPENDS = "attr libaio libcap acl openssl" | ||
23 | SRCREV = "b0ffb8d6ec835c6d49c2c52f802f274818e8ba7c" | ||
24 | |||
25 | SRC_URI = "gitsm://git.enea.se/personal/mlil/ltp;branch=mlil_nohz_v3_rebased \ | ||
26 | " | ||
27 | |||
28 | S = "${WORKDIR}/git" | ||
29 | |||
30 | PR="r26" | ||
31 | |||
32 | inherit autotools-brokensep | ||
33 | |||
34 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
35 | |||
36 | export prefix = "/opt/ltp" | ||
37 | export exec_prefix = "/opt/ltp" | ||
38 | |||
39 | # ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call. | ||
40 | # we explicitly force regeneration of that directory and pass configure options. | ||
41 | do_configure_append() { | ||
42 | (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS}) | ||
43 | } | ||
44 | |||
45 | # The makefiles make excessive use of make -C and several include testcases.mk | ||
46 | # which triggers a build of the syscall header. To reproduce, build ltp, | ||
47 | # then delete the header, then "make -j XX" and watch regen.sh run multiple | ||
48 | # times. Its easier to generate this once here instead. | ||
49 | do_compile_prepend () { | ||
50 | ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h ) | ||
51 | } | ||
52 | |||
53 | do_install(){ | ||
54 | install -d ${D}/opt/ltp/ | ||
55 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install | ||
56 | |||
57 | # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual | ||
58 | cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases | ||
59 | |||
60 | # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core | ||
61 | # We will add expect for enhancement in future | ||
62 | find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f | ||
63 | } | ||
64 | |||
65 | RDEPENDS_${PN} = "perl e2fsprogs-mke2fs packagegroup-enea-rt-tools" | ||
66 | |||
67 | FILES_${PN}-dbg += "\ | ||
68 | /opt/ltp/runtest/.debug \ | ||
69 | /opt/ltp/testcases/bin/.debug \ | ||
70 | /opt/ltp/testcases/bin/*/bin/.debug \ | ||
71 | /opt/ltp/testcases/bin/*/test/.debug \ | ||
72 | /opt/ltp/scenario_groups/.debug \ | ||
73 | /opt/ltp/testscripts/.debug \ | ||
74 | /opt/ltp/testscripts/open_posix_testsuite/.debug \ | ||
75 | " | ||
76 | |||
77 | FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a" | ||
78 | |||
79 | FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*" | ||
80 | |||
81 | # Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails | ||
82 | INHIBIT_PACKAGE_STRIP = "1" | ||