summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2025-01-07 14:43:16 -0300
committerDaiane Angolini <daiane.angolini@foundries.io>2025-01-07 14:43:16 -0300
commit13f58ee622648bad264d25d58cf8a33ec4c8cedd (patch)
tree2c9ce02475878084812d380503600ab7fa513e7d
parent8cc3bb0ff75e38becfd0a9eced0b7dc22cb3f86c (diff)
downloadmeta-freescale-bump-linux-fslc-imx-2.2.0.tar.gz
linux-fslc-imx: Use 6.6-2.2.0.x from NXP BSP LF6.6.52_2.2.0bump-linux-fslc-imx-2.2.0
It also updates the stable kernel tags up to version v6.6.69, and include some LmP commits Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb27
1 files changed, 16 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index ed19bc8b..b926b4ff 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -38,14 +38,19 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41 41# The list includes well-known commits not yet upstreamed. Reverts address merge
42# $ git log --oneline --no-merges v6.6.34.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y 42# conflicts, prioritizing NXP BSP source code as the latest vendor updates.
43# - a10c64e35a24 tty: vt: conmakehash: cope with abs_srctree no longer in env 43# Additional commits may exist to better acommodate yocto builds.
44# - 3fb57e773e55 tty: vt: conmakehash: Don't mention the full path of the input in output 44#
45# - d1198b88bc1b Revert "dmaengine: fsl-edma: add address for channel mux register in fsl_edma_chan" 45# $ git log --oneline --no-merges v6.6.52.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y
46# - 717fee4a9cf7 Revert "dmaengine: fsl-edma: add i.MX8ULP edma support" 46# - 090d101928fc tty: vt: conmakehash: Don't mention the full path of the input in output
47# - 74ef72069927 Revert "dmaengine: fsl-edma: clean up unused "fsl,imx8qm-adma" compatible string" 47# - d16eb5ced32f arm64: dts: imx8mm-evk-qca-wifi: enable support for bluetooth
48# - b54c6ea17058 Revert "dmaengine: fsl-edma: change the memory access from local into remote mode in i.MX 8QM" 48# - d39502c0dea9 imx:dts:imx8mm-evkb: fix the pmic name to avoid duplicated label error
49# - 58181fb0ff67 media: imx8: select v4l2_* for mxc-mipi-csi2_yav
50# - 930431e0d1d5 gpu: drm: cadence: select hdmi helper
51# - da675fd29502 of: enable using OF_DYNAMIC without OF_UNITTEST
52# - 7c5f3cbb180c arm64: dts: imx8mq: drop cpu-idle-states
53# - a9920ce3e197 hwrng: optee: support generic crypto
49# 54#
50# NOTE to upgraders: 55# NOTE to upgraders:
51# This recipe should NOT collect individual patches, they should be applied to 56# This recipe should NOT collect individual patches, they should be applied to
@@ -55,16 +60,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
55 60
56require linux-imx.inc 61require linux-imx.inc
57 62
58KBRANCH = "6.6-2.1.x-imx" 63KBRANCH = "6.6-2.2.x-imx"
59SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 64SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
60SRCREV = "6605f549a71ef3af9c65609cba985086ac4edf2b" 65SRCREV = "113a097d3614e3dce802828ae439be23c5e4c931"
61 66
62# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 67# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
63# required by kernel-yocto.bbclass. 68# required by kernel-yocto.bbclass.
64# 69#
65# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 70# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
66# should be updated once patchlevel is merged. 71# should be updated once patchlevel is merged.
67LINUX_VERSION = "6.6.54" 72LINUX_VERSION = "6.6.69"
68 73
69KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 74KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
70KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 75KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"