diff options
author | Flora Hu <flora.hu@nxp.com> | 2024-11-04 16:56:19 +0800 |
---|---|---|
committer | Flora Hu <flora.hu@nxp.com> | 2024-11-05 11:06:23 +0800 |
commit | 1e3e3eb90e58a652899c9e9a9c49cecccc586b9c (patch) | |
tree | 7157dcf2923c6c75f8afa016b199e1f04b92f534 | |
parent | 412acc27c60d325d43919e74d9124336931360be (diff) | |
download | meta-freescale-1e3e3eb90e58a652899c9e9a9c49cecccc586b9c.tar.gz |
secure-obj: Update to latest from NXP 6.6.36-2.1.0
- secure-obj: update license; update revision to 4706a65; make it compatible with OPTEE 3.17+
- secure-obj-module: update license; update revision to 4706a65
Signed-off-by: Flora Hu <flora.hu@nxp.com>
-rw-r--r-- | recipes-extended/secure-obj/secure-obj-module_git.bb | 2 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 4 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj_git.bb | 13 |
3 files changed, 11 insertions, 8 deletions
diff --git a/recipes-extended/secure-obj/secure-obj-module_git.bb b/recipes-extended/secure-obj/secure-obj-module_git.bb index 3866dde4..1e5709b6 100644 --- a/recipes-extended/secure-obj/secure-obj-module_git.bb +++ b/recipes-extended/secure-obj/secure-obj-module_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require secure-obj.inc | 1 | require secure-obj.inc |
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://../README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | 3 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
4 | 4 | ||
5 | DEPENDS += "virtual/kernel" | 5 | DEPENDS += "virtual/kernel" |
6 | 6 | ||
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc index 64e4a6b7..16115ff0 100644 --- a/recipes-extended/secure-obj/secure-obj.inc +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -1,5 +1,5 @@ | |||
1 | DESCRIPTION = "Secure Object" | 1 | DESCRIPTION = "Secure Object" |
2 | LICENSE = "BSD" | 2 | LICENSE = "BSD-3-Clause" |
3 | 3 | ||
4 | DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" | 4 | DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" |
5 | RDEPENDS:${PN} = "bash libcrypto libssl" | 5 | RDEPENDS:${PN} = "bash libcrypto libssl" |
@@ -11,7 +11,7 @@ inherit python3native | |||
11 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" | 11 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/nxp-qoriq/secure_obj;protocol=https;nobranch=1" | 13 | SRC_URI = "git://github.com/nxp-qoriq/secure_obj;protocol=https;nobranch=1" |
14 | SRCREV = "5ff1231f74b4b01744be95a3137a14ad0a483e61" | 14 | SRCREV = "4706a6534ec09f9a46bfe305c5e49badca32b4c6" |
15 | 15 | ||
16 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 16 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
17 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | 17 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" |
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb index 84ecea1e..64f59f47 100644 --- a/recipes-extended/secure-obj/secure-obj_git.bb +++ b/recipes-extended/secure-obj/secure-obj_git.bb | |||
@@ -1,9 +1,11 @@ | |||
1 | require secure-obj.inc | 1 | require secure-obj.inc |
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
4 | 4 | ||
5 | S = "${WORKDIR}/git" | 5 | S = "${WORKDIR}/git" |
6 | 6 | ||
7 | DEPENDS:remove = " python3-pycryptodomex-native" | ||
8 | DEPENDS:append = " python3-cryptography-native optee-os-qoriq-tadevkit" | ||
7 | RDEPENDS:{PN} += "secure-obj-module" | 9 | RDEPENDS:{PN} += "secure-obj-module" |
8 | 10 | ||
9 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 11 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
@@ -17,14 +19,15 @@ CFLAGS += "${TOOLCHAIN_OPTIONS}" | |||
17 | 19 | ||
18 | do_compile() { | 20 | do_compile() { |
19 | unset LDFLAGS | 21 | unset LDFLAGS |
20 | export TA_DEV_KIT_DIR="${RECIPE_SYSROOT}/usr/include/optee/export-user_ta" | 22 | export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta/ |
21 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" | 23 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" |
22 | export OPENSSL_PATH="${RECIPE_SYSROOT}/usr" | 24 | export OPENSSL_PATH="${RECIPE_SYSROOT}/usr" |
23 | for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do | 25 | export OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules |
26 | for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do | ||
24 | cd ${APP} | 27 | cd ${APP} |
25 | oe_runmake | 28 | oe_runmake |
26 | cd .. | 29 | cd .. |
27 | done | 30 | done |
28 | } | 31 | } |
29 | 32 | ||
30 | do_install() { | 33 | do_install() { |