diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-22 13:25:43 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-22 13:25:43 -0700 |
commit | 365e9110b9ee938259c306e66a07cac4e2ddc3c0 (patch) | |
tree | 27c84624fad1372bed39effccb52c267b97f13d9 | |
parent | 23ceaa0ecd56b41e3edb44ed0c7216829f7613ad (diff) | |
download | meta-freescale-365e9110b9ee938259c306e66a07cac4e2ddc3c0.tar.gz |
recipes: Switch WORKDIR use with UNPACKDIR
This is being enforced in master oe-core
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb | 2 | ||||
-rw-r--r-- | recipes-core/udev/udev-rules-qoriq.bb | 3 | ||||
-rw-r--r-- | recipes-devtools/uuu/uuu-bin_1.5.165.bb | 8 | ||||
-rw-r--r-- | recipes-extended/merge-files/merge-files_1.0.bb | 5 | ||||
-rw-r--r-- | recipes-extended/testfloat/testfloat_2a.bb | 2 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | 4 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 4 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_10.0.5.imx.bb | 8 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_12.0.3.imx.bb | 8 | ||||
-rw-r--r-- | recipes-multimedia/pulseaudio/pulseaudio_%.bbappend | 6 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-client-fslc.inc | 4 | ||||
-rw-r--r-- | recipes-security/optee-qoriq/optee-client.nxp.inc | 2 |
14 files changed, 30 insertions, 34 deletions
diff --git a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend index f64637bd..7cb6c07a 100644 --- a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend +++ b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend | |||
@@ -4,6 +4,6 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" | |||
4 | SRC_URI:append:qoriq-ppc = " file://qemu.conf" | 4 | SRC_URI:append:qoriq-ppc = " file://qemu.conf" |
5 | 5 | ||
6 | do_install:append:qoriq-ppc() { | 6 | do_install:append:qoriq-ppc() { |
7 | install -m 0644 ${WORKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf | 7 | install -m 0644 ${UNPACKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf |
8 | } | 8 | } |
9 | 9 | ||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 930cdf94..ae3dc469 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -73,11 +73,11 @@ do_install() { | |||
73 | PLATFORM=${PLATFORM} \ | 73 | PLATFORM=${PLATFORM} \ |
74 | install | 74 | install |
75 | 75 | ||
76 | if [ -e ${WORKDIR}/clocks.sh ]; then | 76 | if [ -e ${UNPACKDIR}/clocks.sh ]; then |
77 | install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh | 77 | install -m 755 ${UNPACKDIR}/clocks.sh ${D}/unit_tests/clocks.sh |
78 | fi | 78 | fi |
79 | install -d -m 0755 ${D}${ROOT_HOME}/ | 79 | install -d -m 0755 ${D}${ROOT_HOME}/ |
80 | install -m 0644 ${WORKDIR}/memtool_profile ${D}${ROOT_HOME}/.profile | 80 | install -m 0644 ${UNPACKDIR}/memtool_profile ${D}${ROOT_HOME}/.profile |
81 | } | 81 | } |
82 | 82 | ||
83 | FILES:${PN} += "/unit_tests ${ROOT_HOME}/.profile" | 83 | FILES:${PN} += "/unit_tests ${ROOT_HOME}/.profile" |
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb index b160c31d..4723146e 100644 --- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb +++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb | |||
@@ -82,7 +82,7 @@ PACKAGECONFIG[dma-heap-uncached] = "--with-dma-heap-allocator=yes ${UNCACHED_DMA | |||
82 | # Using do_install_ptest_base instead of do_install_ptest, since | 82 | # Using do_install_ptest_base instead of do_install_ptest, since |
83 | # the default do_install_ptest_base is hardcoded to expect Makefiles. | 83 | # the default do_install_ptest_base is hardcoded to expect Makefiles. |
84 | do_install_ptest_base() { | 84 | do_install_ptest_base() { |
85 | install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest | 85 | install -D ${UNPACKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest |
86 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} | 86 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} |
87 | } | 87 | } |
88 | 88 | ||
diff --git a/recipes-core/udev/udev-rules-qoriq.bb b/recipes-core/udev/udev-rules-qoriq.bb index 1200527c..792c3234 100644 --- a/recipes-core/udev/udev-rules-qoriq.bb +++ b/recipes-core/udev/udev-rules-qoriq.bb | |||
@@ -9,7 +9,6 @@ SRC_URI = "\ | |||
9 | file://74-ls1046a-xfi2-networking.rules \ | 9 | file://74-ls1046a-xfi2-networking.rules \ |
10 | file://73-fsl-enetc-networking.rules \ | 10 | file://73-fsl-enetc-networking.rules \ |
11 | " | 11 | " |
12 | S = "${WORKDIR}" | ||
13 | 12 | ||
14 | RULE = "71-fsl-dpaa-persistent-networking.rules" | 13 | RULE = "71-fsl-dpaa-persistent-networking.rules" |
15 | RULE:e6500 = "72-fsl-dpaa-persistent-networking.rules" | 14 | RULE:e6500 = "72-fsl-dpaa-persistent-networking.rules" |
@@ -26,7 +25,7 @@ RULE:ls1012a = "" | |||
26 | do_install () { | 25 | do_install () { |
27 | install -d ${D}${sysconfdir}/udev/rules.d/ | 26 | install -d ${D}${sysconfdir}/udev/rules.d/ |
28 | for r in ${RULE};do | 27 | for r in ${RULE};do |
29 | install -m 0644 ${WORKDIR}/${r} ${D}${sysconfdir}/udev/rules.d/ | 28 | install -m 0644 ${UNPACKDIR}/${r} ${D}${sysconfdir}/udev/rules.d/ |
30 | done | 29 | done |
31 | } | 30 | } |
32 | 31 | ||
diff --git a/recipes-devtools/uuu/uuu-bin_1.5.165.bb b/recipes-devtools/uuu/uuu-bin_1.5.165.bb index 2b5feda1..61c3927c 100644 --- a/recipes-devtools/uuu/uuu-bin_1.5.165.bb +++ b/recipes-devtools/uuu/uuu-bin_1.5.165.bb | |||
@@ -19,14 +19,12 @@ SRC_URI[Linux.sha256sum] = "f863bba022202361d19e5026be0af408d307f78d2dbf2c139fb7 | |||
19 | SRC_URI[Mac.sha256sum] = "62da0bd7e333931fba100823aa50133621c7e6047be0546bc12e29c0ea78a4d8" | 19 | SRC_URI[Mac.sha256sum] = "62da0bd7e333931fba100823aa50133621c7e6047be0546bc12e29c0ea78a4d8" |
20 | SRC_URI[Windows.sha256sum] = "013ed8bb45e21b971b6b3a5802c5f154733913714bece0b020cb770a809cd206" | 20 | SRC_URI[Windows.sha256sum] = "013ed8bb45e21b971b6b3a5802c5f154733913714bece0b020cb770a809cd206" |
21 | 21 | ||
22 | S = "${WORKDIR}" | ||
23 | |||
24 | inherit allarch | 22 | inherit allarch |
25 | 23 | ||
26 | do_install() { | 24 | do_install() { |
27 | install -D -m 0755 ${WORKDIR}/uuu-${PV} ${D}${libdir}/uuu/uuu | 25 | install -D -m 0755 ${UNPACKDIR}/uuu-${PV} ${D}${libdir}/uuu/uuu |
28 | install -D -m 0755 ${WORKDIR}/uuu-${PV}_mac ${D}${libdir}/uuu/uuu_mac | 26 | install -D -m 0755 ${UNPACKDIR}/uuu-${PV}_mac ${D}${libdir}/uuu/uuu_mac |
29 | install -D -m 0644 ${WORKDIR}/uuu-${PV}.exe ${D}${libdir}/uuu/uuu.exe | 27 | install -D -m 0644 ${UNPACKDIR}/uuu-${PV}.exe ${D}${libdir}/uuu/uuu.exe |
30 | } | 28 | } |
31 | 29 | ||
32 | # HACK! We are not aiming to run those binaries during the build but copy then for MFGTOOL bundle. | 30 | # HACK! We are not aiming to run those binaries during the build but copy then for MFGTOOL bundle. |
diff --git a/recipes-extended/merge-files/merge-files_1.0.bb b/recipes-extended/merge-files/merge-files_1.0.bb index 5b3ca7ed..bd788fdb 100644 --- a/recipes-extended/merge-files/merge-files_1.0.bb +++ b/recipes-extended/merge-files/merge-files_1.0.bb | |||
@@ -5,14 +5,13 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384 | |||
5 | inherit allarch | 5 | inherit allarch |
6 | 6 | ||
7 | SRC_URI = "file://merge" | 7 | SRC_URI = "file://merge" |
8 | S = "${WORKDIR}" | ||
9 | 8 | ||
10 | MERGED_DST ?= "${ROOT_HOME}" | 9 | MERGED_DST ?= "${ROOT_HOME}" |
11 | do_install () { | 10 | do_install () { |
12 | install -d ${D}/${MERGED_DST} | 11 | install -d ${D}/${MERGED_DST} |
13 | find ${WORKDIR}/merge/ -maxdepth 1 -mindepth 1 -not -name README \ | 12 | find ${UNPACKDIR}/merge/ -maxdepth 1 -mindepth 1 -not -name README \ |
14 | -exec cp -fr '{}' ${D}/${MERGED_DST}/ \; | 13 | -exec cp -fr '{}' ${D}/${MERGED_DST}/ \; |
15 | find ${WORKDIR}/merge/ -maxdepth 1 -mindepth 1 -exec rm -fr '{}' \; | 14 | find ${UNPACKDIR}/merge/ -maxdepth 1 -mindepth 1 -exec rm -fr '{}' \; |
16 | } | 15 | } |
17 | do_configure[noexec] = "1" | 16 | do_configure[noexec] = "1" |
18 | do_compile[noexec] = "1" | 17 | do_compile[noexec] = "1" |
diff --git a/recipes-extended/testfloat/testfloat_2a.bb b/recipes-extended/testfloat/testfloat_2a.bb index 4ed2ceb3..60e9b864 100644 --- a/recipes-extended/testfloat/testfloat_2a.bb +++ b/recipes-extended/testfloat/testfloat_2a.bb | |||
@@ -18,7 +18,7 @@ SRC_URI[SoftFloat.sha256sum] = "89d14b55113a2ba8cbda7011443ba1d298d381c89d939515 | |||
18 | S = "${WORKDIR}/TestFloat-2a" | 18 | S = "${WORKDIR}/TestFloat-2a" |
19 | 19 | ||
20 | do_unpack2(){ | 20 | do_unpack2(){ |
21 | mv ${WORKDIR}/SoftFloat-2b ${S}/SoftFloat-2b | 21 | mv ${UNPACKDIR}/SoftFloat-2b ${S}/SoftFloat-2b |
22 | cd ${S} | 22 | cd ${S} |
23 | if [ -n "$(which fromdos)" ];then | 23 | if [ -n "$(which fromdos)" ];then |
24 | find -type f -exec fromdos {} \; | 24 | find -type f -exec fromdos {} \; |
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb index 87d05365..658b28de 100644 --- a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb +++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | |||
@@ -17,13 +17,13 @@ do_install:use-mainline-bsp() { | |||
17 | 17 | ||
18 | # systemd | 18 | # systemd |
19 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 19 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
20 | install -D -m 644 ${WORKDIR}/mesa-etnaviv.conf \ | 20 | install -D -m 644 ${UNPACKDIR}/mesa-etnaviv.conf \ |
21 | ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf | 21 | ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf |
22 | fi | 22 | fi |
23 | 23 | ||
24 | # sysvinit | 24 | # sysvinit |
25 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then | 25 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
26 | install -D -m 644 ${WORKDIR}/mesa-etnaviv.sh \ | 26 | install -D -m 644 ${UNPACKDIR}/mesa-etnaviv.sh \ |
27 | ${D}${sysconfdir}/profile.d/mesa-etnaviv.sh | 27 | ${D}${sysconfdir}/profile.d/mesa-etnaviv.sh |
28 | fi | 28 | fi |
29 | } | 29 | } |
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index 9d04df23..07a4ea86 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -58,8 +58,8 @@ PACKAGECONFIG[use-g2d] = ",," | |||
58 | PACKAGECONFIG[xwayland] = ",," | 58 | PACKAGECONFIG[xwayland] = ",," |
59 | 59 | ||
60 | do_install:append() { | 60 | do_install:append() { |
61 | if [ -f "${WORKDIR}/weston.config" ]; then | 61 | if [ -f "${UNPACKDIR}/weston.config" ]; then |
62 | install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston | 62 | install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston |
63 | fi | 63 | fi |
64 | 64 | ||
65 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'gbm-format', 'yes', 'no', d)}" = "yes" ]; then | 65 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'gbm-format', 'yes', 'no', d)}" = "yes" ]; then |
diff --git a/recipes-graphics/wayland/weston_10.0.5.imx.bb b/recipes-graphics/wayland/weston_10.0.5.imx.bb index 99624887..df2898f0 100644 --- a/recipes-graphics/wayland/weston_10.0.5.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.5.imx.bb | |||
@@ -109,18 +109,18 @@ do_install:append() { | |||
109 | # If X11, ship a desktop file to launch it | 109 | # If X11, ship a desktop file to launch it |
110 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then | 110 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then |
111 | install -d ${D}${datadir}/applications | 111 | install -d ${D}${datadir}/applications |
112 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | 112 | install ${UNPACKDIR}/weston.desktop ${D}${datadir}/applications |
113 | 113 | ||
114 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | 114 | install -d ${D}${datadir}/icons/hicolor/48x48/apps |
115 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | 115 | install ${UNPACKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps |
116 | fi | 116 | fi |
117 | 117 | ||
118 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | 118 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then |
119 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | 119 | install -Dm 644 ${UNPACKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland |
120 | fi | 120 | fi |
121 | 121 | ||
122 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then | 122 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then |
123 | install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify | 123 | install -Dm 644 ${UNPACKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify |
124 | fi | 124 | fi |
125 | 125 | ||
126 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then | 126 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then |
diff --git a/recipes-graphics/wayland/weston_12.0.3.imx.bb b/recipes-graphics/wayland/weston_12.0.3.imx.bb index 8114ddbb..14b79f18 100644 --- a/recipes-graphics/wayland/weston_12.0.3.imx.bb +++ b/recipes-graphics/wayland/weston_12.0.3.imx.bb | |||
@@ -116,18 +116,18 @@ do_install:append() { | |||
116 | # If X11, ship a desktop file to launch it | 116 | # If X11, ship a desktop file to launch it |
117 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then | 117 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then |
118 | install -d ${D}${datadir}/applications | 118 | install -d ${D}${datadir}/applications |
119 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | 119 | install ${UNPACKDIR}/weston.desktop ${D}${datadir}/applications |
120 | 120 | ||
121 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | 121 | install -d ${D}${datadir}/icons/hicolor/48x48/apps |
122 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | 122 | install ${UNPACKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps |
123 | fi | 123 | fi |
124 | 124 | ||
125 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | 125 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then |
126 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | 126 | install -Dm 644 ${UNPACKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland |
127 | fi | 127 | fi |
128 | 128 | ||
129 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then | 129 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then |
130 | install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify | 130 | install -Dm 644 ${UNPACKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify |
131 | fi | 131 | fi |
132 | 132 | ||
133 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then | 133 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then |
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend index 93f71e8f..6e4db911 100644 --- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend +++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend | |||
@@ -17,9 +17,9 @@ SRC_URI_IMX:mx9-nxp-bsp = " \ | |||
17 | CACHED_CONFIGUREVARS:append:mx6-nxp-bsp = " ax_cv_PTHREAD_PRIO_INHERIT=no" | 17 | CACHED_CONFIGUREVARS:append:mx6-nxp-bsp = " ax_cv_PTHREAD_PRIO_INHERIT=no" |
18 | 18 | ||
19 | do_install:append() { | 19 | do_install:append() { |
20 | if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then | 20 | if [ -e "${UNPACKDIR}/daemon.conf" ] && [ -e "${UNPACKDIR}/default.pa" ]; then |
21 | install -m 0644 ${WORKDIR}/daemon.conf ${D}${sysconfdir}/pulse/daemon.conf | 21 | install -m 0644 ${UNPACKDIR}/daemon.conf ${D}${sysconfdir}/pulse/daemon.conf |
22 | install -m 0644 ${WORKDIR}/default.pa ${D}${sysconfdir}/pulse/default.pa | 22 | install -m 0644 ${UNPACKDIR}/default.pa ${D}${sysconfdir}/pulse/default.pa |
23 | fi | 23 | fi |
24 | } | 24 | } |
25 | 25 | ||
diff --git a/recipes-security/optee-imx/optee-client-fslc.inc b/recipes-security/optee-imx/optee-client-fslc.inc index 92f9f1d1..b9e91f97 100644 --- a/recipes-security/optee-imx/optee-client-fslc.inc +++ b/recipes-security/optee-imx/optee-client-fslc.inc | |||
@@ -37,6 +37,6 @@ do_install () { | |||
37 | 37 | ||
38 | cp -a ${B}/export/usr/include ${D}${includedir} | 38 | cp -a ${B}/export/usr/include ${D}${includedir} |
39 | 39 | ||
40 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${WORKDIR}/tee-supplicant.service | 40 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${UNPACKDIR}/tee-supplicant.service |
41 | install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service | 41 | install -D -p -m0644 ${UNPACKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service |
42 | } | 42 | } |
diff --git a/recipes-security/optee-qoriq/optee-client.nxp.inc b/recipes-security/optee-qoriq/optee-client.nxp.inc index a7d34497..c3933a24 100644 --- a/recipes-security/optee-qoriq/optee-client.nxp.inc +++ b/recipes-security/optee-qoriq/optee-client.nxp.inc | |||
@@ -41,7 +41,7 @@ do_install () { | |||
41 | cp -a ${B}/export/usr/include ${D}${includedir} | 41 | cp -a ${B}/export/usr/include ${D}${includedir} |
42 | 42 | ||
43 | install -d ${D}${systemd_system_unitdir}/ | 43 | install -d ${D}${systemd_system_unitdir}/ |
44 | install -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/ | 44 | install -m0644 ${UNPACKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/ |
45 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${D}${systemd_system_unitdir}/tee-supplicant.service | 45 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${D}${systemd_system_unitdir}/tee-supplicant.service |
46 | } | 46 | } |
47 | 47 | ||