diff options
author | Hiago De Franco <hiago.franco@toradex.com> | 2025-03-24 13:26:09 -0300 |
---|---|---|
committer | Hiago De Franco <hiago.franco@toradex.com> | 2025-03-24 13:57:11 -0300 |
commit | 7cf349d287a9d6eece4320cf487fc804917c2077 (patch) | |
tree | fa22629a718ea8c843b080729265dff3b9786b65 | |
parent | 5c73b6f49ff91a30ab1e1355a6c96fc385a5349b (diff) | |
download | meta-freescale-7cf349d287a9d6eece4320cf487fc804917c2077.tar.gz |
imx-oei: provide virtual/imx-oei
Some hardware vendors provide a customized Optional Executable Image
(OEI) with changes specific to their boards (e.g. Toradex SMARC i.MX95).
Add a virtual provider to avoid conflicts between the OEI recipes from
other layers. This follows the pattern used for the related
imx-system-manager.
Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
-rw-r--r-- | conf/machine/include/imx-base.inc | 3 | ||||
-rw-r--r-- | dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 2 |
3 files changed, 5 insertions, 2 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 5c79a8c1..280d7ca5 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -414,7 +414,8 @@ IMX_EXTRA_FIRMWARE:mx8ulp-generic-bsp = "firmware-upower firmware-ele-imx" | |||
414 | IMX_EXTRA_FIRMWARE:mx91-generic-bsp = "imx-boot-firmware-files firmware-ele-imx" | 414 | IMX_EXTRA_FIRMWARE:mx91-generic-bsp = "imx-boot-firmware-files firmware-ele-imx" |
415 | IMX_EXTRA_FIRMWARE:mx93-generic-bsp = "imx-boot-firmware-files firmware-ele-imx" | 415 | IMX_EXTRA_FIRMWARE:mx93-generic-bsp = "imx-boot-firmware-files firmware-ele-imx" |
416 | PREFERRED_PROVIDER_virtual/imx-system-manager ??= "imx-system-manager" | 416 | PREFERRED_PROVIDER_virtual/imx-system-manager ??= "imx-system-manager" |
417 | IMX_EXTRA_FIRMWARE:mx95-generic-bsp = "imx-boot-firmware-files firmware-ele-imx virtual/imx-system-manager imx-oei" | 417 | PREFERRED_PROVIDER_virtual/imx-oei ??= "imx-oei" |
418 | IMX_EXTRA_FIRMWARE:mx95-generic-bsp = "imx-boot-firmware-files firmware-ele-imx virtual/imx-system-manager virtual/imx-oei" | ||
418 | 419 | ||
419 | # Firmware | 420 | # Firmware |
420 | MACHINE_FIRMWARE ?= "" | 421 | MACHINE_FIRMWARE ?= "" |
diff --git a/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb index b10bd869..d0713875 100644 --- a/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb +++ b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb | |||
@@ -56,4 +56,6 @@ do_deploy() { | |||
56 | FILES:${PN} = "/firmware" | 56 | FILES:${PN} = "/firmware" |
57 | SYSROOT_DIRS += "/firmware" | 57 | SYSROOT_DIRS += "/firmware" |
58 | 58 | ||
59 | PROVIDES += "virtual/imx-oei" | ||
60 | |||
59 | COMPATIBLE_MACHINE = "(mx95-generic-bsp)" | 61 | COMPATIBLE_MACHINE = "(mx95-generic-bsp)" |
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index 63857fa6..9d20aff3 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -38,7 +38,7 @@ do_compile[depends] += " \ | |||
38 | 38 | ||
39 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" | 39 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" |
40 | 40 | ||
41 | OEI_ENABLE = "${@bb.utils.contains('DEPENDS', 'imx-oei', 'YES', 'NO', d)}" | 41 | OEI_ENABLE = "${@bb.utils.contains('DEPENDS', 'virtual/imx-oei', 'YES', 'NO', d)}" |
42 | OEI_NAME ?= "oei-${OEI_CORE}-*.bin" | 42 | OEI_NAME ?= "oei-${OEI_CORE}-*.bin" |
43 | 43 | ||
44 | ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin" | 44 | ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin" |