diff options
author | Zelan Zou <zelan.zou@nxp.com> | 2025-01-06 07:48:13 +0100 |
---|---|---|
committer | Zelan Zou <zelan.zou@nxp.com> | 2025-02-08 07:45:21 +0100 |
commit | 947b3eb4c91c4ca63bc6be9293ab8909ce82a9f0 (patch) | |
tree | 826199cd4da733351324f5cf547192fd9d2ec676 | |
parent | 954f33d03b5cf3b75ad436666e27724c587aa292 (diff) | |
download | meta-freescale-947b3eb4c91c4ca63bc6be9293ab8909ce82a9f0.tar.gz |
imx-vpuwrap: Update to L6.6.52_2.2.0 release
Signed-off-by: Zelan Zou <zelan.zou@nxp.com>
3 files changed, 2 insertions, 64 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_VCencoder-add-sys-time.h-for-gett.patch b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_VCencoder-add-sys-time.h-for-gett.patch deleted file mode 100644 index ab8b50de..00000000 --- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_VCencoder-add-sys-time.h-for-gett.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From a57daf8f58cf69be06de8ebc9eab3a3077143760 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hiago De Franco <hiago.franco@toradex.com> | ||
3 | Date: Fri, 26 Jul 2024 14:43:55 -0300 | ||
4 | Subject: [PATCH] vpu_wrapper_hantro_VCencoder: add sys/time.h for gettimeofday | ||
5 | |||
6 | Fixes: | ||
7 | | ../git/vpu_wrapper_hantro_VCencoder.c:1965:5: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration] | ||
8 | | 1965 | gettimeofday (&pObj->tvBegin, NULL); | ||
9 | | | ^~~~~~~~~~~~ | ||
10 | |||
11 | Upstream-Status: Submitted [https://github.com/nxp-imx/imx-vpuwrap/pull/2] | ||
12 | Signed-off-by: Hiago De Franco <hiago.franco@toradex.com> | ||
13 | --- | ||
14 | vpu_wrapper_hantro_VCencoder.c | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/vpu_wrapper_hantro_VCencoder.c b/vpu_wrapper_hantro_VCencoder.c | ||
18 | index efae31a77ca4..6185cfc067d1 100755 | ||
19 | --- a/vpu_wrapper_hantro_VCencoder.c | ||
20 | +++ b/vpu_wrapper_hantro_VCencoder.c | ||
21 | @@ -17,6 +17,7 @@ | ||
22 | #include <stdio.h> | ||
23 | #include <stdlib.h> | ||
24 | #include <string.h> | ||
25 | +#include <sys/time.h> | ||
26 | #include <time.h> | ||
27 | #include <math.h> | ||
28 | #include <fcntl.h> | ||
29 | -- | ||
30 | 2.39.2 | ||
31 | |||
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch deleted file mode 100644 index cbf37417..00000000 --- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 482c639a0da4b093cfc029009604e9653ced33c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Thu, 13 Jun 2024 07:15:12 +0000 | ||
4 | Subject: [PATCH] vpu_wrapper_hantro_encoder: add sys/time.h for gettimeofday | ||
5 | |||
6 | Fixes: | ||
7 | | ../git/vpu_wrapper_hantro_encoder.c:953:3: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration] | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
11 | --- | ||
12 | vpu_wrapper_hantro_encoder.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/vpu_wrapper_hantro_encoder.c b/vpu_wrapper_hantro_encoder.c | ||
16 | index 3819c389320c..635c98bf1f19 100755 | ||
17 | --- a/vpu_wrapper_hantro_encoder.c | ||
18 | +++ b/vpu_wrapper_hantro_encoder.c | ||
19 | @@ -24,6 +24,7 @@ | ||
20 | #include <stdlib.h> | ||
21 | #include <string.h> | ||
22 | #include <time.h> | ||
23 | +#include <sys/time.h> | ||
24 | #include <semaphore.h> | ||
25 | |||
26 | #include "headers/OMX_Video.h" | ||
27 | -- | ||
28 | 2.42.0 | ||
29 | |||
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb index 2b737999..86533c3c 100644 --- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb +++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb | |||
@@ -12,11 +12,9 @@ DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" | |||
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ | 14 | git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ |
15 | file://0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch \ | ||
16 | file://0001-vpu_wrapper_hantro_VCencoder-add-sys-time.h-for-gett.patch \ | ||
17 | " | 15 | " |
18 | SRCBRANCH = "MM_04.09.01_2408_L6.6.y" | 16 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" |
19 | SRCREV = "c13069d239cae314adc3651df25b96afa46cb434" | 17 | SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff" |
20 | 18 | ||
21 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
22 | 20 | ||