summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-09-28 12:04:24 -0300
committerGitHub <noreply@github.com>2024-09-28 12:04:24 -0300
commitcfabecce5662af7e71900882a45c093bb70619a5 (patch)
treebf83bb986f12458824db1aa42f860fd1695c792f
parentf869389a2a9d009587307dee95c917de3b911c24 (diff)
parent39d58dfc62163d8909b774d29ed8fbb17d25ccd4 (diff)
downloadmeta-freescale-cfabecce5662af7e71900882a45c093bb70619a5.tar.gz
Merge pull request #1954 from Livius90/master
[master] linux-fslc: 6.6.50 -> 6.11.0
-rw-r--r--recipes-kernel/linux/linux-fslc-lts_6.6.bb37
-rw-r--r--recipes-kernel/linux/linux-fslc_6.11.bb (renamed from recipes-kernel/linux/linux-fslc_6.6.bb)10
2 files changed, 44 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-lts_6.6.bb b/recipes-kernel/linux/linux-fslc-lts_6.6.bb
new file mode 100644
index 00000000..a8c91cdb
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-lts_6.6.bb
@@ -0,0 +1,37 @@
1# Copyright (C) 2012-2024 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "FSL Community BSP Linux LTS based kernel with backported features and fixes"
8DESCRIPTION = "Linux kernel based on LTS kernel used by FSL Community BSP in order to \
9provide support for some backported features and fixes, or because it was applied in upstream \
10and will not become part of a LTS version, or because it is not applicable for \
11upstreaming in any form."
12
13require linux-imx.inc
14
15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
16
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass.
19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6.50"
23
24KBRANCH = "6.6.x+fslc"
25SRCREV = "2473dfed9007471b503efe1f7de74d63eaf4c699"
26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"
29KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v6_v7_defconfig"
30KBUILD_DEFCONFIG:mx8-generic-bsp = "defconfig"
31KBUILD_DEFCONFIG:mx9-generic-bsp = "defconfig"
32KBUILD_DEFCONFIG:mxs-generic-bsp = "mxs_defconfig"
33KBUILD_DEFCONFIG:vf-generic-bsp = "imx_v6_v7_defconfig"
34
35LOCALVERSION = "-fslc"
36
37COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-kernel/linux/linux-fslc_6.6.bb b/recipes-kernel/linux/linux-fslc_6.11.bb
index 1919eacd..cf4c117b 100644
--- a/recipes-kernel/linux/linux-fslc_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc_6.11.bb
@@ -14,15 +14,19 @@ require linux-imx.inc
14 14
15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
16 16
17DEPENDS += " \
18 coreutils-native \
19"
20
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 21# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass. 22# required by kernel-yocto.bbclass.
19# 23#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 24# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 25# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6.50" 26LINUX_VERSION = "6.11.0"
23 27
24KBRANCH = "6.6.x+fslc" 28KBRANCH = "6.11.x+fslc"
25SRCREV = "2473dfed9007471b503efe1f7de74d63eaf4c699" 29SRCREV = "98f7e32f20d28ec452afb208f9cffc08448a2652"
26 30
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 31KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig" 32KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"