diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-05-05 12:57:28 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-05-05 12:57:28 -0300 |
commit | d2997c6b0d0499bcfff8f35bb44ec726345b9106 (patch) | |
tree | 89f472d23015987cdb6aebc0bc12a1da5d51a729 | |
parent | 7431918c86ac6d3be2a273e091227157446960a7 (diff) | |
parent | 5ea77dce34cf2d8b936a0df75bfe274d48a321ec (diff) | |
download | meta-freescale-d2997c6b0d0499bcfff8f35bb44ec726345b9106.tar.gz |
Merge pull request #2195 from tq-steina/alsa-state-layerscape
alsa-state: Use i:MX-specific configuration to support QorIQ platforms
-rw-r--r-- | conf/machine/include/qoriq-base.inc | 4 | ||||
-rw-r--r-- | recipes-bsp/alsa-state/alsa-state.bbappend | 1 | ||||
l--------- | recipes-bsp/alsa-state/alsa-state/qoriq-generic-bsp | 1 | ||||
l--------- | recipes-bsp/alsa-state/alsa-state/qoriq-mainline-bsp | 1 | ||||
l--------- | recipes-bsp/alsa-state/alsa-state/qoriq-nxp-bsp | 1 |
5 files changed, 8 insertions, 0 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc index 4340c942..4a42a8bd 100644 --- a/conf/machine/include/qoriq-base.inc +++ b/conf/machine/include/qoriq-base.inc | |||
@@ -43,6 +43,8 @@ EXTRA_IMAGEDEPENDS += "u-boot qoriq-cst-native" | |||
43 | 43 | ||
44 | MACHINEOVERRIDES =. "qoriq:" | 44 | MACHINEOVERRIDES =. "qoriq:" |
45 | 45 | ||
46 | INHERIT += "machine-overrides-extender" | ||
47 | |||
46 | # Machines or distros can define which BSP it should use by default. We are | 48 | # Machines or distros can define which BSP it should use by default. We are |
47 | # intending to default for nxp BSP by default and specific machines or | 49 | # intending to default for nxp BSP by default and specific machines or |
48 | # DISTROs might change it if need. | 50 | # DISTROs might change it if need. |
@@ -51,6 +53,8 @@ MACHINEOVERRIDES =. "qoriq:" | |||
51 | QORIQ_DEFAULT_BSP ?= "nxp" | 53 | QORIQ_DEFAULT_BSP ?= "nxp" |
52 | 54 | ||
53 | MACHINEOVERRIDES =. "use-${QORIQ_DEFAULT_BSP}-bsp:" | 55 | MACHINEOVERRIDES =. "use-${QORIQ_DEFAULT_BSP}-bsp:" |
56 | MACHINEOVERRIDES_EXTENDER:use-mainline-bsp = "qoriq-generic-bsp:qoriq-mainline-bsp" | ||
57 | MACHINEOVERRIDES_EXTENDER:use-nxp-bsp = "qoriq-generic-bsp:qoriq-nxp-bsp" | ||
54 | 58 | ||
55 | # Sub-architecture support | 59 | # Sub-architecture support |
56 | MACHINE_SOCARCH_SUFFIX ?= "" | 60 | MACHINE_SOCARCH_SUFFIX ?= "" |
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend index b6194d76..c31fb04b 100644 --- a/recipes-bsp/alsa-state/alsa-state.bbappend +++ b/recipes-bsp/alsa-state/alsa-state.bbappend | |||
@@ -2,3 +2,4 @@ | |||
2 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | 2 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
3 | 3 | ||
4 | PACKAGE_ARCH:imx-generic-bsp = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH:imx-generic-bsp = "${MACHINE_ARCH}" |
5 | PACKAGE_ARCH:qoriq-generic-bsp = "${MACHINE_ARCH}" | ||
diff --git a/recipes-bsp/alsa-state/alsa-state/qoriq-generic-bsp b/recipes-bsp/alsa-state/alsa-state/qoriq-generic-bsp new file mode 120000 index 00000000..febb30e2 --- /dev/null +++ b/recipes-bsp/alsa-state/alsa-state/qoriq-generic-bsp | |||
@@ -0,0 +1 @@ | |||
imx-generic-bsp \ No newline at end of file | |||
diff --git a/recipes-bsp/alsa-state/alsa-state/qoriq-mainline-bsp b/recipes-bsp/alsa-state/alsa-state/qoriq-mainline-bsp new file mode 120000 index 00000000..b43cbb34 --- /dev/null +++ b/recipes-bsp/alsa-state/alsa-state/qoriq-mainline-bsp | |||
@@ -0,0 +1 @@ | |||
imx-mainline-bsp \ No newline at end of file | |||
diff --git a/recipes-bsp/alsa-state/alsa-state/qoriq-nxp-bsp b/recipes-bsp/alsa-state/alsa-state/qoriq-nxp-bsp new file mode 120000 index 00000000..022b2509 --- /dev/null +++ b/recipes-bsp/alsa-state/alsa-state/qoriq-nxp-bsp | |||
@@ -0,0 +1 @@ | |||
imx-nxp-bsp \ No newline at end of file | |||