diff options
author | Zelan Zou <zelan.zou@nxp.com> | 2024-11-05 03:10:59 +0100 |
---|---|---|
committer | Zelan Zou <zelan.zou@nxp.com> | 2024-11-06 02:59:18 +0100 |
commit | e822d0905a78b85fcdd79d9ea9dbbc7ffd1214a7 (patch) | |
tree | a38c9f9f6e88ac98aeef495002257431360a231f | |
parent | 72d3c276506dc912df9b49a3f1538c2002aa88b4 (diff) | |
download | meta-freescale-e822d0905a78b85fcdd79d9ea9dbbc7ffd1214a7.tar.gz |
fmc: Upgrade to lf-6.6.36-2.1.0 release
Signed-off-by: Zelan Zou <zelan.zou@nxp.com>
2 files changed, 1 insertions, 60 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch deleted file mode 100644 index 5769d555..00000000 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc/0001-FMCCFGReader-improve-parameter-definition-of-functio.patch +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | From 018249d180705657efbecdce3736c9a415412762 Mon Sep 17 00:00:00 2001 | ||
2 | From: Meng Li <Meng.Li@windriver.com> | ||
3 | Date: Tue, 9 Jul 2024 14:35:06 +0800 | ||
4 | Subject: [PATCH] FMCCFGReader: improve parameter definition of function | ||
5 | errorFuncHandler | ||
6 | |||
7 | When building fmc package, there is below error: | ||
8 | FMCCFGReader.cpp: In member function 'void CCFGReader::parseCfgData(std::string)': | ||
9 | FMCCFGReader.cpp:98:40: error: invalid conversion from | ||
10 | 'void (*)(void*, xmlErrorPtr)' {aka 'void (*)(void*, _xmlError*)'} to | ||
11 | 'xmlStructuredErrorFunc' {aka 'void (*)(void*, const _xmlError*)'} [-fpermissive] | ||
12 | 98 | xmlSetStructuredErrorFunc( &error, errorFuncHandler ); | ||
13 | | ^~~~~~~~~~~~~~~~ | ||
14 | | | | ||
15 | | void (*)(void*, xmlErrorPtr) {aka void (*)(void*, _xmlError*)} | ||
16 | Because in libxml2 package, the parameter definition of function | ||
17 | pointer xmlStructuredErrorFunc has changed, adjust the parameter | ||
18 | of errorFuncHandler to align with upstream. | ||
19 | |||
20 | Upstream-Status: Pending | ||
21 | |||
22 | Signed-off-by: Meng Li <Meng.Li@windriver.com> | ||
23 | --- | ||
24 | source/FMCGenericError.cpp | 2 +- | ||
25 | source/FMCGenericError.h | 2 +- | ||
26 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
27 | |||
28 | diff --git a/source/FMCGenericError.cpp b/source/FMCGenericError.cpp | ||
29 | index a1a87a4..c11742c 100644 | ||
30 | --- a/source/FMCGenericError.cpp | ||
31 | +++ b/source/FMCGenericError.cpp | ||
32 | @@ -33,7 +33,7 @@ | ||
33 | #include "FMCUtils.h" | ||
34 | #include "logger.hpp" | ||
35 | |||
36 | -void errorFuncHandler( void * ctx, xmlErrorPtr error ) | ||
37 | +void errorFuncHandler( void * ctx, const xmlError *error ) | ||
38 | { | ||
39 | char *filestr = (char*)""; | ||
40 | char *msgstr = (char*)""; | ||
41 | diff --git a/source/FMCGenericError.h b/source/FMCGenericError.h | ||
42 | index 504a81b..61ab6c1 100644 | ||
43 | --- a/source/FMCGenericError.h | ||
44 | +++ b/source/FMCGenericError.h | ||
45 | @@ -35,7 +35,7 @@ | ||
46 | |||
47 | const int NO_LINE = -1; | ||
48 | |||
49 | -void errorFuncHandler( void * ctx, xmlErrorPtr error ); | ||
50 | +void errorFuncHandler( void * ctx, const xmlError *error ); | ||
51 | |||
52 | |||
53 | class CGenericError { | ||
54 | -- | ||
55 | 2.34.1 | ||
56 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb index 457a202c..2219a6c0 100644 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb | |||
@@ -7,10 +7,7 @@ PR = "r2" | |||
7 | DEPENDS = "libxml2 fmlib tclap" | 7 | DEPENDS = "libxml2 fmlib tclap" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/nxp-qoriq/fmc;protocol=https;nobranch=1" | 9 | SRC_URI = "git://github.com/nxp-qoriq/fmc;protocol=https;nobranch=1" |
10 | SRC_URI:append = " \ | 10 | SRCREV = "5b9f4b16a864e9dfa58cdcc860be278a7f66ac18" |
11 | file://0001-FMCCFGReader-improve-parameter-definition-of-functio.patch \ | ||
12 | " | ||
13 | SRCREV = "63c8ac99899a9bcd723801579b4d786594670455" | ||
14 | 11 | ||
15 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
16 | 13 | ||