diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2025-04-30 22:18:11 +0200 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2025-04-30 22:22:35 +0200 |
commit | f93d8449ce6c536314fc58fe15af19195305360d (patch) | |
tree | 3724a9ea990dafee5c2a9290da38a902f19f46ed | |
parent | 42ffe6d421588b7b813da82b82e333b805bb3970 (diff) | |
download | meta-freescale-f93d8449ce6c536314fc58fe15af19195305360d.tar.gz |
alsa-lib: rework patches to apply on 1.2.13 and 1.2.14
OE-core updated alsa-lib.
commit 8518e57a117a ("alsa-lib: upgrade 1.2.13 -> 1.2.14")
The patches in their current form either apply to one or the
other version without fuzz.
Move the additions to the cfg_files variable list to the top
rather than to the bottom of the list to have the patches apply
cleanly to the older and newer alsa-lib version.
Fixes: 32226986810a ("alsa-lib: refresh patches") on walnascar
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
4 files changed, 43 insertions, 51 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch index f5ce84ea..7ae8b8fe 100644 --- a/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch +++ b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 365213e10b073c45d7bacf9c94e30e879bfa8255 Mon Sep 17 00:00:00 2001 | 1 | From 3fa81ebaf8bac6b167776888ae26c6c140d8aebc Mon Sep 17 00:00:00 2001 |
2 | From: Shengjiu Wang <b02247@freescale.com> | 2 | From: Shengjiu Wang <b02247@freescale.com> |
3 | Date: Thu, 5 Jun 2014 17:37:47 +0800 | 3 | Date: Thu, 5 Jun 2014 17:37:47 +0800 |
4 | Subject: [PATCH] add conf for multichannel support in imx | 4 | Subject: [PATCH] add conf for multichannel support in imx |
@@ -9,9 +9,9 @@ Signed-off-by: Shengjiu Wang <b02247@freescale.com> | |||
9 | --- | 9 | --- |
10 | src/conf/cards/CS42888.conf | 94 ++++++++++++++++++++++++++++++++++++ | 10 | src/conf/cards/CS42888.conf | 94 ++++++++++++++++++++++++++++++++++++ |
11 | src/conf/cards/IMX-HDMI.conf | 67 +++++++++++++++++++++++++ | 11 | src/conf/cards/IMX-HDMI.conf | 67 +++++++++++++++++++++++++ |
12 | src/conf/cards/Makefile.am | 4 +- | 12 | src/conf/cards/Makefile.am | 2 + |
13 | src/conf/cards/aliases.conf | 2 + | 13 | src/conf/cards/aliases.conf | 2 + |
14 | 4 files changed, 166 insertions(+), 1 deletion(-) | 14 | 4 files changed, 165 insertions(+) |
15 | create mode 100644 src/conf/cards/CS42888.conf | 15 | create mode 100644 src/conf/cards/CS42888.conf |
16 | create mode 100644 src/conf/cards/IMX-HDMI.conf | 16 | create mode 100644 src/conf/cards/IMX-HDMI.conf |
17 | 17 | ||
@@ -189,20 +189,18 @@ index 000000000000..a51509e8ad5a | |||
189 | + | 189 | + |
190 | +# vim: ft=alsaconf | 190 | +# vim: ft=alsaconf |
191 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am | 191 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am |
192 | index f387cf4197da..fb7de95b194d 100644 | 192 | index f387cf4197da..cbd2cd04227d 100644 |
193 | --- a/src/conf/cards/Makefile.am | 193 | --- a/src/conf/cards/Makefile.am |
194 | +++ b/src/conf/cards/Makefile.am | 194 | +++ b/src/conf/cards/Makefile.am |
195 | @@ -58,7 +58,9 @@ cfg_files = aliases.conf \ | 195 | @@ -1,6 +1,8 @@ |
196 | VIA8237.conf \ | 196 | alsaconfigdir = @ALSA_CONFIG_DIR@ |
197 | VX222.conf \ | 197 | alsadir = $(alsaconfigdir)/cards |
198 | VXPocket.conf \ | 198 | cfg_files = aliases.conf \ |
199 | - VXPocket440.conf | ||
200 | + VXPocket440.conf \ | ||
201 | + CS42888.conf \ | 199 | + CS42888.conf \ |
202 | + IMX-HDMI.conf | 200 | + IMX-HDMI.conf \ |
203 | 201 | AACI.conf \ | |
204 | alsa_DATA = $(cfg_files) | 202 | ATIIXP.conf \ |
205 | 203 | ATIIXP-SPDMA.conf \ | |
206 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf | 204 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf |
207 | index a54824ae636b..0aa874d7434f 100644 | 205 | index a54824ae636b..0aa874d7434f 100644 |
208 | --- a/src/conf/cards/aliases.conf | 206 | --- a/src/conf/cards/aliases.conf |
diff --git a/recipes-multimedia/alsa/alsa-lib/0005-add-ak4458-conf-for-multichannel-support.patch b/recipes-multimedia/alsa/alsa-lib/0005-add-ak4458-conf-for-multichannel-support.patch index 82122b14..51e19982 100644 --- a/recipes-multimedia/alsa/alsa-lib/0005-add-ak4458-conf-for-multichannel-support.patch +++ b/recipes-multimedia/alsa/alsa-lib/0005-add-ak4458-conf-for-multichannel-support.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From eba3f36b6619d0794028f0880fbdfc2bb98df45e Mon Sep 17 00:00:00 2001 | 1 | From 92d2b7d91bc1ec4068ee9371753bb24ad1108827 Mon Sep 17 00:00:00 2001 |
2 | From: Shengjiu Wang <shengjiu.wang@nxp.com> | 2 | From: Shengjiu Wang <shengjiu.wang@nxp.com> |
3 | Date: Wed, 31 Jan 2018 15:06:53 +0800 | 3 | Date: Wed, 31 Jan 2018 15:06:53 +0800 |
4 | Subject: [PATCH] add ak4458 conf for multichannel support | 4 | Subject: [PATCH] add ak4458 conf for multichannel support |
@@ -14,9 +14,9 @@ Upstream-Status: Inappropriate [i.MX specific] | |||
14 | Signed-off-by: Shengjiu Wang <shengjiu.wang@nxp.com> | 14 | Signed-off-by: Shengjiu Wang <shengjiu.wang@nxp.com> |
15 | --- | 15 | --- |
16 | src/conf/cards/AK4458.conf | 74 +++++++++++++++++++++++++++++++++++++ | 16 | src/conf/cards/AK4458.conf | 74 +++++++++++++++++++++++++++++++++++++ |
17 | src/conf/cards/Makefile.am | 3 +- | 17 | src/conf/cards/Makefile.am | 1 + |
18 | src/conf/cards/aliases.conf | 1 + | 18 | src/conf/cards/aliases.conf | 1 + |
19 | 3 files changed, 77 insertions(+), 1 deletion(-) | 19 | 3 files changed, 76 insertions(+) |
20 | create mode 100644 src/conf/cards/AK4458.conf | 20 | create mode 100644 src/conf/cards/AK4458.conf |
21 | 21 | ||
22 | diff --git a/src/conf/cards/AK4458.conf b/src/conf/cards/AK4458.conf | 22 | diff --git a/src/conf/cards/AK4458.conf b/src/conf/cards/AK4458.conf |
@@ -100,19 +100,17 @@ index 000000000000..3b5b195f2ca0 | |||
100 | + slave.channels 8 | 100 | + slave.channels 8 |
101 | +} | 101 | +} |
102 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am | 102 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am |
103 | index fb7de95b194d..bdb1c2523d62 100644 | 103 | index cbd2cd04227d..3c29bd65d341 100644 |
104 | --- a/src/conf/cards/Makefile.am | 104 | --- a/src/conf/cards/Makefile.am |
105 | +++ b/src/conf/cards/Makefile.am | 105 | +++ b/src/conf/cards/Makefile.am |
106 | @@ -60,7 +60,8 @@ cfg_files = aliases.conf \ | 106 | @@ -3,6 +3,7 @@ alsadir = $(alsaconfigdir)/cards |
107 | VXPocket.conf \ | 107 | cfg_files = aliases.conf \ |
108 | VXPocket440.conf \ | ||
109 | CS42888.conf \ | 108 | CS42888.conf \ |
110 | - IMX-HDMI.conf | 109 | IMX-HDMI.conf \ |
111 | + IMX-HDMI.conf \ | 110 | + AK4458.conf \ |
112 | + AK4458.conf | 111 | AACI.conf \ |
113 | 112 | ATIIXP.conf \ | |
114 | alsa_DATA = $(cfg_files) | 113 | ATIIXP-SPDMA.conf \ |
115 | |||
116 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf | 114 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf |
117 | index 0aa874d7434f..dda71d99916e 100644 | 115 | index 0aa874d7434f..dda71d99916e 100644 |
118 | --- a/src/conf/cards/aliases.conf | 116 | --- a/src/conf/cards/aliases.conf |
diff --git a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch index c2e8cece..db76eb74 100644 --- a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch +++ b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 812399f89e01239ca88b905451a55ba996a88e1a Mon Sep 17 00:00:00 2001 | 1 | From faa9791070520f8d5e7060e5668efd1302c86c66 Mon Sep 17 00:00:00 2001 |
2 | From: Viorel Suman <viorel.suman@nxp.com> | 2 | From: Viorel Suman <viorel.suman@nxp.com> |
3 | Date: Mon, 9 Mar 2020 14:25:46 +0200 | 3 | Date: Mon, 9 Mar 2020 14:25:46 +0200 |
4 | Subject: [PATCH] add conf for iMX XCVR sound card | 4 | Subject: [PATCH] add conf for iMX XCVR sound card |
@@ -8,9 +8,9 @@ Upstream-Status: Pending | |||
8 | Signed-off-by: Viorel Suman <viorel.suman@nxp.com> | 8 | Signed-off-by: Viorel Suman <viorel.suman@nxp.com> |
9 | --- | 9 | --- |
10 | src/conf/cards/IMX-XCVR.conf | 39 ++++++++++++++++++++++++++++++++++++ | 10 | src/conf/cards/IMX-XCVR.conf | 39 ++++++++++++++++++++++++++++++++++++ |
11 | src/conf/cards/Makefile.am | 3 ++- | 11 | src/conf/cards/Makefile.am | 1 + |
12 | src/conf/cards/aliases.conf | 1 + | 12 | src/conf/cards/aliases.conf | 1 + |
13 | 3 files changed, 42 insertions(+), 1 deletion(-) | 13 | 3 files changed, 41 insertions(+) |
14 | create mode 100755 src/conf/cards/IMX-XCVR.conf | 14 | create mode 100755 src/conf/cards/IMX-XCVR.conf |
15 | 15 | ||
16 | diff --git a/src/conf/cards/IMX-XCVR.conf b/src/conf/cards/IMX-XCVR.conf | 16 | diff --git a/src/conf/cards/IMX-XCVR.conf b/src/conf/cards/IMX-XCVR.conf |
@@ -59,19 +59,17 @@ index 000000000000..009000c63a19 | |||
59 | + preamble.y 0x3 | 59 | + preamble.y 0x3 |
60 | +} | 60 | +} |
61 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am | 61 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am |
62 | index bdb1c2523d62..044d2581f8bd 100644 | 62 | index 3c29bd65d341..4502919e3bec 100644 |
63 | --- a/src/conf/cards/Makefile.am | 63 | --- a/src/conf/cards/Makefile.am |
64 | +++ b/src/conf/cards/Makefile.am | 64 | +++ b/src/conf/cards/Makefile.am |
65 | @@ -61,7 +61,8 @@ cfg_files = aliases.conf \ | 65 | @@ -4,6 +4,7 @@ cfg_files = aliases.conf \ |
66 | VXPocket440.conf \ | ||
67 | CS42888.conf \ | 66 | CS42888.conf \ |
68 | IMX-HDMI.conf \ | 67 | IMX-HDMI.conf \ |
69 | - AK4458.conf | 68 | AK4458.conf \ |
70 | + AK4458.conf \ | 69 | + IMX-XCVR.conf \ |
71 | + IMX-XCVR.conf | 70 | AACI.conf \ |
72 | 71 | ATIIXP.conf \ | |
73 | alsa_DATA = $(cfg_files) | 72 | ATIIXP-SPDMA.conf \ |
74 | |||
75 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf | 73 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf |
76 | index dda71d99916e..6dab14855f25 100644 | 74 | index dda71d99916e..6dab14855f25 100644 |
77 | --- a/src/conf/cards/aliases.conf | 75 | --- a/src/conf/cards/aliases.conf |
diff --git a/recipes-multimedia/alsa/alsa-lib/0007-add-conf-for-imx-cs42448-sound-card.patch b/recipes-multimedia/alsa/alsa-lib/0007-add-conf-for-imx-cs42448-sound-card.patch index 217942d7..fa71078e 100644 --- a/recipes-multimedia/alsa/alsa-lib/0007-add-conf-for-imx-cs42448-sound-card.patch +++ b/recipes-multimedia/alsa/alsa-lib/0007-add-conf-for-imx-cs42448-sound-card.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 2f87ea5afa137dfa2f7a096e9c8518be43920ed9 Mon Sep 17 00:00:00 2001 | 1 | From 38d84440a7bec9e26380f08f050b2ada772b822e Mon Sep 17 00:00:00 2001 |
2 | From: Chancel Liu <chancel.liu@nxp.com> | 2 | From: Chancel Liu <chancel.liu@nxp.com> |
3 | Date: Fri, 29 Jul 2022 16:12:37 +0800 | 3 | Date: Fri, 29 Jul 2022 16:12:37 +0800 |
4 | Subject: [PATCH] add conf for imx-cs42448 sound card | 4 | Subject: [PATCH] add conf for imx-cs42448 sound card |
@@ -11,9 +11,9 @@ Upstream-Status: Inappropriate [i.MX specific] | |||
11 | Signed-off-by: Chancel Liu <chancel.liu@nxp.com> | 11 | Signed-off-by: Chancel Liu <chancel.liu@nxp.com> |
12 | --- | 12 | --- |
13 | src/conf/cards/CS42448.conf | 58 +++++++++++++++++++++++++++++++++++++ | 13 | src/conf/cards/CS42448.conf | 58 +++++++++++++++++++++++++++++++++++++ |
14 | src/conf/cards/Makefile.am | 3 +- | 14 | src/conf/cards/Makefile.am | 1 + |
15 | src/conf/cards/aliases.conf | 1 + | 15 | src/conf/cards/aliases.conf | 1 + |
16 | 3 files changed, 61 insertions(+), 1 deletion(-) | 16 | 3 files changed, 60 insertions(+) |
17 | create mode 100644 src/conf/cards/CS42448.conf | 17 | create mode 100644 src/conf/cards/CS42448.conf |
18 | 18 | ||
19 | diff --git a/src/conf/cards/CS42448.conf b/src/conf/cards/CS42448.conf | 19 | diff --git a/src/conf/cards/CS42448.conf b/src/conf/cards/CS42448.conf |
@@ -81,19 +81,17 @@ index 000000000000..28ba5c485837 | |||
81 | + | 81 | + |
82 | +# vim: ft=alsaconf | 82 | +# vim: ft=alsaconf |
83 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am | 83 | diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am |
84 | index 044d2581f8bd..b08962cf3ba3 100644 | 84 | index 4502919e3bec..da2def3a9498 100644 |
85 | --- a/src/conf/cards/Makefile.am | 85 | --- a/src/conf/cards/Makefile.am |
86 | +++ b/src/conf/cards/Makefile.am | 86 | +++ b/src/conf/cards/Makefile.am |
87 | @@ -62,7 +62,8 @@ cfg_files = aliases.conf \ | 87 | @@ -5,6 +5,7 @@ cfg_files = aliases.conf \ |
88 | CS42888.conf \ | ||
89 | IMX-HDMI.conf \ | 88 | IMX-HDMI.conf \ |
90 | AK4458.conf \ | 89 | AK4458.conf \ |
91 | - IMX-XCVR.conf | 90 | IMX-XCVR.conf \ |
92 | + IMX-XCVR.conf \ | 91 | + CS42448.conf \ |
93 | + CS42448.conf | 92 | AACI.conf \ |
94 | 93 | ATIIXP.conf \ | |
95 | alsa_DATA = $(cfg_files) | 94 | ATIIXP-SPDMA.conf \ |
96 | |||
97 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf | 95 | diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf |
98 | index 6dab14855f25..554db846f8e5 100644 | 96 | index 6dab14855f25..554db846f8e5 100644 |
99 | --- a/src/conf/cards/aliases.conf | 97 | --- a/src/conf/cards/aliases.conf |