summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
diff options
context:
space:
mode:
authorFabio Estevam <festevam@denx.de>2024-09-06 15:14:54 -0300
committerFabio Estevam <festevam@denx.de>2024-09-06 15:14:54 -0300
commit601116752155102cf520144e8ef898adf448ce0a (patch)
tree589308f8bb5fe2f9151b66707bb4dbf1e40ea653 /dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
parentbf73414b4c80e7412dd15e60d5bdc4377a377e48 (diff)
downloadmeta-freescale-601116752155102cf520144e8ef898adf448ce0a.tar.gz
imx-cst: Remove unused patch
Since the update to version 3.4.0, the imx-cst patch is no longer used. Remove the unused imx-cst patch. Signed-off-by: Fabio Estevam <festevam@denx.de>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch b/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
deleted file mode 100644
index a3f5c828..00000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1NXP uses weaken to solve conflict in linking.
2On Ubuntu 22.04(LTS) this fails to link cst with libcrypto.
3
4The patch fixes the conflict in the code itself.
5It restricts the scope of err_msg to the module.
6
7Upstream-Status: Inappropriate [i.MX specific]
8Signed-off-by: Walter Schweizer <walter.schweizer@siemens.com>
9----
10diff --git a/code/cst/code/build/make/rules.mk b/code/cst/code/build/make/rules.mk
11index 1c0842b..9c46cc4 100644
12--- a/code/cst/code/build/make/rules.mk
13+++ b/code/cst/code/build/make/rules.mk
14@@ -25,11 +25,11 @@ LFLAGS := -t
15 %.a:
16 @echo "Create archive $@"
17 $(AR) $(ARFLAGS) $@ $^
18-ifneq ($(OSTYPE),mingw32)
19-ifneq ($(OSTYPE),osx)
20- $(OBJCOPY) --weaken $@
21-endif
22-endif
23+#ifneq ($(OSTYPE),mingw32)
24+#ifneq ($(OSTYPE),osx)
25+# $(OBJCOPY) --weaken $@
26+#endif
27+#endif
28
29 %.exe:
30 @echo "Link $@"
31diff --git a/code/cst/code/front_end/src/acst.c b/code/cst/code/front_end/src/acst.c
32index fb1e8aa..1e993ee 100644
33--- a/code/cst/code/front_end/src/acst.c
34+++ b/code/cst/code/front_end/src/acst.c
35@@ -65,7 +65,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
36 /*===========================================================================
37 LOCAL VARIABLES
38 =============================================================================*/
39-char err_msg[MAX_ERR_MSG_BYTES];
40+static char err_msg[MAX_ERR_MSG_BYTES];
41
42 /*===========================================================================
43 LOCAL FUNCTION PROTOTYPES
44diff --git a/code/cst/code/front_end/src/misc_helper.c b/code/cst/code/front_end/src/misc_helper.c
45index 678dc17..9014b2a 100644
46--- a/code/cst/code/front_end/src/misc_helper.c
47+++ b/code/cst/code/front_end/src/misc_helper.c
48@@ -60,7 +60,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
49 /*===========================================================================
50 LOCAL VARIABLES
51 =============================================================================*/
52-char err_msg[MAX_ERR_MSG_BYTES];
53+static char err_msg[MAX_ERR_MSG_BYTES];
54
55 /*===========================================================================
56 LOCAL FUNCTION PROTOTYPES