diff options
author | Walter Schweizer <walter.schweizer@siemens.com> | 2023-02-03 15:27:04 +0100 |
---|---|---|
committer | Walter Schweizer <walter.schweizer@siemens.com> | 2023-02-04 11:03:24 +0100 |
commit | c731dcbe2ddbaa57c37e4ec8362752c9b96ab13d (patch) | |
tree | f4ddde252d802ff755ebbe65754945dc57808bbb /dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch | |
parent | 9024c90df68ae97d3a6f8decaa513cce7a8c2c5b (diff) | |
download | meta-freescale-c731dcbe2ddbaa57c37e4ec8362752c9b96ab13d.tar.gz |
imx-cst: fix build issue for Ubuntu 22.04(LTS)
On Ubuntu 22.04(LTS) cst fails to link with libcrypto.
NXP uses weaken to solve a conflict in linking.
The linker in Ubuntu seems to ignore weak symbols does
not link libcrypto at all.
The patch fixes the conflict in the code itself.
It restricts the scope of err_msg to the module.
Signed-off-by: Walter Schweizer <walter.schweizer@siemens.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch b/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch new file mode 100644 index 00000000..a3f5c828 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | NXP uses weaken to solve conflict in linking. | ||
2 | On Ubuntu 22.04(LTS) this fails to link cst with libcrypto. | ||
3 | |||
4 | The patch fixes the conflict in the code itself. | ||
5 | It restricts the scope of err_msg to the module. | ||
6 | |||
7 | Upstream-Status: Inappropriate [i.MX specific] | ||
8 | Signed-off-by: Walter Schweizer <walter.schweizer@siemens.com> | ||
9 | ---- | ||
10 | diff --git a/code/cst/code/build/make/rules.mk b/code/cst/code/build/make/rules.mk | ||
11 | index 1c0842b..9c46cc4 100644 | ||
12 | --- a/code/cst/code/build/make/rules.mk | ||
13 | +++ b/code/cst/code/build/make/rules.mk | ||
14 | @@ -25,11 +25,11 @@ LFLAGS := -t | ||
15 | %.a: | ||
16 | @echo "Create archive $@" | ||
17 | $(AR) $(ARFLAGS) $@ $^ | ||
18 | -ifneq ($(OSTYPE),mingw32) | ||
19 | -ifneq ($(OSTYPE),osx) | ||
20 | - $(OBJCOPY) --weaken $@ | ||
21 | -endif | ||
22 | -endif | ||
23 | +#ifneq ($(OSTYPE),mingw32) | ||
24 | +#ifneq ($(OSTYPE),osx) | ||
25 | +# $(OBJCOPY) --weaken $@ | ||
26 | +#endif | ||
27 | +#endif | ||
28 | |||
29 | %.exe: | ||
30 | @echo "Link $@" | ||
31 | diff --git a/code/cst/code/front_end/src/acst.c b/code/cst/code/front_end/src/acst.c | ||
32 | index fb1e8aa..1e993ee 100644 | ||
33 | --- a/code/cst/code/front_end/src/acst.c | ||
34 | +++ b/code/cst/code/front_end/src/acst.c | ||
35 | @@ -65,7 +65,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. | ||
36 | /*=========================================================================== | ||
37 | LOCAL VARIABLES | ||
38 | =============================================================================*/ | ||
39 | -char err_msg[MAX_ERR_MSG_BYTES]; | ||
40 | +static char err_msg[MAX_ERR_MSG_BYTES]; | ||
41 | |||
42 | /*=========================================================================== | ||
43 | LOCAL FUNCTION PROTOTYPES | ||
44 | diff --git a/code/cst/code/front_end/src/misc_helper.c b/code/cst/code/front_end/src/misc_helper.c | ||
45 | index 678dc17..9014b2a 100644 | ||
46 | --- a/code/cst/code/front_end/src/misc_helper.c | ||
47 | +++ b/code/cst/code/front_end/src/misc_helper.c | ||
48 | @@ -60,7 +60,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. | ||
49 | /*=========================================================================== | ||
50 | LOCAL VARIABLES | ||
51 | =============================================================================*/ | ||
52 | -char err_msg[MAX_ERR_MSG_BYTES]; | ||
53 | +static char err_msg[MAX_ERR_MSG_BYTES]; | ||
54 | |||
55 | /*=========================================================================== | ||
56 | LOCAL FUNCTION PROTOTYPES | ||