diff options
author | Alexander Stein <alexander.stein@ew.tq-group.com> | 2024-08-05 11:31:23 +0200 |
---|---|---|
committer | Alexander Stein <alexander.stein@ew.tq-group.com> | 2024-08-05 11:31:38 +0200 |
commit | 753a955102667f147c97823ec881f5c028dca137 (patch) | |
tree | cf8a1cca0b8ef4dda5dd76df2e3343f6255c1864 /dynamic-layers/openembedded-layer | |
parent | 53edaa9dffb89501c223abde946056f99142b759 (diff) | |
download | meta-freescale-753a955102667f147c97823ec881f5c028dca137.tar.gz |
openembedded-layer: Remove luajit abbappend
This (qoriq-ppc only) patch fails to apply since upstream commit
https://repo.or.cz/luajit-2.0.git/commitdiff/338e9863c220462201fde0e725aba4002310c849
This breaks 'devtool modify luajit' even on non-qoriq-pcc platforms.
Signed-off-by: Alexander Stein <alexander.stein@ew.tq-group.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch | 104 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend | 4 |
2 files changed, 0 insertions, 108 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch deleted file mode 100644 index a576f917..00000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit/ppc-fixplt.patch +++ /dev/null | |||
@@ -1,104 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
3 | |||
4 | libluajit is having symbols that can't be | ||
5 | resolved the reloc cannot accommodate an offset greater than 24 bits. | ||
6 | |||
7 | Looking at libluajit with readelf -r, you see a bunch of entries that look like: | ||
8 | 000082f0 00003c0a R_PPC_REL24 00000000 sqrt + 0 | ||
9 | |||
10 | These should not occur when the code is compiled and linked with -fPIC. | ||
11 | |||
12 | It turns out that libluajit *is* compiled and linked with -fPIC, however... | ||
13 | There is one assembler file called lj_vm.s which is generated during the build. | ||
14 | This file is missing the `@plt' qualifier from external references. | ||
15 | |||
16 | This file is generated by a program called buildvm. This in turn uses tables | ||
17 | in a file called buildvm_arch.h which is generated by dynasm.lua. | ||
18 | |||
19 | Index: LuaJIT-2.0.1/src/host/buildvm.c | ||
20 | =================================================================== | ||
21 | --- LuaJIT-2.0.1.orig/src/host/buildvm.c 2013-02-19 12:15:00.000000000 -0800 | ||
22 | +++ LuaJIT-2.0.1/src/host/buildvm.c 2013-05-14 20:26:05.933444512 -0700 | ||
23 | @@ -107,12 +107,14 @@ | ||
24 | #endif | ||
25 | sprintf(name, "%s%s%s", symprefix, prefix, suffix); | ||
26 | p = strchr(name, '@'); | ||
27 | +#if 0 | ||
28 | if (p) { | ||
29 | if (!LJ_64 && (ctx->mode == BUILD_coffasm || ctx->mode == BUILD_peobj)) | ||
30 | name[0] = '@'; | ||
31 | else | ||
32 | *p = '\0'; | ||
33 | } | ||
34 | +#endif | ||
35 | p = (char *)malloc(strlen(name)+1); /* MSVC doesn't like strdup. */ | ||
36 | strcpy(p, name); | ||
37 | return p; | ||
38 | Index: LuaJIT-2.0.1/src/vm_ppcspe.dasc | ||
39 | =================================================================== | ||
40 | --- LuaJIT-2.0.1.orig/src/vm_ppcspe.dasc 2013-02-19 12:15:00.000000000 -0800 | ||
41 | +++ LuaJIT-2.0.1/src/vm_ppcspe.dasc 2013-05-14 20:26:05.937444512 -0700 | ||
42 | @@ -1390,7 +1390,7 @@ | ||
43 | | checknum CARG2 | ||
44 | | evmergehi CARG1, CARG2, CARG2 | ||
45 | | checkfail ->fff_fallback | ||
46 | - | bl extern func | ||
47 | + | bl extern func@plt | ||
48 | | evmergelo CRET1, CRET1, CRET2 | ||
49 | | b ->fff_restv | ||
50 | |.endmacro | ||
51 | @@ -1405,7 +1405,7 @@ | ||
52 | | checknum CARG1 | ||
53 | | evmergehi CARG3, CARG4, CARG4 | ||
54 | | checkanyfail ->fff_fallback | ||
55 | - | bl extern func | ||
56 | + | bl extern func@plt | ||
57 | | evmergelo CRET1, CRET1, CRET2 | ||
58 | | b ->fff_restv | ||
59 | |.endmacro | ||
60 | @@ -1437,7 +1437,7 @@ | ||
61 | | checknum CARG2 | ||
62 | | evmergehi CARG1, CARG2, CARG2 | ||
63 | | checkfail ->fff_fallback | ||
64 | - | bl extern log | ||
65 | + | bl extern log@plt | ||
66 | | evmergelo CRET1, CRET1, CRET2 | ||
67 | | b ->fff_restv | ||
68 | | | ||
69 | @@ -1471,7 +1471,7 @@ | ||
70 | | checknum CARG1 | ||
71 | | checkanyfail ->fff_fallback | ||
72 | | efdctsi CARG3, CARG4 | ||
73 | - | bl extern ldexp | ||
74 | + | bl extern ldexp@plt | ||
75 | | evmergelo CRET1, CRET1, CRET2 | ||
76 | | b ->fff_restv | ||
77 | | | ||
78 | @@ -1484,7 +1484,7 @@ | ||
79 | | checkfail ->fff_fallback | ||
80 | | la CARG3, DISPATCH_GL(tmptv)(DISPATCH) | ||
81 | | lwz PC, FRAME_PC(BASE) | ||
82 | - | bl extern frexp | ||
83 | + | bl extern frexp@plt | ||
84 | | lwz TMP1, DISPATCH_GL(tmptv)(DISPATCH) | ||
85 | | evmergelo CRET1, CRET1, CRET2 | ||
86 | | efdcfsi CRET2, TMP1 | ||
87 | @@ -1503,7 +1503,7 @@ | ||
88 | | checkfail ->fff_fallback | ||
89 | | la CARG3, -8(BASE) | ||
90 | | lwz PC, FRAME_PC(BASE) | ||
91 | - | bl extern modf | ||
92 | + | bl extern modf@plt | ||
93 | | evmergelo CRET1, CRET1, CRET2 | ||
94 | | la RA, -8(BASE) | ||
95 | | evstdd CRET1, 0(BASE) | ||
96 | @@ -2399,7 +2399,7 @@ | ||
97 | | checknum CARG1 | ||
98 | | evmergehi CARG3, CARG4, CARG4 | ||
99 | | checkanyfail ->vmeta_arith_vv | ||
100 | - | bl extern pow | ||
101 | + | bl extern pow@plt | ||
102 | | evmergelo CRET2, CRET1, CRET2 | ||
103 | | evstddx CRET2, BASE, RA | ||
104 | | ins_next | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend deleted file mode 100644 index d07f8ae1..00000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" | ||
2 | |||
3 | SRC_URI:append:qoriq-ppc = " file://ppc-fixplt.patch " | ||
4 | |||