summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorHiago De Franco <hiago.franco@toradex.com>2024-08-28 09:33:03 -0300
committerHiago De Franco <hiago.franco@toradex.com>2024-09-08 11:25:18 +0200
commit07931ef7fdf35ca2956481387f8476cd531a9048 (patch)
tree1a2e026127064ad59881fbb98c077f9ff0e05d4a /dynamic-layers
parentfd179116f63cc0a3900c65d752531831bdb1c38c (diff)
downloadmeta-freescale-07931ef7fdf35ca2956481387f8476cd531a9048.tar.gz
imx-oei: move to dynamic-layers and add arm-toolchain
The recipe depends on meta-arm-toolchain, therefore it should be on dynamic-layers/arm-toolchain folder. Create it and make the necessary changes for conf/layer.conf. Fixes: 61beaf5861f2 ("recipes-bsp: introduce imx-oei recipe") Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb
new file mode 100644
index 00000000..a853a803
--- /dev/null
+++ b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb
@@ -0,0 +1,57 @@
1SUMMARY = "i.MX Optional Execution Image"
2
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6INHIBIT_DEFAULT_DEPS = "1"
7DEPENDS = "gcc-arm-none-eabi-native"
8
9SRC_URI = "${IMX_OEI_SRC};branch=${SRCBRANCH}"
10IMX_OEI_SRC ?= "git://github.com/nxp-imx/imx-oei.git;protocol=https"
11SRCBRANCH = "master"
12SRCREV = "1a572a640ef8d6883e8ca39744cd6d2d5dbed678"
13
14S = "${WORKDIR}/git"
15
16inherit deploy
17
18OEI_CONFIGS ?= "UNDEFINED"
19OEI_CORE ?= "UNDEFINED"
20OEI_SOC ?= "UNDEFINED"
21OEI_BOARD ?= "UNDEFINED"
22
23LDFLAGS[unexport] = "1"
24
25EXTRA_OEMAKE = "\
26 board=${OEI_BOARD} \
27 DEBUG=1 \
28 OEI_CROSS_COMPILE=arm-none-eabi-"
29
30do_configure() {
31 for oei_config in ${OEI_CONFIGS}; do
32 oe_runmake clean oei=$oei_config
33 done
34}
35
36do_compile() {
37 for oei_config in ${OEI_CONFIGS}; do
38 oe_runmake oei=$oei_config
39 done
40}
41
42do_install() {
43 install -d ${D}/firmware
44 for oei_config in ${OEI_CONFIGS}; do
45 install -m 0644 ${B}/build/${OEI_BOARD}/$oei_config/oei-*.bin ${D}/firmware
46 done
47}
48
49addtask deploy after do_install
50do_deploy() {
51 cp -rf ${D}/firmware/* ${DEPLOYDIR}/
52}
53
54FILES:${PN} = "/firmware"
55SYSROOT_DIRS += "/firmware"
56
57COMPATIBLE_MACHINE = "(mx95-generic-bsp)"