diff options
author | Paul Gerber <paul.gerber@ew.tq-group.com> | 2024-08-23 11:18:30 +0200 |
---|---|---|
committer | Paul Gerber <paul.gerber@ew.tq-group.com> | 2024-08-27 08:06:10 +0200 |
commit | 81657e636f75015534f1b95af31a3a51552f7545 (patch) | |
tree | 848496a4373532298fc33c83ea8bff1022c0e0d9 /dynamic-layers | |
parent | 52c1409dc2278b7ace5ebca3077b9d8242eac37f (diff) | |
download | meta-freescale-81657e636f75015534f1b95af31a3a51552f7545.tar.gz |
imx-cst: update the recipe for version 3.4.0
New version of NXP i.MX Code Signing Tool for signing images for i.MX
HABv4 and AHAB.
Signed-off-by: Paul Gerber <paul.gerber@ew.tq-group.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb | 35 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb | 40 |
2 files changed, 40 insertions, 35 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb deleted file mode 100644 index 5f808a97..00000000 --- a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | SUMMARY = "i.MX code signing tool" | ||
2 | DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library" | ||
3 | SECTION = "cst" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE.bsd3;md5=1fbcd66ae51447aa94da10cbf6271530" | ||
7 | |||
8 | DEPENDS = "byacc-native flex-native openssl" | ||
9 | |||
10 | # tag=debian/3.3.1+dfsg-2 | ||
11 | SRCREV = "e2c687a856e6670e753147aacef42d0a3c07891a" | ||
12 | SRC_URI = " \ | ||
13 | file://0001-fix-err-msg-linking.patch \ | ||
14 | git://gitlab.apertis.org/pkg/imx-code-signing-tool.git;protocol=https;branch=apertis/v2022pre \ | ||
15 | " | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"' | ||
20 | |||
21 | do_compile() { | ||
22 | cd ${S}/code/cst | ||
23 | oe_runmake build OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}" | ||
24 | cd - | ||
25 | oe_runmake -C code/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" | ||
26 | } | ||
27 | |||
28 | do_install () { | ||
29 | install -d ${D}${bindir} | ||
30 | install -m 755 ${S}/code/cst/code/obj.linux64/cst ${D}${bindir} | ||
31 | install -m 755 ${S}/code/cst/code/obj.linux64/srktool ${D}${bindir} | ||
32 | install -m 755 ${S}/code/hab_csf_parser/csf_parser ${D}${bindir} | ||
33 | } | ||
34 | |||
35 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb new file mode 100644 index 00000000..0e0ebc6e --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "i.MX code signing tool" | ||
2 | DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library" | ||
3 | SECTION = "cst" | ||
4 | LICENSE = "BSD-3-Clause & Apache-2.0" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://LICENSE.bsd3;md5=14aba05f9fa6c25527297c8aac95fcf6 \ | ||
8 | file://LICENSE.hidapi;md5=e0ea014f523f64f0adb13409055ee59e \ | ||
9 | file://LICENSE.openssl;md5=3441526b1df5cc01d812c7dfc218cea6 \ | ||
10 | " | ||
11 | |||
12 | DEPENDS = "byacc-native flex-native openssl" | ||
13 | |||
14 | # debian: 3.4.0+dfsg-2 | ||
15 | DEBIAN_PGK_NAME = "imx-code-signing-tool" | ||
16 | DEBIAN_PGK_VERSION = "${PV}+dfsg" | ||
17 | |||
18 | SRC_URI = "\ | ||
19 | ${DEBIAN_MIRROR}/main/i/${DEBIAN_PGK_NAME}/${DEBIAN_PGK_NAME}_${DEBIAN_PGK_VERSION}.orig.tar.xz \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[sha256sum] = "52ee3cee3bc500a42095f73c4584e223b4b9d2dfc1cd3e5df965c5952eba8c8d" | ||
23 | |||
24 | S = "${WORKDIR}/${DEBIAN_PGK_NAME}-${DEBIAN_PGK_VERSION}" | ||
25 | |||
26 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"' | ||
27 | |||
28 | do_compile() { | ||
29 | oe_runmake -C code/obj.linux64 OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}" | ||
30 | oe_runmake -C add-ons/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" | ||
31 | } | ||
32 | |||
33 | do_install () { | ||
34 | install -d ${D}${bindir} | ||
35 | install -m 755 ${S}/code/obj.linux64/cst ${D}${bindir}/ | ||
36 | install -m 755 ${S}/code/obj.linux64/srktool ${D}${bindir} | ||
37 | install -m 755 ${S}/add-ons/hab_csf_parser/csf_parser ${D}${bindir} | ||
38 | } | ||
39 | |||
40 | BBCLASSEXTEND = "native nativesdk" | ||