summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2025-03-18 12:42:02 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2025-03-18 12:42:02 -0700
commit792ad7d32b300eb1d421abdbc830df567ae34875 (patch)
tree17849f87cec0919cbc2fbf395b1e3f49c8d34019 /recipes-bsp
parent234230d55184110a65533bdfc0481dfaec056d65 (diff)
downloadmeta-freescale-792ad7d32b300eb1d421abdbc830df567ae34875.tar.gz
imx-uuc: Don't inherit autotools
The do_configure task is failing: ``` ERROR: imx-uuc-0.5.1+git-r1 do_configure: no configure script found at ./configure ``` It appears to be due to this OE-Core change: autotools: require that a configure script exists There's no point inheriting autotools if you're not actually going to run a configure script, so make a missing configure script fatal. https://github.com/openembedded/openembedded-core/commit/6d327a39befae44a88a812bdf4acde800dcee57b imx-uuc doesn't need autotools, just a simple do_install implementation. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-uuc/imx-uuc_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb
index 49fc1558..e245f28b 100644
--- a/recipes-bsp/imx-uuc/imx-uuc_git.bb
+++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb
@@ -6,8 +6,6 @@ DEPENDS = "virtual/kernel dosfstools-native"
6LICENSE = "GPL-2.0-only" 6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9inherit autotools-brokensep
10
11PR = "r1" 9PR = "r1"
12PV = "0.5.1+git${SRCPV}" 10PV = "0.5.1+git${SRCPV}"
13 11
@@ -16,6 +14,10 @@ SRCREV = "9b4adc0cde346fbae743dc21fcf5115488307b83"
16 14
17S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
18 16
17do_install() {
18 oe_runmake 'DESTDIR=${D}' install
19}
20
19FILES:${PN} += "/linuxrc /fat" 21FILES:${PN} += "/linuxrc /fat"
20 22
21COMPATIBLE_MACHINE = "(imx-generic-bsp)" 23COMPATIBLE_MACHINE = "(imx-generic-bsp)"