diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-23 16:02:25 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:59 -0300 |
commit | 6a868a671472d454b407a165fc31c5f7dfe783c6 (patch) | |
tree | 7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch | |
parent | 62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff) | |
download | meta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz |
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc
subdirectory to this layer's root, merging the contents of common
files, subsequent changes are based on top of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch')
-rw-r--r-- | recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch b/recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch new file mode 100644 index 00000000..42de56d3 --- /dev/null +++ b/recipes-extended/testfloat/files/Yocto-replace-COMPILE_PREFIX-gcc.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From 6c7567e05c28b8cb6c7dc68c278950a32feb6f64 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <b28495@freescale.com> | ||
3 | Date: Wed, 9 May 2012 02:42:57 -0500 | ||
4 | Subject: [PATCH] Yocto: replace $(COMPILE_PREFIX)gcc with $(CC) and remove -te500v2 flags | ||
5 | |||
6 | Signed-off-by: Ting Liu <b28495@freescale.com> | ||
7 | --- | ||
8 | SoftFloat-2b/softfloat/bits32/powerpc-GCC/Makefile | 4 ++-- | ||
9 | SoftFloat-2b/softfloat/bits64/powerpc-GCC/Makefile | 4 ++-- | ||
10 | testfloat/powerpc-linux-gcc/Makefile | 8 ++++---- | ||
11 | 3 files changed, 8 insertions(+), 8 deletions(-) | ||
12 | |||
13 | diff --git a/SoftFloat-2b/softfloat/bits32/powerpc-GCC/Makefile b/SoftFloat-2b/softfloat/bits32/powerpc-GCC/Makefile | ||
14 | index 28f1e33..4098048 100644 | ||
15 | --- a/SoftFloat-2b/softfloat/bits32/powerpc-GCC/Makefile | ||
16 | +++ b/SoftFloat-2b/softfloat/bits32/powerpc-GCC/Makefile | ||
17 | @@ -5,8 +5,8 @@ SOFTFLOAT_MACROS = ../softfloat-macros | ||
18 | OBJ = .o | ||
19 | EXE = | ||
20 | INCLUDES = -I. -I.. | ||
21 | -COMPILE_C = $(COMPILE_PREFIX)gcc -msoft-float -c -o $@ $(INCLUDES) -I- -O2 | ||
22 | -LINK = $(COMPILE_PREFIX)gcc -o $@ | ||
23 | +COMPILE_C = $(CC) -msoft-float -c -o $@ $(INCLUDES) -I- -O2 | ||
24 | +LINK = $(CC) -o $@ | ||
25 | |||
26 | ALL: softfloat$(OBJ) timesoftfloat$(EXE) | ||
27 | |||
28 | diff --git a/SoftFloat-2b/softfloat/bits64/powerpc-GCC/Makefile b/SoftFloat-2b/softfloat/bits64/powerpc-GCC/Makefile | ||
29 | index a5e2cc7..c34e16e 100644 | ||
30 | --- a/SoftFloat-2b/softfloat/bits64/powerpc-GCC/Makefile | ||
31 | +++ b/SoftFloat-2b/softfloat/bits64/powerpc-GCC/Makefile | ||
32 | @@ -5,8 +5,8 @@ SOFTFLOAT_MACROS = ../softfloat-macros | ||
33 | OBJ = .o | ||
34 | EXE = | ||
35 | INCLUDES = -I. -I.. | ||
36 | -COMPILE_C = $(COMPILE_PREFIX) -mcpu=8548 -mhard-float -mfloat-gprs=double -o $@ $(INCLUDES) -I- -O2 | ||
37 | -LINK = $(COMPILE_PREFIX) -o $@ | ||
38 | +COMPILE_C = $(CC) -mcpu=8548 -mhard-float -mfloat-gprs=double -o $@ $(INCLUDES) -I- -O2 | ||
39 | +LINK = $(CC) -o $@ | ||
40 | |||
41 | ALL: softfloat$(OBJ) timesoftfloat$(EXE) | ||
42 | |||
43 | diff --git a/testfloat/powerpc-linux-gcc/Makefile b/testfloat/powerpc-linux-gcc/Makefile | ||
44 | index de50aad..1a8b5f7 100644 | ||
45 | --- a/testfloat/powerpc-linux-gcc/Makefile | ||
46 | +++ b/testfloat/powerpc-linux-gcc/Makefile | ||
47 | @@ -8,13 +8,13 @@ OBJ = .o | ||
48 | EXE = | ||
49 | INCLUDES = -I. -I.. -I$(SOFTFLOAT_DIR) | ||
50 | |||
51 | -COMPILE_C = $(COMPILE_PREFIX)gcc -c -o $@ $(INCLUDES) -I- -O $(EXTRA_CFLAGS) | ||
52 | +COMPILE_C = $(CC) -c -o $@ $(INCLUDES) -I- -O $(EXTRA_CFLAGS) | ||
53 | |||
54 | -COMPILE_C_HARD = $(COMPILE_PREFIX)gcc -c -te500v2 -o $@ $(INCLUDES) | ||
55 | +COMPILE_C_HARD = $(CC) -c -o $@ $(INCLUDES) | ||
56 | |||
57 | -COMPILE_SLOWFLOAT_C = $(COMPILE_PREFIX)gcc -c -o $@ $(INCLUDES) -I- -O | ||
58 | +COMPILE_SLOWFLOAT_C = $(CC) -c -o $@ $(INCLUDES) -I- -O | ||
59 | |||
60 | -LINK = $(COMPILE_PREFIX)gcc -lm -o $@ | ||
61 | +LINK = $(CC) -lm -o $@ | ||
62 | |||
63 | SOFTFLOAT_H = $(SOFTFLOAT_DIR)/softfloat.h | ||
64 | SOFTFLOAT_OBJ = $(SOFTFLOAT_DIR)/softfloat$(OBJ) | ||
65 | -- | ||
66 | 1.7.3.4 | ||
67 | |||