diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2024-08-14 09:05:32 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2024-08-14 12:56:04 -0700 |
commit | 81ec8d145bc632e2245467921bd9cfdbc2fc7ff5 (patch) | |
tree | 480143045f0ceda92415eec33b9a6edb9d797298 /recipes-kernel | |
parent | 8335c55ed1f67ad38062dbc7ed35b8ef41466033 (diff) | |
download | meta-freescale-81ec8d145bc632e2245467921bd9cfdbc2fc7ff5.tar.gz |
linux-imx*: Upgrade v6.6.3-1.0.0 -> v6.6.23-2.0.0
Include three backported patches to avoid QA Errors for illegal TMPDIR
references.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-kernel')
5 files changed, 183 insertions, 7 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_6.6.bb b/recipes-kernel/linux/linux-imx-headers_6.6.bb index 95ec32b0..65634ac9 100644 --- a/recipes-kernel/linux/linux-imx-headers_6.6.bb +++ b/recipes-kernel/linux/linux-imx-headers_6.6.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | # Copyright 2017-2023 NXP | 1 | # Copyright 2017-2024 NXP |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | SUMMARY = "Installs i.MX-specific kernel headers" | 4 | SUMMARY = "Installs i.MX-specific kernel headers" |
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | |||
9 | 9 | ||
10 | SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" | 10 | SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" |
11 | SRCBRANCH = "lf-6.6.y" | 11 | SRCBRANCH = "lf-6.6.y" |
12 | LOCALVERSION = "-6.6.3-1.0.0" | 12 | LOCALVERSION = "-6.6.23-2.0.0" |
13 | SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a" | 13 | SRCREV = "b586a521770e508d1d440ccb085c7696b9d6d387" |
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||
diff --git a/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch b/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch new file mode 100644 index 00000000..2933c40e --- /dev/null +++ b/recipes-kernel/linux/linux-imx/0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From 5ef6dc08cfde240b8c748733759185646e654570 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Uwe=20Kleine-K=C3=B6nig?= <u.kleine-koenig@pengutronix.de> | ||
3 | Date: Wed, 13 Mar 2024 22:19:56 +0100 | ||
4 | Subject: [PATCH] lib/build_OID_registry: don't mention the full path of the | ||
5 | script in output | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | This change strips the full path of the script generating | ||
11 | lib/oid_registry_data.c to just lib/build_OID_registry. The motivation | ||
12 | for this change is Yocto emitting a build warning | ||
13 | |||
14 | File /usr/src/debug/linux-lxatac/6.7-r0/lib/oid_registry_data.c in package linux-lxatac-src contains reference to TMPDIR [buildpaths] | ||
15 | |||
16 | So this change brings us one step closer to make the build result | ||
17 | reproducible independent of the build path. | ||
18 | |||
19 | Upstream-Status: Backport [https://github.com/torvalds/linux/commit/5ef6dc08cfde240b8c748733759185646e654570] | ||
20 | |||
21 | Link: https://lkml.kernel.org/r/20240313211957.884561-2-u.kleine-koenig@pengutronix.de | ||
22 | Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de> | ||
23 | Cc: Masahiro Yamada <masahiroy@kernel.org> | ||
24 | Reviewed-by: Nicolas Schier <nicolas@fjasle.eu> | ||
25 | Signed-off-by: Andrew Morton <akpm@linux-foundation.org> | ||
26 | --- | ||
27 | lib/build_OID_registry | 5 ++++- | ||
28 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
29 | |||
30 | diff --git a/lib/build_OID_registry b/lib/build_OID_registry | ||
31 | index d7fc32ea8ac2..56d8bafeb848 100755 | ||
32 | --- a/lib/build_OID_registry | ||
33 | +++ b/lib/build_OID_registry | ||
34 | @@ -8,6 +8,7 @@ | ||
35 | # | ||
36 | |||
37 | use strict; | ||
38 | +use Cwd qw(abs_path); | ||
39 | |||
40 | my @names = (); | ||
41 | my @oids = (); | ||
42 | @@ -17,6 +18,8 @@ if ($#ARGV != 1) { | ||
43 | exit(2); | ||
44 | } | ||
45 | |||
46 | +my $abs_srctree = abs_path($ENV{'srctree'}); | ||
47 | + | ||
48 | # | ||
49 | # Open the file to read from | ||
50 | # | ||
51 | @@ -35,7 +38,7 @@ close IN_FILE || die; | ||
52 | # | ||
53 | open C_FILE, ">$ARGV[1]" or die; | ||
54 | print C_FILE "/*\n"; | ||
55 | -print C_FILE " * Automatically generated by ", $0, ". Do not edit\n"; | ||
56 | +print C_FILE " * Automatically generated by ", $0 =~ s#^\Q$abs_srctree/\E##r, ". Do not edit\n"; | ||
57 | print C_FILE " */\n"; | ||
58 | |||
59 | # | ||
60 | -- | ||
61 | 2.34.1 | ||
62 | |||
diff --git a/recipes-kernel/linux/linux-imx/0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch b/recipes-kernel/linux/linux-imx/0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch new file mode 100644 index 00000000..dbeae515 --- /dev/null +++ b/recipes-kernel/linux/linux-imx/0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | From 3bd85c6c97b2d232638594bf828de62083fe3389 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Uwe=20Kleine-K=C3=B6nig?= <u.kleine-koenig@pengutronix.de> | ||
3 | Date: Mon, 11 Mar 2024 12:30:18 +0100 | ||
4 | Subject: [PATCH] tty: vt: conmakehash: Don't mention the full path of the | ||
5 | input in output | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | This change strips $abs_srctree of the input file containing the | ||
11 | character mapping table in the generated output. The motivation for this | ||
12 | change is Yocto emitting a build warning | ||
13 | |||
14 | WARNING: linux-lxatac-6.7-r0 do_package_qa: QA Issue: File /usr/src/debug/linux-lxatac/6.7-r0/drivers/tty/vt/consolemap_deftbl.c in package linux-lxatac-src contains reference to TMPDIR | ||
15 | |||
16 | So this change brings us one step closer to make the build result | ||
17 | reproducible independent of the build path. | ||
18 | |||
19 | Upstream-Status: Backport [https://github.com/torvalds/linux/commit/3bd85c6c97b2d232638594bf828de62083fe3389] | ||
20 | |||
21 | Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de> | ||
22 | Link: https://lore.kernel.org/r/20240311113017.483101-2-u.kleine-koenig@pengutronix.de | ||
23 | Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org> | ||
24 | --- | ||
25 | drivers/tty/vt/conmakehash.c | 15 +++++++++++++-- | ||
26 | 1 file changed, 13 insertions(+), 2 deletions(-) | ||
27 | |||
28 | diff --git a/drivers/tty/vt/conmakehash.c b/drivers/tty/vt/conmakehash.c | ||
29 | index cddd789fe46e..dc2177fec715 100644 | ||
30 | --- a/drivers/tty/vt/conmakehash.c | ||
31 | +++ b/drivers/tty/vt/conmakehash.c | ||
32 | @@ -76,7 +76,8 @@ static void addpair(int fp, int un) | ||
33 | int main(int argc, char *argv[]) | ||
34 | { | ||
35 | FILE *ctbl; | ||
36 | - char *tblname; | ||
37 | + const char *tblname, *rel_tblname; | ||
38 | + const char *abs_srctree; | ||
39 | char buffer[65536]; | ||
40 | int fontlen; | ||
41 | int i, nuni, nent; | ||
42 | @@ -101,6 +102,16 @@ int main(int argc, char *argv[]) | ||
43 | } | ||
44 | } | ||
45 | |||
46 | + abs_srctree = getenv("abs_srctree"); | ||
47 | + if (abs_srctree && !strncmp(abs_srctree, tblname, strlen(abs_srctree))) | ||
48 | + { | ||
49 | + rel_tblname = tblname + strlen(abs_srctree); | ||
50 | + while (*rel_tblname == '/') | ||
51 | + ++rel_tblname; | ||
52 | + } | ||
53 | + else | ||
54 | + rel_tblname = tblname; | ||
55 | + | ||
56 | /* For now we assume the default font is always 256 characters. */ | ||
57 | fontlen = 256; | ||
58 | |||
59 | @@ -253,7 +264,7 @@ int main(int argc, char *argv[]) | ||
60 | #include <linux/types.h>\n\ | ||
61 | \n\ | ||
62 | u8 dfont_unicount[%d] = \n\ | ||
63 | -{\n\t", argv[1], fontlen); | ||
64 | +{\n\t", rel_tblname, fontlen); | ||
65 | |||
66 | for ( i = 0 ; i < fontlen ; i++ ) | ||
67 | { | ||
68 | -- | ||
69 | 2.34.1 | ||
70 | |||
diff --git a/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch b/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch new file mode 100644 index 00000000..b9ec1be3 --- /dev/null +++ b/recipes-kernel/linux/linux-imx/0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From fb3b9c2d217f1f51fffe19fc0f4eaf55e2d4ea4f Mon Sep 17 00:00:00 2001 | ||
2 | From: Lucas Stach <l.stach@pengutronix.de> | ||
3 | Date: Wed, 10 Apr 2024 15:41:21 +0200 | ||
4 | Subject: [PATCH 6/6] video: logo: Drop full path of the input filename in | ||
5 | generated file | ||
6 | |||
7 | Avoid this Yocto build warning to make build reproducible: | ||
8 | |||
9 | WARNING: linux-foo-6.8-r0 do_package_qa: QA Issue: | ||
10 | File /usr/src/debug/linux-foo/6.8-r0/drivers/video/logo/logo_linux_clut224.c | ||
11 | in package linux-foo-src contains reference to TMPDIR | ||
12 | |||
13 | Helge modified the patch to drop the whole line. | ||
14 | |||
15 | Upstream-Status: Backport [https://github.com/torvalds/linux/commit/fb3b9c2d217f1f51fffe19fc0f4eaf55e2d4ea4f] | ||
16 | |||
17 | Signed-off-by: Lucas Stach <l.stach@pengutronix.de> | ||
18 | Signed-off-by: Helge Deller <deller@gmx.de> | ||
19 | --- | ||
20 | drivers/video/logo/pnmtologo.c | 2 -- | ||
21 | 1 file changed, 2 deletions(-) | ||
22 | |||
23 | diff --git a/drivers/video/logo/pnmtologo.c b/drivers/video/logo/pnmtologo.c | ||
24 | index 2434a25afb64..8080c4d9c4a2 100644 | ||
25 | --- a/drivers/video/logo/pnmtologo.c | ||
26 | +++ b/drivers/video/logo/pnmtologo.c | ||
27 | @@ -235,8 +235,6 @@ static void write_header(void) | ||
28 | fputs("/*\n", out); | ||
29 | fputs(" * DO NOT EDIT THIS FILE!\n", out); | ||
30 | fputs(" *\n", out); | ||
31 | - fprintf(out, " * It was automatically generated from %s\n", filename); | ||
32 | - fputs(" *\n", out); | ||
33 | fprintf(out, " * Linux logo %s\n", logoname); | ||
34 | fputs(" */\n\n", out); | ||
35 | fputs("#include <linux/linux_logo.h>\n\n", out); | ||
36 | -- | ||
37 | 2.34.1 | ||
38 | |||
diff --git a/recipes-kernel/linux/linux-imx_6.6.bb b/recipes-kernel/linux/linux-imx_6.6.bb index 409e1f66..b90b40d3 100644 --- a/recipes-kernel/linux/linux-imx_6.6.bb +++ b/recipes-kernel/linux/linux-imx_6.6.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # Copyright 2013-2016 (C) Freescale Semiconductor | 1 | # Copyright 2013-2016 (C) Freescale Semiconductor |
2 | # Copyright 2017-2023 (C) NXP | 2 | # Copyright 2017-2024 (C) NXP |
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | 3 | # Copyright 2018 (C) O.S. Systems Software LTDA. |
4 | # Released under the MIT license (see COPYING.MIT for the terms) | 4 | # Released under the MIT license (see COPYING.MIT for the terms) |
5 | # | 5 | # |
@@ -13,15 +13,21 @@ i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU | |||
13 | require recipes-kernel/linux/linux-imx.inc | 13 | require recipes-kernel/linux/linux-imx.inc |
14 | 14 | ||
15 | SRCBRANCH = "lf-6.6.y" | 15 | SRCBRANCH = "lf-6.6.y" |
16 | LOCALVERSION = "-6.6.3-1.0.0" | 16 | LOCALVERSION = "-6.6.23-2.0.0" |
17 | SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a" | 17 | SRCREV = "b586a521770e508d1d440ccb085c7696b9d6d387" |
18 | |||
19 | SRC_URI += " \ | ||
20 | file://0001-tty-vt-conmakehash-Don-t-mention-the-full-path-of-th.patch \ | ||
21 | file://0001-lib-build_OID_registry-don-t-mention-the-full-path-o.patch \ | ||
22 | file://0001-video-logo-Drop-full-path-of-the-input-filename-in-g.patch \ | ||
23 | " | ||
18 | 24 | ||
19 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 25 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
20 | # required by kernel-yocto.bbclass. | 26 | # required by kernel-yocto.bbclass. |
21 | # | 27 | # |
22 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 28 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
23 | # should be updated once patchlevel is merged. | 29 | # should be updated once patchlevel is merged. |
24 | LINUX_VERSION = "6.6.3" | 30 | LINUX_VERSION = "6.6.23" |
25 | 31 | ||
26 | KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" | 32 | KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" |
27 | KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" | 33 | KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" |