diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2024-04-26 13:23:26 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2024-04-26 13:23:26 -0700 |
commit | d29e7efe84ed773152e3935e420c3b77ceb7c68a (patch) | |
tree | 57b613665fad848d632b1a97cf5f269622e8db3d /recipes-multimedia | |
parent | d92b0e3884fff63eded32318afff5d02fa45fe4e (diff) | |
download | meta-freescale-d29e7efe84ed773152e3935e420c3b77ceb7c68a.tar.gz |
gstreamer: Use upstream recipes
The downgraded recipes are no longer needed.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia')
7 files changed, 0 insertions, 329 deletions
diff --git a/recipes-multimedia/gstreamer/gst-devtools_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gst-devtools_1.22.0.imx.bb deleted file mode 100644 index 4006f3eb..00000000 --- a/recipes-multimedia/gstreamer/gst-devtools_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | SUMMARY = "Gstreamer validation tool" | ||
2 | DESCRIPTION = "A Tool to test GStreamer components" | ||
3 | HOMEPAGE = "https://gstreamer.freedesktop.org/documentation/gst-devtools/index.html" | ||
4 | SECTION = "multimedia" | ||
5 | |||
6 | LICENSE = "LGPL-2.1-or-later" | ||
7 | LIC_FILES_CHKSUM = "file://validate/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" | ||
8 | |||
9 | S = "${WORKDIR}/gst-devtools-${@get_gst_ver('${PV}')}" | ||
10 | |||
11 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-${@get_gst_ver('${PV}')}.tar.xz \ | ||
12 | file://0001-connect-has-a-different-signature-on-musl.patch \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[sha256sum] = "4d21fee5c15f2877c0b1f6c2da0cdba67ce7caab2c199ab27e91a1394d5ba195" | ||
16 | |||
17 | DEPENDS = "json-glib glib-2.0 glib-2.0-native gstreamer1.0 gstreamer1.0-plugins-base" | ||
18 | RRECOMMENDS:${PN} = "git" | ||
19 | |||
20 | FILES:${PN} += "${datadir}/gstreamer-1.0/* ${libdir}/gst-validate-launcher/* ${libdir}/gstreamer-1.0/*" | ||
21 | |||
22 | inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection | ||
23 | |||
24 | # Drop .imx from PV | ||
25 | def get_gst_ver(v): | ||
26 | return oe.utils.trim_version(v, 3) | ||
27 | |||
28 | # TODO: put this in a gettext.bbclass patch | ||
29 | def gettext_oemeson(d): | ||
30 | if d.getVar('USE_NLS') == 'no': | ||
31 | return '-Dnls=disabled' | ||
32 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set | ||
33 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): | ||
34 | return '-Dnls=disabled' | ||
35 | return '-Dnls=enabled' | ||
36 | |||
37 | # Build GstValidateVideo | ||
38 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" | ||
39 | |||
40 | EXTRA_OEMESON += " \ | ||
41 | -Ddoc=disabled \ | ||
42 | -Ddebug_viewer=disabled \ | ||
43 | -Dtests=disabled \ | ||
44 | -Dvalidate=enabled \ | ||
45 | ${@gettext_oemeson(d)} \ | ||
46 | " | ||
47 | |||
48 | do_install:append () { | ||
49 | for fn in ${bindir}/gst-validate-launcher \ | ||
50 | ${libdir}/gst-validate-launcher/python/launcher/config.py; do | ||
51 | sed -i -e 's,${B},/usr/src/debug/${PN},g' -e 's,${S},/usr/src/debug/${PN},g' ${D}$fn | ||
52 | done | ||
53 | } | ||
54 | |||
55 | GIR_MESON_ENABLE_FLAG = "enabled" | ||
56 | GIR_MESON_DISABLE_FLAG = "disabled" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.22.0.imx.bb deleted file mode 100644 index 742004d8..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | SUMMARY = "Libav-based GStreamer 1.x plugin" | ||
2 | DESCRIPTION = "Contains a GStreamer plugin for using the encoders, decoders, \ | ||
3 | muxers, and demuxers provided by FFmpeg." | ||
4 | HOMEPAGE = "http://gstreamer.freedesktop.org/" | ||
5 | SECTION = "multimedia" | ||
6 | |||
7 | # ffmpeg has comercial license flags so add it as we need ffmpeg as a dependency | ||
8 | LICENSE_FLAGS = "commercial" | ||
9 | LICENSE = "LGPL-2.1-or-later" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770 \ | ||
11 | file://ext/libav/gstav.h;beginline=1;endline=18;md5=a752c35267d8276fd9ca3db6994fca9c \ | ||
12 | " | ||
13 | |||
14 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${@get_gst_ver('${PV}')}.tar.xz \ | ||
15 | file://ffmpeg-6.0.patch \ | ||
16 | " | ||
17 | SRC_URI[sha256sum] = "0e48407b4905227a260213dbda84cba3812f0530fc7a75b43829102ef82810f1" | ||
18 | |||
19 | S = "${WORKDIR}/gst-libav-${@get_gst_ver('${PV}')}" | ||
20 | |||
21 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base ffmpeg" | ||
22 | |||
23 | inherit meson pkgconfig upstream-version-is-even | ||
24 | |||
25 | EXTRA_OEMESON += " \ | ||
26 | -Dtests=disabled \ | ||
27 | " | ||
28 | |||
29 | # Drop .imx from PV | ||
30 | def get_gst_ver(v): | ||
31 | return oe.utils.trim_version(v, 3) | ||
32 | |||
33 | FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" | ||
34 | FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
35 | |||
36 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.0.imx.bb deleted file mode 100644 index dc4bccd7..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | SUMMARY = "OpenMAX IL plugins for GStreamer" | ||
2 | DESCRIPTION = "Wraps available OpenMAX IL components and makes them available as standard GStreamer elements." | ||
3 | HOMEPAGE = "http://gstreamer.freedesktop.org/" | ||
4 | SECTION = "multimedia" | ||
5 | |||
6 | LICENSE = "LGPL-2.1-or-later" | ||
7 | LICENSE_FLAGS = "commercial" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ | ||
9 | file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f" | ||
10 | |||
11 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${@get_gst_ver('${PV}')}.tar.xz" | ||
12 | |||
13 | SRC_URI[sha256sum] = "dbc951a99af532380e599aa8acd9e1385fdb299b46b5868cd2be4230ad888341" | ||
14 | |||
15 | S = "${WORKDIR}/gst-omx-${@get_gst_ver('${PV}')}" | ||
16 | |||
17 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil" | ||
18 | |||
19 | inherit meson pkgconfig upstream-version-is-even | ||
20 | |||
21 | GSTREAMER_1_0_OMX_TARGET ?= "bellagio" | ||
22 | GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0" | ||
23 | |||
24 | EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}" | ||
25 | |||
26 | python __anonymous () { | ||
27 | omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET") | ||
28 | if omx_target in ['generic', 'bellagio']: | ||
29 | # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,# | ||
30 | # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros); | ||
31 | # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this | ||
32 | d.appendVar("CFLAGS", " -I${S}/omx/openmax") | ||
33 | elif omx_target == "rpi": | ||
34 | # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific | ||
35 | d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH")) | ||
36 | } | ||
37 | |||
38 | set_omx_core_name() { | ||
39 | sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf" | ||
40 | } | ||
41 | |||
42 | # Drop .imx from PV | ||
43 | def get_gst_ver(v): | ||
44 | return oe.utils.trim_version(v, 3) | ||
45 | |||
46 | do_install[postfuncs] += " set_omx_core_name " | ||
47 | |||
48 | FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" | ||
49 | FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
50 | |||
51 | VIRTUAL-RUNTIME_libomxil ?= "libomxil" | ||
52 | RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_libomxil}" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.22.0.imx.bb deleted file mode 100644 index 17522a93..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | require gstreamer1.0-plugins-common.inc | ||
2 | require gstreamer1.0-plugins-license.inc | ||
3 | |||
4 | SUMMARY = "'Ugly GStreamer plugins" | ||
5 | HOMEPAGE = "https://gstreamer.freedesktop.org/" | ||
6 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly/-/issues" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ | ||
9 | " | ||
10 | |||
11 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later" | ||
12 | LICENSE_FLAGS = "commercial" | ||
13 | |||
14 | SRC_URI = " \ | ||
15 | https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${@get_gst_ver("${PV}")}.tar.xz \ | ||
16 | " | ||
17 | SRC_URI[sha256sum] = "a644dc981afa2d8d3a913f763ab9523c0620ee4e65a7ec73c7721c29da3c5a0c" | ||
18 | |||
19 | S = "${WORKDIR}/gst-plugins-ugly-${@get_gst_ver("${PV}")}" | ||
20 | |||
21 | DEPENDS += "gstreamer1.0-plugins-base" | ||
22 | |||
23 | GST_PLUGIN_SET_HAS_EXAMPLES = "0" | ||
24 | |||
25 | PACKAGECONFIG ??= " \ | ||
26 | ${GSTREAMER_ORC} \ | ||
27 | a52dec mpeg2dec \ | ||
28 | " | ||
29 | |||
30 | PACKAGECONFIG[amrnb] = "-Damrnb=enabled,-Damrnb=disabled,opencore-amr" | ||
31 | PACKAGECONFIG[amrwb] = "-Damrwbdec=enabled,-Damrwbdec=disabled,opencore-amr" | ||
32 | PACKAGECONFIG[a52dec] = "-Da52dec=enabled,-Da52dec=disabled,liba52" | ||
33 | PACKAGECONFIG[cdio] = "-Dcdio=enabled,-Dcdio=disabled,libcdio" | ||
34 | PACKAGECONFIG[dvdread] = "-Ddvdread=enabled,-Ddvdread=disabled,libdvdread" | ||
35 | PACKAGECONFIG[mpeg2dec] = "-Dmpeg2dec=enabled,-Dmpeg2dec=disabled,mpeg2dec" | ||
36 | PACKAGECONFIG[x264] = "-Dx264=enabled,-Dx264=disabled,x264" | ||
37 | |||
38 | GSTREAMER_GPL = "${@bb.utils.filter('PACKAGECONFIG', 'a52dec cdio dvdread mpeg2dec x264', d)}" | ||
39 | |||
40 | EXTRA_OEMESON += " \ | ||
41 | -Ddoc=disabled \ | ||
42 | -Dsidplay=disabled \ | ||
43 | " | ||
44 | |||
45 | # Drop .imx from PV | ||
46 | def get_gst_ver(v): | ||
47 | return oe.utils.trim_version(v, 3) | ||
48 | |||
49 | FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs" | ||
50 | FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs" | ||
51 | |||
52 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-python_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-python_1.22.0.imx.bb deleted file mode 100644 index 6f38929a..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-python_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | SUMMARY = "Python bindings for GStreamer 1.0" | ||
2 | DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \ | ||
3 | provided by python-gi) " | ||
4 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" | ||
5 | SECTION = "multimedia" | ||
6 | |||
7 | LICENSE = "LGPL-2.1-or-later" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" | ||
9 | |||
10 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${@get_gst_ver('${PV}')}.tar.xz" | ||
11 | SRC_URI[sha256sum] = "6c63ad364ca4617eb2cbb3975ab26c66760eb3c7a6adf5be69f99c11e21ef3a5" | ||
12 | |||
13 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" | ||
14 | RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" | ||
15 | |||
16 | PNREAL = "gst-python" | ||
17 | |||
18 | S = "${WORKDIR}/${PNREAL}-${@get_gst_ver('${PV}')}" | ||
19 | |||
20 | EXTRA_OEMESON += "\ | ||
21 | -Dtests=disabled \ | ||
22 | -Dplugin=enabled \ | ||
23 | -Dlibpython-dir=${libdir} \ | ||
24 | " | ||
25 | |||
26 | # Drop .imx from PV | ||
27 | def get_gst_ver(v): | ||
28 | return oe.utils.trim_version(v, 3) | ||
29 | |||
30 | inherit meson pkgconfig setuptools3-base upstream-version-is-even | ||
31 | |||
32 | FILES:${PN} += "${libdir}/gstreamer-1.0" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.22.0.imx.bb deleted file mode 100644 index d569ea9f..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | SUMMARY = "A library on top of GStreamer for building an RTSP server" | ||
2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/" | ||
3 | SECTION = "multimedia" | ||
4 | LICENSE = "LGPL-2.1-or-later" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770" | ||
6 | |||
7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base" | ||
8 | |||
9 | PNREAL = "gst-rtsp-server" | ||
10 | |||
11 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${@get_gst_ver("${PV}")}.tar.xz" | ||
12 | |||
13 | SRC_URI[sha256sum] = "aea24eeb59ee5fadfac355de2f7cecb51966c3e147e5ad7cfb4c314f1a4086ed" | ||
14 | |||
15 | S = "${WORKDIR}/${PNREAL}-${@get_gst_ver("${PV}")}" | ||
16 | |||
17 | inherit meson pkgconfig upstream-version-is-even gobject-introspection | ||
18 | |||
19 | EXTRA_OEMESON += " \ | ||
20 | -Ddoc=disabled \ | ||
21 | -Dexamples=disabled \ | ||
22 | -Dtests=disabled \ | ||
23 | " | ||
24 | |||
25 | GIR_MESON_ENABLE_FLAG = "enabled" | ||
26 | GIR_MESON_DISABLE_FLAG = "disabled" | ||
27 | |||
28 | # Drop .imx from PV | ||
29 | def get_gst_ver(v): | ||
30 | return oe.utils.trim_version(v, 3) | ||
31 | |||
32 | # Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well | ||
33 | require gstreamer1.0-plugins-packaging.inc | ||
34 | |||
35 | CVE_PRODUCT += "gst-rtsp-server" | ||
36 | |||
37 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb deleted file mode 100644 index 02dc86e4..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | SUMMARY = "VA-API support to GStreamer" | ||
2 | HOMEPAGE = "https://gstreamer.freedesktop.org/" | ||
3 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ | ||
4 | based plugins for GStreamer and helper libraries: `vaapidecode', \ | ||
5 | `vaapiconvert', and `vaapisink'." | ||
6 | |||
7 | REALPN = "gstreamer-vaapi" | ||
8 | |||
9 | LICENSE = "LGPL-2.1-or-later" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" | ||
11 | |||
12 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${@get_gst_ver('${PV}')}.tar.xz" | ||
13 | |||
14 | SRC_URI[sha256sum] = "593ccad19f88e5fa29f40f98356c007806bd535828707b1406944d16a90bdff5" | ||
15 | |||
16 | S = "${WORKDIR}/${REALPN}-${@get_gst_ver('${PV}')}" | ||
17 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
18 | |||
19 | inherit meson pkgconfig features_check upstream-version-is-even | ||
20 | |||
21 | REQUIRED_DISTRO_FEATURES ?= "opengl" | ||
22 | |||
23 | EXTRA_OEMESON += " \ | ||
24 | -Ddoc=disabled \ | ||
25 | -Dexamples=disabled \ | ||
26 | -Dtests=enabled \ | ||
27 | " | ||
28 | |||
29 | # Drop .imx from PV | ||
30 | def get_gst_ver(v): | ||
31 | return oe.utils.trim_version(v, 3) | ||
32 | |||
33 | PACKAGES =+ "${PN}-tests" | ||
34 | |||
35 | # OpenGL packageconfig factored out to make it easy for distros | ||
36 | # and BSP layers to pick either glx, egl, or no GL. By default, | ||
37 | # try detecting X11 first, and if found (with OpenGL), use GLX, | ||
38 | # otherwise try to check if EGL can be used. | ||
39 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ | ||
40 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ | ||
41 | '', d), d)}" | ||
42 | |||
43 | PACKAGECONFIG ??= "drm encoders \ | ||
44 | ${PACKAGECONFIG_GL} \ | ||
45 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" | ||
46 | |||
47 | PACKAGECONFIG[drm] = "-Ddrm=enabled,-Ddrm=disabled,udev libdrm" | ||
48 | PACKAGECONFIG[egl] = "-Degl=enabled,-Degl=disabled,virtual/egl" | ||
49 | PACKAGECONFIG[encoders] = "-Dencoders=enabled,-Dencoders=disabled" | ||
50 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/libgl" | ||
51 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols" | ||
52 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,virtual/libx11 libxrandr libxrender" | ||
53 | |||
54 | FILES:${PN} += "${libdir}/gstreamer-*/*.so" | ||
55 | FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug" | ||
56 | FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a" | ||
57 | FILES:${PN}-tests = "${bindir}/*" | ||
58 | |||
59 | # correct .pc install location - fixed in upstream trunk | ||
60 | do_install:append() { | ||
61 | mkdir -p ${D}/${libdir}/pkgconfig | ||
62 | mv ${D}/${libdir}/gstreamer-1.0/pkgconfig/*.pc ${D}/${libdir}/pkgconfig | ||
63 | rmdir ${D}/${libdir}/gstreamer-1.0/pkgconfig/ | ||
64 | } | ||