summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2024-10-22 09:27:41 -0300
committerDaiane Angolini <daiane.angolini@foundries.io>2024-10-22 09:27:41 -0300
commit9cb48dfa57d96ba1254c2380c531331eb755b7e7 (patch)
tree0dba78723acb83483da027dd92476e6cd8b8386c /recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch
parent12fc8f4da4677d60404acb116a3dbce6366102cf (diff)
downloadmeta-freescale-wip-optee-os-fix.tar.gz
WIP: optee-oswip-optee-os-fix
Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
Diffstat (limited to 'recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch')
-rw-r--r--recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch b/recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch
new file mode 100644
index 00000000..ecea9148
--- /dev/null
+++ b/recipes-security/optee-imx/optee-os/0001-mk-compile.mk-remove-absolute-build-time-paths.patch
@@ -0,0 +1,52 @@
1From 29b84ae5b277b85cd7244acde077694e6643fcde Mon Sep 17 00:00:00 2001
2From: Mikko Rapeli <mikko.rapeli@linaro.org>
3Date: Thu, 18 Jul 2024 07:54:18 +0000
4Subject: [PATCH] mk/compile.mk: remove absolute build time paths
5
6Some generated files get a __FILE_ID__ which include absolute
7build time paths. Remove the paths and use plain file name.
8Fixes yocto QA check.
9
10Problem/bug:
11
12$ strings ../image/lib/firmware/tee.elf | grep mikko
13__FILE_ID__
14_home_mikko_build_core_ta_pub_key_c
15__FILE_ID__
16_home_mikko_build_core_ldelf_hex_c
17__FILE_ID__
18_home_mikko_build_core_early_ta_fd02c9da_306c_48c7_a49c_bbd827ae86ee_c
19
20With this patch:
21
22$ strings ../image/lib/firmware/tee.elf | grep mikko
23$ strings ../image/lib/firmware/tee.elf | grep FILE_ID | egrep \
24"core_ta_pub_key_c|core_ldelf_hex_c|core_early_ta_fd02c9da_306c_4"
25__FILE_ID__ core_ta_pub_key_c
26__FILE_ID__ core_ldelf_hex_c
27__FILE_ID__ core_early_ta_fd02c9da_306c_48c7_a49c_bbd827ae86ee_c
28
29Reviewed-by: Jens Wiklander <jens.wiklander@linaro.org>
30Acked-by: Jerome Forissier <jerome.forissier@linaro.org>
31Signed-off-by: Mikko Rapeli <mikko.rapeli@linaro.org>
32---
33 mk/compile.mk | 2 +-
34 1 file changed, 1 insertion(+), 1 deletion(-)
35
36Upstream-Status: Backport
37
38diff --git a/mk/compile.mk b/mk/compile.mk
39index b3d807ba4..338535bf3 100644
40--- a/mk/compile.mk
41+++ b/mk/compile.mk
42@@ -120,7 +120,7 @@ comp-cppflags-$2 = $$(filter-out $$(CPPFLAGS_REMOVE) $$(cppflags-remove) \
43 $$(addprefix -I,$$(incdirs-$2)) \
44 $$(cppflags$$(comp-sm-$2)) \
45 $$(cppflags-lib$$(comp-lib-$2)) $$(cppflags-$2)) \
46- -D__FILE_ID__=$$(subst -,_,$$(subst /,_,$$(subst .,_,$1)))
47+ -D__FILE_ID__=$$(subst -,_,$$(subst /,_,$$(subst .,_,$$(patsubst $$(out-dir)/%,%,$1))))
48
49 comp-flags-$2 += -MD -MF $$(comp-dep-$2) -MT $$@
50 comp-flags-$2 += $$(comp-cppflags-$2)
51--
522.34.1