diff options
author | André Draszik <andre.draszik@jci.com> | 2019-12-24 08:23:32 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-01-08 16:12:06 -0300 |
commit | 8b51ea3dafe9c5ac667a918911fb8f1050fc8897 (patch) | |
tree | 76093070fbfb8c78f5a1736ee9c6508f5895438d /recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch | |
parent | 241312a74438e69063fcc67d91517dc90fa96065 (diff) | |
download | meta-freescale-8b51ea3dafe9c5ac667a918911fb8f1050fc8897.tar.gz |
optee-imx: add (backported) patches for GCC 9 & musl
See the individual patches - all patches are simply
backports from optee upstream releases.
Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch')
-rw-r--r-- | recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch b/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch new file mode 100644 index 00000000..ed45df60 --- /dev/null +++ b/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From 1401b89684ee81bf0b3d3dea06e2926b24ba3f97 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <andre.draszik@jci.com> | ||
3 | Date: Thu, 7 Feb 2019 01:29:08 +0000 | ||
4 | Subject: [PATCH 2/3] build: ignore declaration-after-statement warnings | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | | Makefile:37: recipe for target 'xtest' failed | ||
10 | | make: *** [xtest] Error 2 | ||
11 | | make: *** Waiting for unfinished jobs.... | ||
12 | | arith_taf.c: In function 'get_handle': | ||
13 | | arith_taf.c:56:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
14 | | int h = handle_get(&hdb, ptr); | ||
15 | | ^~~ | ||
16 | | arith_taf.c: In function 'ta_entry_arith_new_var': | ||
17 | | arith_taf.c:82:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
18 | | size_t len = TEE_BigIntSizeInU32(params[0].value.a); | ||
19 | | ^~~~~~ | ||
20 | | arith_taf.c: In function 'ta_entry_arith_new_fmm_var': | ||
21 | | arith_taf.c:129:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
22 | | size_t len = TEE_BigIntFMMSizeInU32(params[0].value.a); | ||
23 | | ^~~~~~ | ||
24 | | arith_taf.c: In function 'ta_entry_arith_free_handle': | ||
25 | | arith_taf.c:150:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
26 | | void *ptr = put_handle(params[0].value.a & ~HT_MASK); | ||
27 | | ^~~~ | ||
28 | | arith_taf.c: In function 'ta_entry_arith_from_octet_string': | ||
29 | | arith_taf.c:165:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
30 | | TEE_BigInt *big_int = lookup_handle(HT_BIGINT, params[0].value.a); | ||
31 | | ^~~~~~~~~~ | ||
32 | | arith_taf.c: In function 'ta_entry_arith_from_s32': | ||
33 | | arith_taf.c:181:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement] | ||
34 | | TEE_BigInt *big_int = lookup_handle(HT_BIGINT, params[0].value.a); | ||
35 | | ^~~~~~~~~~ | ||
36 | |||
37 | etc. | ||
38 | |||
39 | Signed-off-by: André Draszik <andre.draszik@jci.com> | ||
40 | Acked-by: Jens Wiklander <jens.wiklander@linaro.org> | ||
41 | Reviewed-by: Jerome Forissier <jerome.forissier@linaro.org> | ||
42 | --- | ||
43 | Signed-off-by: André Draszik <andre.draszik@jci.com> | ||
44 | Upstream-Status: Backport [3.5.0] | ||
45 | host/xtest/Makefile | 1 + | ||
46 | 1 file changed, 1 insertion(+) | ||
47 | |||
48 | diff --git a/host/xtest/Makefile b/host/xtest/Makefile | ||
49 | index f4291e0..e97e555 100644 | ||
50 | --- a/host/xtest/Makefile | ||
51 | +++ b/host/xtest/Makefile | ||
52 | @@ -154,6 +154,7 @@ CFLAGS += -Wall -Wcast-align -Werror \ | ||
53 | -Wmissing-prototypes -Wnested-externs -Wpointer-arith \ | ||
54 | -Wshadow -Wstrict-prototypes -Wswitch-default \ | ||
55 | -Wwrite-strings \ | ||
56 | + -Wno-declaration-after-statement \ | ||
57 | -Wno-missing-field-initializers -Wno-format-zero-length | ||
58 | endif | ||
59 | |||
60 | -- | ||
61 | 2.23.0.rc1 | ||
62 | |||