summaryrefslogtreecommitdiffstats
path: root/scripts/generate-license-file
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2025-04-01 14:56:00 -0300
committerGitHub <noreply@github.com>2025-04-01 14:56:00 -0300
commit02743af87d6ad6b3571a992eb8c5dff00faddb42 (patch)
tree0317f5c4b01c538ca43d8661b0ebc861305bfc8e /scripts/generate-license-file
parent501032fb30abbad54616a2d9bb4555c297fc35b6 (diff)
parentf7bd7c06b3daad80d41ea24e667b844120e505bb (diff)
downloadmeta-freescale-dunfell.tar.gz
Merge pull request #2177 from mdrodrigo/topic/dunfelldunfell
Add update-license-file in dunfell branch
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-xscripts/generate-license-file18
1 files changed, 18 insertions, 0 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file
new file mode 100755
index 00000000..b6d43cd9
--- /dev/null
+++ b/scripts/generate-license-file
@@ -0,0 +1,18 @@
1#!/bin/bash
2
3# Create or clear the LICENSE file
4echo "# License Information" > LICENSE
5echo "" >> LICENSE
6echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE
7echo "" >> LICENSE
8
9# Find all .bb and .inc files and extract license information
10find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do
11 # Extract the license line from each recipe file, if it exists
12 license_line=$(grep -i "^LICENSE" "$file")
13 if [ -n "$license_line" ]; then
14 echo "$file: $license_line" >> LICENSE
15 fi
16done
17
18echo "LICENSE file has been generated and updated with current recipe licenses."