diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-04-01 14:56:00 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-04-01 14:56:00 -0300 |
commit | 02743af87d6ad6b3571a992eb8c5dff00faddb42 (patch) | |
tree | 0317f5c4b01c538ca43d8661b0ebc861305bfc8e /scripts/generate-license-file | |
parent | 501032fb30abbad54616a2d9bb4555c297fc35b6 (diff) | |
parent | f7bd7c06b3daad80d41ea24e667b844120e505bb (diff) | |
download | meta-freescale-dunfell.tar.gz |
Merge pull request #2177 from mdrodrigo/topic/dunfelldunfell
Add update-license-file in dunfell branch
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-x | scripts/generate-license-file | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file new file mode 100755 index 00000000..b6d43cd9 --- /dev/null +++ b/scripts/generate-license-file | |||
@@ -0,0 +1,18 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | # Create or clear the LICENSE file | ||
4 | echo "# License Information" > LICENSE | ||
5 | echo "" >> LICENSE | ||
6 | echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE | ||
7 | echo "" >> LICENSE | ||
8 | |||
9 | # Find all .bb and .inc files and extract license information | ||
10 | find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do | ||
11 | # Extract the license line from each recipe file, if it exists | ||
12 | license_line=$(grep -i "^LICENSE" "$file") | ||
13 | if [ -n "$license_line" ]; then | ||
14 | echo "$file: $license_line" >> LICENSE | ||
15 | fi | ||
16 | done | ||
17 | |||
18 | echo "LICENSE file has been generated and updated with current recipe licenses." | ||