summaryrefslogtreecommitdiffstats
path: root/scripts/generate-license-file
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2025-04-01 14:34:45 -0300
committerGitHub <noreply@github.com>2025-04-01 14:34:45 -0300
commit3a2b7166425579d1fba35a45072d23c6d927751d (patch)
tree2b9ec350bdd22d48aa6a9b83e7c31d773cede8ad /scripts/generate-license-file
parent5d71d4f20f8b676fc5308141f8f5002745b7d20e (diff)
parentf3fd802ed59e88bac10d5aa9178c4f33aa44fa48 (diff)
downloadmeta-freescale-mickledore.tar.gz
Merge pull request #2172 from mdrodrigo/topic/mickledoremickledore
Add update-license-file in mickledore branch
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-xscripts/generate-license-file18
1 files changed, 18 insertions, 0 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file
new file mode 100755
index 00000000..b6d43cd9
--- /dev/null
+++ b/scripts/generate-license-file
@@ -0,0 +1,18 @@
1#!/bin/bash
2
3# Create or clear the LICENSE file
4echo "# License Information" > LICENSE
5echo "" >> LICENSE
6echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE
7echo "" >> LICENSE
8
9# Find all .bb and .inc files and extract license information
10find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do
11 # Extract the license line from each recipe file, if it exists
12 license_line=$(grep -i "^LICENSE" "$file")
13 if [ -n "$license_line" ]; then
14 echo "$file: $license_line" >> LICENSE
15 fi
16done
17
18echo "LICENSE file has been generated and updated with current recipe licenses."