summaryrefslogtreecommitdiffstats
path: root/scripts/generate-license-file
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2025-04-02 12:47:39 -0300
committerGitHub <noreply@github.com>2025-04-02 12:47:39 -0300
commit5c042cc7edc0742f07eeef6a9e7bffef509d3a27 (patch)
tree1e76391343c3ccbd45c2494fedfc7c35c741182f /scripts/generate-license-file
parent4bfe03290aeae26446c3a271fb999179f71d5bfd (diff)
parentf8c8fc73c4e482525111fc677fb24878c68392cf (diff)
downloadmeta-freescale-5c042cc7edc0742f07eeef6a9e7bffef509d3a27.tar.gz
Merge pull request #2181 from mdrodrigo/topic/scarthgap-update
Scarthgap branch update
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-xscripts/generate-license-file6
1 files changed, 4 insertions, 2 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file
index b6d43cd9..02b45ab3 100755
--- a/scripts/generate-license-file
+++ b/scripts/generate-license-file
@@ -1,13 +1,15 @@
1#!/bin/bash 1#!/bin/bash
2 2
3export LC_ALL=C
4
3# Create or clear the LICENSE file 5# Create or clear the LICENSE file
4echo "# License Information" > LICENSE 6echo "# License Information" > LICENSE
5echo "" >> LICENSE 7echo "" >> LICENSE
6echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE 8echo "This file lists all licenses used by recipes in the meta-freescale layer." >> LICENSE
7echo "" >> LICENSE 9echo "" >> LICENSE
8 10
9# Find all .bb and .inc files and extract license information 11# Find all .bb and .inc files and extract license information
10find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do 12find . -type f \( -name "*.bb" -o -name "*.inc" \) | sort | while read -r file; do
11 # Extract the license line from each recipe file, if it exists 13 # Extract the license line from each recipe file, if it exists
12 license_line=$(grep -i "^LICENSE" "$file") 14 license_line=$(grep -i "^LICENSE" "$file")
13 if [ -n "$license_line" ]; then 15 if [ -n "$license_line" ]; then