diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-04-02 12:47:39 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-04-02 12:47:39 -0300 |
commit | 5c042cc7edc0742f07eeef6a9e7bffef509d3a27 (patch) | |
tree | 1e76391343c3ccbd45c2494fedfc7c35c741182f /scripts/generate-license-file | |
parent | 4bfe03290aeae26446c3a271fb999179f71d5bfd (diff) | |
parent | f8c8fc73c4e482525111fc677fb24878c68392cf (diff) | |
download | meta-freescale-5c042cc7edc0742f07eeef6a9e7bffef509d3a27.tar.gz |
Merge pull request #2181 from mdrodrigo/topic/scarthgap-update
Scarthgap branch update
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-x | scripts/generate-license-file | 6 |
1 files changed, 4 insertions, 2 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file index b6d43cd9..02b45ab3 100755 --- a/scripts/generate-license-file +++ b/scripts/generate-license-file | |||
@@ -1,13 +1,15 @@ | |||
1 | #!/bin/bash | 1 | #!/bin/bash |
2 | 2 | ||
3 | export LC_ALL=C | ||
4 | |||
3 | # Create or clear the LICENSE file | 5 | # Create or clear the LICENSE file |
4 | echo "# License Information" > LICENSE | 6 | echo "# License Information" > LICENSE |
5 | echo "" >> LICENSE | 7 | echo "" >> LICENSE |
6 | echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE | 8 | echo "This file lists all licenses used by recipes in the meta-freescale layer." >> LICENSE |
7 | echo "" >> LICENSE | 9 | echo "" >> LICENSE |
8 | 10 | ||
9 | # Find all .bb and .inc files and extract license information | 11 | # Find all .bb and .inc files and extract license information |
10 | find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do | 12 | find . -type f \( -name "*.bb" -o -name "*.inc" \) | sort | while read -r file; do |
11 | # Extract the license line from each recipe file, if it exists | 13 | # Extract the license line from each recipe file, if it exists |
12 | license_line=$(grep -i "^LICENSE" "$file") | 14 | license_line=$(grep -i "^LICENSE" "$file") |
13 | if [ -n "$license_line" ]; then | 15 | if [ -n "$license_line" ]; then |