summaryrefslogtreecommitdiffstats
path: root/scripts/generate-license-file
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2025-04-01 14:56:09 -0300
committerGitHub <noreply@github.com>2025-04-01 14:56:09 -0300
commit74291c5ee1daac70b2c682f59c072b757f908e65 (patch)
tree8c4196ffc9a603b4bd2f5854da308188f9c92a26 /scripts/generate-license-file
parentc0c3b6108837ff232831b67c9ca87fb5b891182a (diff)
parent9181f0c3766c47190df31d7e743b9ae46e3b73a5 (diff)
downloadmeta-freescale-74291c5ee1daac70b2c682f59c072b757f908e65.tar.gz
Merge pull request #2176 from mdrodrigo/topic/gatesgarthgatesgarth
Add update-license-file in gatesgath branch
Diffstat (limited to 'scripts/generate-license-file')
-rwxr-xr-xscripts/generate-license-file18
1 files changed, 18 insertions, 0 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file
new file mode 100755
index 00000000..b6d43cd9
--- /dev/null
+++ b/scripts/generate-license-file
@@ -0,0 +1,18 @@
1#!/bin/bash
2
3# Create or clear the LICENSE file
4echo "# License Information" > LICENSE
5echo "" >> LICENSE
6echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE
7echo "" >> LICENSE
8
9# Find all .bb and .inc files and extract license information
10find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do
11 # Extract the license line from each recipe file, if it exists
12 license_line=$(grep -i "^LICENSE" "$file")
13 if [ -n "$license_line" ]; then
14 echo "$file: $license_line" >> LICENSE
15 fi
16done
17
18echo "LICENSE file has been generated and updated with current recipe licenses."