diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-04-01 14:50:15 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-04-01 14:50:15 -0300 |
commit | 22bbe41834f6ec7e03b6b72de4810846fd6b24a6 (patch) | |
tree | f0c20fe155b70c8c80c2341e46ce550d334f1326 /scripts | |
parent | 66635782a4968cc9fcb58a07e1821cc910245a80 (diff) | |
parent | f52917d5b90572044e7249aa754e61afb3e1aa67 (diff) | |
download | meta-freescale-honister.tar.gz |
Merge pull request #2174 from mdrodrigo/topic/honisterhonister
Add update-license-file in honister branch
Diffstat (limited to 'scripts')
-rwxr-xr-x | scripts/generate-license-file | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/scripts/generate-license-file b/scripts/generate-license-file new file mode 100755 index 00000000..b6d43cd9 --- /dev/null +++ b/scripts/generate-license-file | |||
@@ -0,0 +1,18 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | # Create or clear the LICENSE file | ||
4 | echo "# License Information" > LICENSE | ||
5 | echo "" >> LICENSE | ||
6 | echo "This file lists all licenses used by recipes in the meta-freescale-3rdparty layer." >> LICENSE | ||
7 | echo "" >> LICENSE | ||
8 | |||
9 | # Find all .bb and .inc files and extract license information | ||
10 | find . -type f \( -name "*.bb" -o -name "*.inc" \) | while read -r file; do | ||
11 | # Extract the license line from each recipe file, if it exists | ||
12 | license_line=$(grep -i "^LICENSE" "$file") | ||
13 | if [ -n "$license_line" ]; then | ||
14 | echo "$file: $license_line" >> LICENSE | ||
15 | fi | ||
16 | done | ||
17 | |||
18 | echo "LICENSE file has been generated and updated with current recipe licenses." | ||