diff options
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch | 56 |
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch b/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch deleted file mode 100644 index b8cf4e19..00000000 --- a/recipes-kernel/cryptodev/sdk_patches/0026-fix-Makefile-to-allow-parallel-make-with-j-option.patch +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | From d96ae48c87f80af1a202c2d2e837bf477edc0fb7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Thu, 10 Dec 2015 12:42:18 +0200 | ||
4 | Subject: [PATCH 26/38] fix Makefile to allow parallel make with -j option | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Recursive make commands should always use the variable MAKE, not the | ||
10 | explicit command name ‘make’ | ||
11 | |||
12 | Documented in section "5.7.1 How the MAKE Variable Works" of GNU Make manual | ||
13 | |||
14 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
15 | --- | ||
16 | Makefile | 10 +++++----- | ||
17 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
18 | |||
19 | diff --git a/Makefile b/Makefile | ||
20 | index 9e56e9d..2f50210 100644 | ||
21 | --- a/Makefile | ||
22 | +++ b/Makefile | ||
23 | @@ -22,7 +22,7 @@ KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE} | ||
24 | endif | ||
25 | |||
26 | build: version.h | ||
27 | - make ${KERNEL_MAKE_OPTS} modules | ||
28 | + $(MAKE) $(KERNEL_MAKE_OPTS) modules | ||
29 | |||
30 | version.h: Makefile | ||
31 | @echo "#define VERSION \"$(VERSION)\"" > version.h | ||
32 | @@ -30,17 +30,17 @@ version.h: Makefile | ||
33 | install: modules_install | ||
34 | |||
35 | modules_install: | ||
36 | - make -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install | ||
37 | + $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install | ||
38 | @echo "Installing cryptodev.h in $(PREFIX)/usr/include/crypto ..." | ||
39 | @install -D crypto/cryptodev.h $(PREFIX)/usr/include/crypto/cryptodev.h | ||
40 | |||
41 | clean: | ||
42 | - make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean | ||
43 | + $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` clean | ||
44 | rm -f $(hostprogs) *~ | ||
45 | - CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) make -C tests clean | ||
46 | + CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean | ||
47 | |||
48 | check: | ||
49 | - CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) make -C tests check | ||
50 | + CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check | ||
51 | |||
52 | CPOPTS = | ||
53 | ifneq (${SHOW_TYPES},) | ||
54 | -- | ||
55 | 2.7.0 | ||
56 | |||