diff options
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0027-use-Linux-kernel-conventions-for-Makefile-variables.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0027-use-Linux-kernel-conventions-for-Makefile-variables.patch | 47 |
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0027-use-Linux-kernel-conventions-for-Makefile-variables.patch b/recipes-kernel/cryptodev/sdk_patches/0027-use-Linux-kernel-conventions-for-Makefile-variables.patch deleted file mode 100644 index ad18da81..00000000 --- a/recipes-kernel/cryptodev/sdk_patches/0027-use-Linux-kernel-conventions-for-Makefile-variables.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From e51bf208fbd3796238ff4d721e8d070f711f8c56 Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Thu, 10 Dec 2015 12:42:19 +0200 | ||
4 | Subject: [PATCH 27/38] use Linux kernel conventions for Makefile variables | ||
5 | |||
6 | The kernel Makefile specifies to use M=... instead of SUBDIR=... for | ||
7 | external modules. | ||
8 | |||
9 | PWD variable is already set in a POSIX system and calling `pwd` to find | ||
10 | it is redundant. | ||
11 | |||
12 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
13 | --- | ||
14 | Makefile | 6 +++--- | ||
15 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index 2f50210..7c7e193 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -13,7 +13,7 @@ cryptodev-objs = ioctl.o main.o cryptlib.o authenc.o zc.o util.o | ||
22 | |||
23 | obj-m += cryptodev.o | ||
24 | |||
25 | -KERNEL_MAKE_OPTS := -C ${KERNEL_DIR} SUBDIRS=`pwd` | ||
26 | +KERNEL_MAKE_OPTS := -C $(KERNEL_DIR) M=$(PWD) | ||
27 | ifneq (${ARCH},) | ||
28 | KERNEL_MAKE_OPTS += ARCH=${ARCH} | ||
29 | endif | ||
30 | @@ -30,12 +30,12 @@ version.h: Makefile | ||
31 | install: modules_install | ||
32 | |||
33 | modules_install: | ||
34 | - $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install | ||
35 | + $(MAKE) -C $(KERNEL_DIR) M=$(PWD) modules_install | ||
36 | @echo "Installing cryptodev.h in $(PREFIX)/usr/include/crypto ..." | ||
37 | @install -D crypto/cryptodev.h $(PREFIX)/usr/include/crypto/cryptodev.h | ||
38 | |||
39 | clean: | ||
40 | - $(MAKE) -C $(KERNEL_DIR) SUBDIRS=`pwd` clean | ||
41 | + $(MAKE) -C $(KERNEL_DIR) M=$(PWD) clean | ||
42 | rm -f $(hostprogs) *~ | ||
43 | CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean | ||
44 | |||
45 | -- | ||
46 | 2.7.0 | ||
47 | |||