summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch66
1 files changed, 0 insertions, 66 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch b/recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch
deleted file mode 100644
index b4ab34ce..00000000
--- a/recipes-kernel/cryptodev/sdk_patches/0077-the-C-standard-used-by-cryptodev-is-C90-with-GNU-ext.patch
+++ /dev/null
@@ -1,66 +0,0 @@
1From 76de6db1bc69b2239d8fb91fd65b74610cb8e22f Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Thu, 27 Oct 2016 16:41:10 +0300
4Subject: [PATCH 077/104] the C standard used by cryptodev is C90 with GNU
5 extensions
6
7This avoids some problems with gcc>=5.0 which chaged the default to C11.
8The choice for gnu90 is based on the C standard used by Linux kernel which
9is gnu90 as well.
10
11Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
12---
13 Makefile | 6 +++---
14 lib/Makefile | 2 +-
15 tests/Makefile | 2 +-
16 3 files changed, 5 insertions(+), 5 deletions(-)
17
18diff --git a/Makefile b/Makefile
19index 90e86d9..80439f6 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -3,7 +3,7 @@
23 # disabled by default. To re-enable it uncomment the
24 # corresponding CFLAG.
25 #
26-CRYPTODEV_CFLAGS += -DENABLE_ASYNC
27+CRYPTODEV_CFLAGS += -DENABLE_ASYNC -std=gnu90
28 KBUILD_CFLAGS += -I$(src) $(CRYPTODEV_CFLAGS)
29 KERNEL_DIR ?= /lib/modules/$(shell uname -r)/build
30 VERSION = 1.8
31@@ -38,10 +38,10 @@ modules_install:
32 clean:
33 $(MAKE) $(KERNEL_MAKE_OPTS) clean
34 rm -f $(hostprogs) *~
35- CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean
36+ CFLAGS="$(CRYPTODEV_CFLAGS)" KERNEL_DIR="$(KERNEL_DIR)" $(MAKE) -C tests clean
37
38 check:
39- CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
40+ CFLAGS="$(CRYPTODEV_CFLAGS)" KERNEL_DIR="$(KERNEL_DIR)" $(MAKE) -C tests check
41
42 testprogs:
43 KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests all
44diff --git a/lib/Makefile b/lib/Makefile
45index 3bedc34..0044613 100644
46--- a/lib/Makefile
47+++ b/lib/Makefile
48@@ -1,4 +1,4 @@
49-CFLAGS=-g -O2 -Wall
50+CFLAGS=-g -O2 -Wall -std=gnu90
51
52 all: benchmark
53
54diff --git a/tests/Makefile b/tests/Makefile
55index e7a60cb..23d67f9 100644
56--- a/tests/Makefile
57+++ b/tests/Makefile
58@@ -1,4 +1,4 @@
59-CRYPTODEV_CFLAGS += -DENABLE_ASYNC -Wall -Werror
60+CRYPTODEV_CFLAGS += -DENABLE_ASYNC -std=gnu90 -Wall -Werror
61 CFLAGS += -I.. $(CRYPTODEV_CFLAGS)
62
63 comp_progs := cipher_comp hash_comp hmac_comp
64--
652.10.2
66