diff options
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0086-add-a-wrapper-script-for-running-all-tests.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0086-add-a-wrapper-script-for-running-all-tests.patch | 58 |
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0086-add-a-wrapper-script-for-running-all-tests.patch b/recipes-kernel/cryptodev/sdk_patches/0086-add-a-wrapper-script-for-running-all-tests.patch deleted file mode 100644 index 3e781aa3..00000000 --- a/recipes-kernel/cryptodev/sdk_patches/0086-add-a-wrapper-script-for-running-all-tests.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From fc04b5a05fd4ab1fc0f581b52d52db7c709dfc6a Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Fri, 28 Oct 2016 18:55:09 +0300 | ||
4 | Subject: [PATCH 086/104] add a wrapper script for running all tests | ||
5 | |||
6 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
7 | --- | ||
8 | tests/Makefile | 1 + | ||
9 | tests/run_crypto_tests.sh | 25 +++++++++++++++++++++++++ | ||
10 | 2 files changed, 26 insertions(+) | ||
11 | create mode 100644 tests/run_crypto_tests.sh | ||
12 | |||
13 | diff --git a/tests/Makefile b/tests/Makefile | ||
14 | index 400fb7a..51469e8 100644 | ||
15 | --- a/tests/Makefile | ||
16 | +++ b/tests/Makefile | ||
17 | @@ -39,6 +39,7 @@ install: | ||
18 | install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \ | ||
19 | done | ||
20 | install -m 755 async_speed_multi.sh $(DESTDIR)/$(bindir) | ||
21 | + install -m 755 run_crypto_tests.sh $(DESTDIR)/$(bindir) | ||
22 | |||
23 | clean: | ||
24 | rm -f *.o *~ $(hostprogs) | ||
25 | diff --git a/tests/run_crypto_tests.sh b/tests/run_crypto_tests.sh | ||
26 | new file mode 100644 | ||
27 | index 0000000..32ab8e2 | ||
28 | --- /dev/null | ||
29 | +++ b/tests/run_crypto_tests.sh | ||
30 | @@ -0,0 +1,25 @@ | ||
31 | +#!/bin/bash | ||
32 | + | ||
33 | + | ||
34 | +BUF_SIZE="8192 16384 65536 131072 262144" | ||
35 | +THREAD_CNT="1 8 12" | ||
36 | +ALG_NAMES="aes-128-cbc aes-256-xts sha1 sha256 crc32c" | ||
37 | + | ||
38 | +#restool dpseci create --num-queues=8 --priorities=1,2,3,4,5,6,7,8 | ||
39 | +#restool dprc assign dprc.1 --object=dpseci.0 --plugged=1 | ||
40 | + | ||
41 | + | ||
42 | +#grep DPIO /proc/interrupts | ||
43 | +for alg_name in ${ALG_NAMES} | ||
44 | +do | ||
45 | + for multi in ${THREAD_CNT} | ||
46 | + do | ||
47 | + for bsize in ${BUF_SIZE} | ||
48 | + do | ||
49 | + async_speed_multi.sh -t 10 -n $bsize -m ${multi} ${alg_name} | | ||
50 | + tail -n 1 | ||
51 | + done | ||
52 | + done | ||
53 | +done | ||
54 | + | ||
55 | +#grep DPIO /proc/interrupts | ||
56 | -- | ||
57 | 2.10.2 | ||
58 | |||