summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch b/recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch
new file mode 100644
index 00000000..fd6b1c16
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-python/0001-meson.build-Fix-missing-python_opt.patch
@@ -0,0 +1,47 @@
1From 8d7e2eaed10e2928358805f613223a6a149790d6 Mon Sep 17 00:00:00 2001
2From: Hiago De Franco <hiago.franco@toradex.com>
3Date: Wed, 31 Jul 2024 11:51:06 -0300
4Subject: [PATCH] meson.build: Fix missing python_opt
5
6'python_opt' was not declared earlier, giving the following build error:
7
8| Message: python_abi_flags =
9|
10| ../gst-python-1.24.0/meson.build:84:16: ERROR: Unknown variable "python_opt".
11
12Remove it and keep the error message.
13
14Upstream-Status: Inappropriate [oe specific]
15
16The patch already exists upstream, but this is related to another fix [1]
17not suitable for OE. Moreover, the backport does not apply since
18the patch was added to the gstreamer monorepo.
19
20[1] https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6734?
21
22Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
23---
24 meson.build | 7 +------
25 1 file changed, 1 insertion(+), 6 deletions(-)
26
27diff --git a/meson.build b/meson.build
28index f240b6fd8aca..53f7a43702c7 100644
29--- a/meson.build
30+++ b/meson.build
31@@ -80,12 +80,7 @@ foreach loc: pylib_locs
32 endforeach
33 endforeach
34 if pylib_fname == ''
35- error_msg = 'Could not find python library to load'
36- if python_opt.enabled()
37- error(error_msg)
38- else
39- message(error_msg)
40- endif
41+ message('Could not find python library to load')
42 endif
43
44 pygi_override_dir = get_option('pygi-overrides-dir')
45--
462.39.2
47