summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch34
1 files changed, 18 insertions, 16 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch b/recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch
index 568e38cb..456f0762 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0/0002-tests-add-support-for-install-the-tests.patch
@@ -1,4 +1,4 @@
1From 08b1aaff972a7f6349373fc1ad4cc23081adb52c Mon Sep 17 00:00:00 2001 1From 330e15374bb30ac29ee72c4b3de79c17b1157112 Mon Sep 17 00:00:00 2001
2From: Jose Quaresma <quaresma.jose@gmail.com> 2From: Jose Quaresma <quaresma.jose@gmail.com>
3Date: Sun, 11 Apr 2021 19:48:13 +0100 3Date: Sun, 11 Apr 2021 19:48:13 +0100
4Subject: [PATCH] tests: add support for install the tests 4Subject: [PATCH] tests: add support for install the tests
@@ -14,16 +14,16 @@ Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
14--- 14---
15 meson.build | 4 ++++ 15 meson.build | 4 ++++
16 meson_options.txt | 1 + 16 meson_options.txt | 1 +
17 tests/check/meson.build | 22 +++++++++++++++++++++- 17 tests/check/meson.build | 21 ++++++++++++++++++++-
18 tests/check/template.test.in | 3 +++ 18 tests/check/template.test.in | 3 +++
19 4 files changed, 29 insertions(+), 1 deletion(-) 19 4 files changed, 28 insertions(+), 1 deletion(-)
20 create mode 100644 tests/check/template.test.in 20 create mode 100644 tests/check/template.test.in
21 21
22diff --git a/meson.build b/meson.build 22diff --git a/meson.build b/meson.build
23index f9f591d..3906fb3 100644 23index 540d6d290e10..0267f22a79ea 100644
24--- a/meson.build 24--- a/meson.build
25+++ b/meson.build 25+++ b/meson.build
26@@ -606,6 +606,10 @@ if bashcomp_dep.found() 26@@ -624,6 +624,10 @@ if bashcomp_dep.found()
27 endif 27 endif
28 endif 28 endif
29 29
@@ -35,10 +35,10 @@ index f9f591d..3906fb3 100644
35 35
36 pkgconfig = import('pkgconfig') 36 pkgconfig = import('pkgconfig')
37diff --git a/meson_options.txt b/meson_options.txt 37diff --git a/meson_options.txt b/meson_options.txt
38index 7363bdb..a34ba37 100644 38index 340fb5801d02..5b87f68e8d7f 100644
39--- a/meson_options.txt 39--- a/meson_options.txt
40+++ b/meson_options.txt 40+++ b/meson_options.txt
41@@ -15,6 +15,7 @@ option('poisoning', type : 'boolean', value : false, description : 'Enable poiso 41@@ -16,6 +16,7 @@ option('poisoning', type : 'boolean', value : false, description : 'Enable poiso
42 option('memory-alignment', type: 'combo', 42 option('memory-alignment', type: 'combo',
43 choices : ['1', '2', '4', '8', '16', '32', '64', '128', '256', '512', '1024', '2048', '4096', '8192', 'malloc', 'pagesize'], 43 choices : ['1', '2', '4', '8', '16', '32', '64', '128', '256', '512', '1024', '2048', '4096', '8192', 'malloc', 'pagesize'],
44 value: 'malloc') 44 value: 'malloc')
@@ -47,14 +47,14 @@ index 7363bdb..a34ba37 100644
47 # Feature options 47 # Feature options
48 option('check', type : 'feature', value : 'auto', description : 'Build unit test libraries') 48 option('check', type : 'feature', value : 'auto', description : 'Build unit test libraries')
49diff --git a/tests/check/meson.build b/tests/check/meson.build 49diff --git a/tests/check/meson.build b/tests/check/meson.build
50index 16caac7..f2d400f 100644 50index e9501feb2af5..fd5a99611e3d 100644
51--- a/tests/check/meson.build 51--- a/tests/check/meson.build
52+++ b/tests/check/meson.build 52+++ b/tests/check/meson.build
53@@ -124,10 +124,16 @@ test_defines = [ 53@@ -125,10 +125,16 @@ test_defines = [
54 '-UG_DISABLE_ASSERT', 54 '-UG_DISABLE_ASSERT',
55 '-UG_DISABLE_CAST_CHECKS', 55 '-UG_DISABLE_CAST_CHECKS',
56 '-DGST_CHECK_TEST_ENVIRONMENT_BEACON="GST_STATE_IGNORE_ELEMENTS"', 56 '-DGST_CHECK_TEST_ENVIRONMENT_BEACON="GST_STATE_IGNORE_ELEMENTS"',
57- '-DTESTFILE="' + meson.current_source_dir() + '/meson.build"', 57- '-DTESTFILE="' + fsmod.as_posix(meson.current_source_dir()) + '/meson.build"',
58 '-DGST_DISABLE_DEPRECATED', 58 '-DGST_DISABLE_DEPRECATED',
59 ] 59 ]
60 60
@@ -68,7 +68,7 @@ index 16caac7..f2d400f 100644
68 # sanity checking 68 # sanity checking
69 if get_option('check').disabled() 69 if get_option('check').disabled()
70 if get_option('tests').enabled() 70 if get_option('tests').enabled()
71@@ -150,6 +156,8 @@ foreach t : core_tests 71@@ -151,6 +157,8 @@ foreach t : core_tests
72 include_directories : [configinc], 72 include_directories : [configinc],
73 link_with : link_with_libs, 73 link_with : link_with_libs,
74 dependencies : gst_deps + test_deps, 74 dependencies : gst_deps + test_deps,
@@ -77,10 +77,10 @@ index 16caac7..f2d400f 100644
77 ) 77 )
78 78
79 env = environment() 79 env = environment()
80@@ -161,6 +169,18 @@ foreach t : core_tests 80@@ -161,6 +169,17 @@ foreach t : core_tests
81 env.set('GST_REGISTRY', '@0@/@1@.registry'.format(meson.current_build_dir(), test_name))
81 env.set('GST_PLUGIN_SCANNER_1_0', gst_scanner_dir + '/gst-plugin-scanner') 82 env.set('GST_PLUGIN_SCANNER_1_0', gst_scanner_dir + '/gst-plugin-scanner')
82 env.set('GST_PLUGIN_LOADING_WHITELIST', 'gstreamer') 83 env.set('GST_PLUGIN_LOADING_WHITELIST', 'gstreamer')
83
84+ if installed_tests_enabled 84+ if installed_tests_enabled
85+ test_conf = configuration_data() 85+ test_conf = configuration_data()
86+ test_conf.set('installed_tests_dir', join_paths(prefix, installed_tests_execdir)) 86+ test_conf.set('installed_tests_dir', join_paths(prefix, installed_tests_execdir))
@@ -92,16 +92,18 @@ index 16caac7..f2d400f 100644
92+ configuration: test_conf 92+ configuration: test_conf
93+ ) 93+ )
94+ endif 94+ endif
95+ 95
96 test(test_name, exe, env: env, timeout : 3 * 60) 96 test(test_name, exe, env: env, timeout : 3 * 60)
97 endif 97 endif
98 endforeach
99diff --git a/tests/check/template.test.in b/tests/check/template.test.in 98diff --git a/tests/check/template.test.in b/tests/check/template.test.in
100new file mode 100644 99new file mode 100644
101index 0000000..f701627 100index 000000000000..f701627f87a6
102--- /dev/null 101--- /dev/null
103+++ b/tests/check/template.test.in 102+++ b/tests/check/template.test.in
104@@ -0,0 +1,3 @@ 103@@ -0,0 +1,3 @@
105+[Test] 104+[Test]
106+Type=session 105+Type=session
107+Exec=@installed_tests_dir@/@program@ 106+Exec=@installed_tests_dir@/@program@
107--
1082.39.2
109