diff options
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r-- | recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch | 37 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gst-examples/gst-player.desktop | 10 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb | 38 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb) | 2 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb | 8 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb | 4 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb | 4 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb | 4 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb | 8 |
9 files changed, 99 insertions, 16 deletions
diff --git a/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch b/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch new file mode 100644 index 00000000..828c87dc --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-examples/0001-Make-player-examples-installable.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 7924016fce2d0b435891a335cdae52fc939c7e3b Mon Sep 17 00:00:00 2001 | ||
2 | From: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
3 | Date: Thu, 17 Aug 2017 11:07:02 +0300 | ||
4 | Subject: [PATCH] Make player examples installable | ||
5 | |||
6 | Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> | ||
7 | Upstream-Status: Denied [Upstream considers these code examples, for now a least] | ||
8 | |||
9 | https://bugzilla.gnome.org/show_bug.cgi?id=777827 | ||
10 | |||
11 | --- | ||
12 | playback/player/gst-play/meson.build | 1 + | ||
13 | playback/player/gtk/meson.build | 1 + | ||
14 | 2 files changed, 2 insertions(+) | ||
15 | |||
16 | Index: gst-examples/playback/player/gst-play/meson.build | ||
17 | =================================================================== | ||
18 | --- gst-examples.orig/playback/player/gst-play/meson.build | ||
19 | +++ gst-examples/playback/player/gst-play/meson.build | ||
20 | @@ -2,5 +2,6 @@ executable('gst-play', | ||
21 | ['gst-play.c', | ||
22 | 'gst-play-kb.c', | ||
23 | 'gst-play-kb.h'], | ||
24 | + install: true, | ||
25 | dependencies : [gst_dep, dependency('gstreamer-play-1.0'), m_dep]) | ||
26 | |||
27 | Index: gst-examples/playback/player/gtk/meson.build | ||
28 | =================================================================== | ||
29 | --- gst-examples.orig/playback/player/gtk/meson.build | ||
30 | +++ gst-examples/playback/player/gtk/meson.build | ||
31 | @@ -20,5 +20,6 @@ if gtk_dep.found() | ||
32 | 'gtk-video-renderer.h', | ||
33 | 'gtk-video-renderer.c'], | ||
34 | c_args : extra_c_args, | ||
35 | + install: true, | ||
36 | dependencies : [gst_dep, gsttag_dep, gstplay_dep, gtk_dep, x11_dep]) | ||
37 | endif | ||
diff --git a/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop b/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop new file mode 100644 index 00000000..d165e5d9 --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-examples/gst-player.desktop | |||
@@ -0,0 +1,10 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Media Player | ||
3 | Comment=Basic media player | ||
4 | Icon=video-player | ||
5 | TryExec=gtk-play | ||
6 | Exec=gtk-play | ||
7 | StartupNotify=true | ||
8 | Terminal=false | ||
9 | Type=Application | ||
10 | Categories=GTK;AudioVideo; | ||
diff --git a/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb new file mode 100644 index 00000000..3830846b --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-examples_1.24.7.imx.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | # This builds an older version which is compatible with the gstreamer NXP fork 1.24.7.imx, | ||
2 | # thus the version is appended with '.imx' | ||
3 | |||
4 | SUMMARY = "GStreamer examples (including gtk-play, gst-play)" | ||
5 | DESCRIPTION = "GStreamer example applications." | ||
6 | HOMEPAGE = "https://gitlab.freedesktop.org/gstreamer/gst-examples" | ||
7 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-examples/-/issues" | ||
8 | LICENSE = "LGPL-2.0-or-later" | ||
9 | LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9" | ||
10 | |||
11 | DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 json-glib glib-2.0-native" | ||
12 | |||
13 | SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gstreamer.git;protocol=https;branch=1.24 \ | ||
14 | file://0001-Make-player-examples-installable.patch \ | ||
15 | file://gst-player.desktop \ | ||
16 | " | ||
17 | |||
18 | SRCREV = "0f1e984e41ce8d6d0758265d35e8b10d5815fde2" | ||
19 | |||
20 | S = "${WORKDIR}/git/subprojects/gst-examples" | ||
21 | |||
22 | inherit meson pkgconfig features_check | ||
23 | |||
24 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)" | ||
25 | |||
26 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | ||
27 | |||
28 | do_install:append() { | ||
29 | install -m 0644 -D ${UNPACKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop | ||
30 | } | ||
31 | |||
32 | RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback" | ||
33 | RRECOMMENDS:${PN} = "gstreamer1.0-plugins-base-meta \ | ||
34 | gstreamer1.0-plugins-good-meta \ | ||
35 | gstreamer1.0-plugins-bad-meta \ | ||
36 | ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-libav", "", d)} \ | ||
37 | ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}" | ||
38 | RPROVIDES:${PN} += "gst-player gst-player-bin" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb index ab542cb5..accca06a 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.24.7.imx.bb | |||
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770 \ | |||
12 | " | 12 | " |
13 | 13 | ||
14 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${@get_gst_ver('${PV}')}.tar.xz" | 14 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${@get_gst_ver('${PV}')}.tar.xz" |
15 | SRC_URI[sha256sum] = "ab775d5b9a7c84176b29822b68c7a34731280039a20b7db5eb639eddd1466178" | 15 | SRC_URI[sha256sum] = "c3e4179ba183c2d3101edf87ff70dd07e728c766a5fee34e6ecded76ca5802df" |
16 | 16 | ||
17 | S = "${WORKDIR}/gst-libav-${@get_gst_ver('${PV}')}" | 17 | S = "${WORKDIR}/gst-libav-${@get_gst_ver('${PV}')}" |
18 | 18 | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb index 4b707875..7f5cd0b3 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.24.7.imx.bb | |||
@@ -187,8 +187,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plug | |||
187 | " | 187 | " |
188 | SRC_URI:prepend = "${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} " | 188 | SRC_URI:prepend = "${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} " |
189 | GST1.0-PLUGINS-BAD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-bad.git;protocol=https" | 189 | GST1.0-PLUGINS-BAD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-bad.git;protocol=https" |
190 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 190 | SRCBRANCH = "MM_04.09.03_2412_L6.12.y" |
191 | SRCREV = "bba296b75dfb3e7ae4c836255edbd2b3c085c269" | 191 | SRCREV = "7bb1254fcb0a0dcb1ecb4ac21efbc5068151943d" |
192 | 192 | ||
193 | S = "${WORKDIR}/git" | 193 | S = "${WORKDIR}/git" |
194 | 194 | ||
@@ -219,9 +219,5 @@ EXTRA_OEMESON:remove = " \ | |||
219 | -Dkate=disabled \ | 219 | -Dkate=disabled \ |
220 | " | 220 | " |
221 | 221 | ||
222 | # it uses nested functions sadly, in ext/wayland/gstwaylandsink.c for GST_ELEMENT_REGISTER_DEFINE | ||
223 | # | ||
224 | TOOLCHAIN = "gcc" | ||
225 | |||
226 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | 222 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
227 | ########### End of i.MX overrides ######### | 223 | ########### End of i.MX overrides ######### |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb index c15457ca..6859d26b 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.24.7.imx.bb | |||
@@ -118,8 +118,8 @@ SRC_URI:remove = " \ | |||
118 | SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} " | 118 | SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} " |
119 | 119 | ||
120 | GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https" | 120 | GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https" |
121 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 121 | SRCBRANCH = "MM_04.09.03_2412_L6.12.y" |
122 | SRCREV = "031d262e65333e58b2ce01aaf47ab1012f93b21e" | 122 | SRCREV = "858ae5a1fb2bd2692ca7ebbd5bde2eee14e1842d" |
123 | 123 | ||
124 | S = "${WORKDIR}/git" | 124 | S = "${WORKDIR}/git" |
125 | 125 | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb index 5dd71743..933adb5e 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.24.7.imx.bb | |||
@@ -111,8 +111,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plu | |||
111 | 111 | ||
112 | SRC_URI:prepend = "${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} " | 112 | SRC_URI:prepend = "${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} " |
113 | GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-good.git;protocol=https" | 113 | GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-good.git;protocol=https" |
114 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 114 | SRCBRANCH = "MM_04.09.03_2412_L6.12.y" |
115 | SRCREV = "33b2732b873758a302064818b35dcad41b5bbc14" | 115 | SRCREV = "626a972e9ef448f1017cfad07a3486a0fb340a0d" |
116 | 116 | ||
117 | S = "${WORKDIR}/git" | 117 | S = "${WORKDIR}/git" |
118 | 118 | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb index 51a12f30..8daeed66 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.24.7.imx.bb | |||
@@ -100,8 +100,8 @@ SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV | |||
100 | " | 100 | " |
101 | SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} " | 101 | SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} " |
102 | GST1.0_SRC ?= "gitsm://github.com/nxp-imx/gstreamer.git;protocol=https" | 102 | GST1.0_SRC ?= "gitsm://github.com/nxp-imx/gstreamer.git;protocol=https" |
103 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 103 | SRCBRANCH = "MM_04.09.03_2412_L6.12.y" |
104 | SRCREV = "1a8f23da16cd224574ab2386803149c76f2cb628" | 104 | SRCREV = "e0d37a7d773a502956f54eced8cd701ec7fa5ff5" |
105 | 105 | ||
106 | S = "${WORKDIR}/git" | 106 | S = "${WORKDIR}/git" |
107 | 107 | ||
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb index 81d9ac0b..a96b5b31 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb | |||
@@ -27,18 +27,20 @@ DEPENDS_IMXGPU:imxgpu = "${DEPENDS_IMX_OPENCL_CONVERTER}" | |||
27 | DEPENDS_IMX_OPENCL_CONVERTER = "imx-opencl-converter" | 27 | DEPENDS_IMX_OPENCL_CONVERTER = "imx-opencl-converter" |
28 | DEPENDS_IMX_OPENCL_CONVERTER:mx6-nxp-bsp = "" | 28 | DEPENDS_IMX_OPENCL_CONVERTER:mx6-nxp-bsp = "" |
29 | DEPENDS_IMX_OPENCL_CONVERTER:mx7-nxp-bsp = "" | 29 | DEPENDS_IMX_OPENCL_CONVERTER:mx7-nxp-bsp = "" |
30 | DEPENDS_IMX_OPENCL_CONVERTER:mx8-nxp-bsp = "imx-opencl-converter" | ||
30 | DEPENDS_IMX_OPENCL_CONVERTER:mx8mm-nxp-bsp = "" | 31 | DEPENDS_IMX_OPENCL_CONVERTER:mx8mm-nxp-bsp = "" |
32 | DEPENDS_IMX_OPENCL_CONVERTER:mx95-nxp-bsp = "imx-opencl-converter" | ||
31 | 33 | ||
32 | # For backwards compatibility | 34 | # For backwards compatibility |
33 | RREPLACES:${PN} = "gst1.0-fsl-plugin" | 35 | RREPLACES:${PN} = "gst1.0-fsl-plugin" |
34 | RPROVIDES:${PN} = "gst1.0-fsl-plugin" | 36 | RPROVIDES:${PN} = "gst1.0-fsl-plugin" |
35 | RCONFLICTS:${PN} = "gst1.0-fsl-plugin" | 37 | RCONFLICTS:${PN} = "gst1.0-fsl-plugin" |
36 | 38 | ||
37 | PV = "4.9.2+git${SRCPV}" | 39 | PV = "4.9.3+git${SRCPV}" |
38 | 40 | ||
39 | SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}" | 41 | SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}" |
40 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 42 | SRCBRANCH = "MM_04.09.03_2412_L6.12.y" |
41 | SRCREV = "ef9c1a080e739e6f0be878148d9f4a050dc83bec" | 43 | SRCREV = "370510ef8137874339df18a2a35ec1d04d98fa0b" |
42 | 44 | ||
43 | S = "${WORKDIR}/git" | 45 | S = "${WORKDIR}/git" |
44 | 46 | ||