diff options
author | Lauren Post <lauren.post@freescale.com> | 2015-12-24 15:16:48 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-02-11 18:07:36 -0200 |
commit | 9f206ec786919135cc30630dad364d6e8cbe2cf9 (patch) | |
tree | bddeb5bf161766f1b54dd5597042399d464ed2de | |
parent | 19935f5775a1cbb50fcd6af8c99f5d19c5d57573 (diff) | |
download | meta-fsl-arm-9f206ec786919135cc30630dad364d6e8cbe2cf9.tar.gz |
linux-imx: Upgrade to 3.14.52-1.1.0_ga Consolidatd GA release
Signed-off-by: Lauren Post <lauren.post@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-8158-LLVMLinux-use-static-inline-in-ARM-ftrace.patch | 48 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline.patch | 59 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-3.14.38/0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch | 56 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-3.14.52/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch (renamed from recipes-kernel/linux/linux-imx-3.14.38/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch) | 0 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-3.14.52/imx/defconfig (renamed from recipes-kernel/linux/linux-imx-3.14.38/imx/defconfig) | 28 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-mfgtool_3.14.52.bb (renamed from recipes-kernel/linux/linux-imx-mfgtool_3.14.38.bb) | 0 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx_3.14.38.bb | 43 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx_3.14.52.bb | 23 |
8 files changed, 42 insertions, 215 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-8158-LLVMLinux-use-static-inline-in-ARM-ftrace.patch b/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-8158-LLVMLinux-use-static-inline-in-ARM-ftrace.patch deleted file mode 100644 index 47f13c7..0000000 --- a/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-8158-LLVMLinux-use-static-inline-in-ARM-ftrace.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001 | ||
2 | From: Behan Webster <behanw@converseincode.com> | ||
3 | Date: Wed, 24 Sep 2014 01:06:46 +0100 | ||
4 | Subject: ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h | ||
5 | |||
6 | With compilers which follow the C99 standard (like modern versions of gcc and | ||
7 | clang), "extern inline" does the wrong thing (emits code for an externally | ||
8 | linkable version of the inline function). In this case using static inline | ||
9 | and removing the NULL version of return_address in return_address.c does | ||
10 | the right thing. | ||
11 | |||
12 | Signed-off-by: Behan Webster <behanw@converseincode.com> | ||
13 | Reviewed-by: Mark Charlebois <charlebm@gmail.com> | ||
14 | Acked-by: Steven Rostedt <rostedt@goodmis.org> | ||
15 | Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk> | ||
16 | |||
17 | diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h | ||
18 | index 39eb16b..bfe2a2f 100644 | ||
19 | --- a/arch/arm/include/asm/ftrace.h | ||
20 | +++ b/arch/arm/include/asm/ftrace.h | ||
21 | @@ -45,7 +45,7 @@ void *return_address(unsigned int); | ||
22 | |||
23 | #else | ||
24 | |||
25 | -extern inline void *return_address(unsigned int level) | ||
26 | +static inline void *return_address(unsigned int level) | ||
27 | { | ||
28 | return NULL; | ||
29 | } | ||
30 | diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c | ||
31 | index fafedd8..f6aa84d 100644 | ||
32 | --- a/arch/arm/kernel/return_address.c | ||
33 | +++ b/arch/arm/kernel/return_address.c | ||
34 | @@ -63,11 +63,6 @@ void *return_address(unsigned int level) | ||
35 | #warning "TODO: return_address should use unwind tables" | ||
36 | #endif | ||
37 | |||
38 | -void *return_address(unsigned int level) | ||
39 | -{ | ||
40 | - return NULL; | ||
41 | -} | ||
42 | - | ||
43 | #endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */ | ||
44 | |||
45 | EXPORT_SYMBOL_GPL(return_address); | ||
46 | -- | ||
47 | cgit v0.10.2 | ||
48 | |||
diff --git a/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline.patch b/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline.patch deleted file mode 100644 index 0ab03fb..0000000 --- a/recipes-kernel/linux/linux-imx-3.14.38/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline.patch +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | From a2561791169351cbf1ac5ca0c4299a0eef7eca65 Mon Sep 17 00:00:00 2001 | ||
2 | From: Behan Webster <behanw@converseincode.com> | ||
3 | Date: Tue, 3 Sep 2013 22:27:26 -0400 | ||
4 | Subject: [PATCH] ARM: LLVMLinux: Change "extern inline" to "static inline" in | ||
5 | glue-cache.h | ||
6 | |||
7 | With compilers which follow the C99 standard (like modern versions of gcc and | ||
8 | clang), "extern inline" does the wrong thing (emits code for an externally | ||
9 | linkable version of the inline function). "static inline" is the correct choice | ||
10 | instead. | ||
11 | |||
12 | Author: Behan Webster <behanw@converseincode.com> | ||
13 | Signed-off-by: Behan Webster <behanw@converseincode.com> | ||
14 | Reviewed-by: Mark Charlebois <charlebm@gmail.com> | ||
15 | --- | ||
16 | arch/arm/include/asm/glue-cache.h | 22 +++++++++++----------- | ||
17 | 1 file changed, 11 insertions(+), 11 deletions(-) | ||
18 | |||
19 | diff --git a/arch/arm/include/asm/glue-cache.h b/arch/arm/include/asm/glue-cache.h | ||
20 | index c81adc0..a3c24cd 100644 | ||
21 | --- a/arch/arm/include/asm/glue-cache.h | ||
22 | +++ b/arch/arm/include/asm/glue-cache.h | ||
23 | @@ -130,22 +130,22 @@ | ||
24 | #endif | ||
25 | |||
26 | #ifndef __ASSEMBLER__ | ||
27 | -extern inline void nop_flush_icache_all(void) { } | ||
28 | -extern inline void nop_flush_kern_cache_all(void) { } | ||
29 | -extern inline void nop_flush_kern_cache_louis(void) { } | ||
30 | -extern inline void nop_flush_user_cache_all(void) { } | ||
31 | -extern inline void nop_flush_user_cache_range(unsigned long a, | ||
32 | +static inline void nop_flush_icache_all(void) { } | ||
33 | +static inline void nop_flush_kern_cache_all(void) { } | ||
34 | +static inline void nop_flush_kern_cache_louis(void) { } | ||
35 | +static inline void nop_flush_user_cache_all(void) { } | ||
36 | +static inline void nop_flush_user_cache_range(unsigned long a, | ||
37 | unsigned long b, unsigned int c) { } | ||
38 | |||
39 | -extern inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { } | ||
40 | -extern inline int nop_coherent_user_range(unsigned long a, | ||
41 | +static inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { } | ||
42 | +static inline int nop_coherent_user_range(unsigned long a, | ||
43 | unsigned long b) { return 0; } | ||
44 | -extern inline void nop_flush_kern_dcache_area(void *a, size_t s) { } | ||
45 | +static inline void nop_flush_kern_dcache_area(void *a, size_t s) { } | ||
46 | |||
47 | -extern inline void nop_dma_flush_range(const void *a, const void *b) { } | ||
48 | +static inline void nop_dma_flush_range(const void *a, const void *b) { } | ||
49 | |||
50 | -extern inline void nop_dma_map_area(const void *s, size_t l, int f) { } | ||
51 | -extern inline void nop_dma_unmap_area(const void *s, size_t l, int f) { } | ||
52 | +static inline void nop_dma_map_area(const void *s, size_t l, int f) { } | ||
53 | +static inline void nop_dma_unmap_area(const void *s, size_t l, int f) { } | ||
54 | #endif | ||
55 | |||
56 | #ifndef MULTI_CACHE | ||
57 | -- | ||
58 | 2.1.4 | ||
59 | |||
diff --git a/recipes-kernel/linux/linux-imx-3.14.38/0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch b/recipes-kernel/linux/linux-imx-3.14.38/0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch deleted file mode 100644 index 0743099..0000000 --- a/recipes-kernel/linux/linux-imx-3.14.38/0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | From 8340ad4ab71b568e65dfd1b92cc0967152887f97 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nikolay Dimitrov <picmaster@mail.bg> | ||
3 | Date: Sun, 8 Feb 2015 22:18:09 +0200 | ||
4 | Subject: [PATCH 3/3] ARM: imx6sl: Disable imx6sl-specific code when imx6sl SOC | ||
5 | support is disabled | ||
6 | |||
7 | Currently the build fails when CONFIG_SOC_IMX6SL is disabled, due to some | ||
8 | hard-coded stuff. The patch purpose is to handle enabling/disabling this | ||
9 | config option. | ||
10 | |||
11 | Signed-off-by: Nikolay Dimitrov <picmaster@mail.bg> | ||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | --- | ||
17 | arch/arm/mach-imx/Makefile | 3 ++- | ||
18 | arch/arm/mach-imx/mxc.h | 4 ++++ | ||
19 | 2 files changed, 6 insertions(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/arch/arm/mach-imx/Makefile b/arch/arm/mach-imx/Makefile | ||
22 | index b76a214..27f1976 100644 | ||
23 | --- a/arch/arm/mach-imx/Makefile | ||
24 | +++ b/arch/arm/mach-imx/Makefile | ||
25 | @@ -122,7 +122,8 @@ obj-$(CONFIG_SOC_IMX6SL) += busfreq_lpddr2.o lpddr2_freq_imx6.o imx6sl_lpm_wfi.o | ||
26 | AFLAGS_lpddr2_freq_imx6sx.o :=-Wa,-march=armv7-a | ||
27 | AFLAGS_ddr3_freq_imx6sx.o :=-Wa,-march=armv7-a | ||
28 | AFLAGS_imx6sx_low_power_idle.o :=-Wa,-march=armv7-a | ||
29 | -obj-$(CONFIG_SOC_IMX6SX) += ddr3_freq_imx6sx.o lpddr2_freq_imx6sx.o imx6sx_low_power_idle.o | ||
30 | +obj-$(CONFIG_SOC_IMX6SX) += ddr3_freq_imx6sx.o lpddr2_freq_imx6sx.o imx6sx_low_power_idle.o \ | ||
31 | + busfreq_lpddr2.o lpddr2_freq_imx6.o | ||
32 | endif | ||
33 | |||
34 | |||
35 | diff --git a/arch/arm/mach-imx/mxc.h b/arch/arm/mach-imx/mxc.h | ||
36 | index 1510769..e6af4dd 100644 | ||
37 | --- a/arch/arm/mach-imx/mxc.h | ||
38 | +++ b/arch/arm/mach-imx/mxc.h | ||
39 | @@ -158,10 +158,14 @@ extern unsigned int __mxc_cpu_type; | ||
40 | #endif | ||
41 | |||
42 | #ifndef __ASSEMBLY__ | ||
43 | +#ifdef CONFIG_SOC_IMX6SL | ||
44 | static inline bool cpu_is_imx6sl(void) | ||
45 | { | ||
46 | return __mxc_cpu_type == MXC_CPU_IMX6SL; | ||
47 | } | ||
48 | +#else | ||
49 | +# define cpu_is_imx6sl() (0) | ||
50 | +#endif | ||
51 | |||
52 | static inline bool cpu_is_imx6dl(void) | ||
53 | { | ||
54 | -- | ||
55 | 2.1.4 | ||
56 | |||
diff --git a/recipes-kernel/linux/linux-imx-3.14.38/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch b/recipes-kernel/linux/linux-imx-3.14.52/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch index 0d3caa4..0d3caa4 100644 --- a/recipes-kernel/linux/linux-imx-3.14.38/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch +++ b/recipes-kernel/linux/linux-imx-3.14.52/0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch | |||
diff --git a/recipes-kernel/linux/linux-imx-3.14.38/imx/defconfig b/recipes-kernel/linux/linux-imx-3.14.52/imx/defconfig index dd9f739..e3315f3 100644 --- a/recipes-kernel/linux/linux-imx-3.14.38/imx/defconfig +++ b/recipes-kernel/linux/linux-imx-3.14.52/imx/defconfig | |||
@@ -80,7 +80,6 @@ CONFIG_BT_BNEP_MC_FILTER=y | |||
80 | CONFIG_BT_BNEP_PROTO_FILTER=y | 80 | CONFIG_BT_BNEP_PROTO_FILTER=y |
81 | CONFIG_BT_HIDP=y | 81 | CONFIG_BT_HIDP=y |
82 | CONFIG_BT_HCIBTUSB=y | 82 | CONFIG_BT_HCIBTUSB=y |
83 | CONFIG_BT_HCIBTSDIO=y | ||
84 | CONFIG_BT_HCIUART=y | 83 | CONFIG_BT_HCIUART=y |
85 | CONFIG_BT_HCIUART_H4=y | 84 | CONFIG_BT_HCIUART_H4=y |
86 | CONFIG_BT_HCIUART_BCSP=y | 85 | CONFIG_BT_HCIUART_BCSP=y |
@@ -117,6 +116,8 @@ CONFIG_MTD_UBI=y | |||
117 | CONFIG_BLK_DEV_LOOP=y | 116 | CONFIG_BLK_DEV_LOOP=y |
118 | CONFIG_BLK_DEV_RAM=y | 117 | CONFIG_BLK_DEV_RAM=y |
119 | CONFIG_BLK_DEV_RAM_SIZE=65536 | 118 | CONFIG_BLK_DEV_RAM_SIZE=65536 |
119 | CONFIG_SENSORS_FXOS8700=y | ||
120 | CONFIG_SENSORS_FXAS2100X=y | ||
120 | CONFIG_EEPROM_AT24=y | 121 | CONFIG_EEPROM_AT24=y |
121 | CONFIG_EEPROM_AT25=y | 122 | CONFIG_EEPROM_AT25=y |
122 | # CONFIG_SCSI_PROC_FS is not set | 123 | # CONFIG_SCSI_PROC_FS is not set |
@@ -145,33 +146,38 @@ CONFIG_SMC91X=y | |||
145 | CONFIG_SMC911X=y | 146 | CONFIG_SMC911X=y |
146 | CONFIG_SMSC911X=y | 147 | CONFIG_SMSC911X=y |
147 | # CONFIG_NET_VENDOR_STMICRO is not set | 148 | # CONFIG_NET_VENDOR_STMICRO is not set |
149 | CONFIG_MICREL_PHY=y | ||
148 | CONFIG_USB_PEGASUS=m | 150 | CONFIG_USB_PEGASUS=m |
149 | CONFIG_USB_RTL8150=m | 151 | CONFIG_USB_RTL8150=m |
150 | CONFIG_USB_RTL8152=m | 152 | CONFIG_USB_RTL8152=m |
151 | CONFIG_USB_USBNET=m | 153 | CONFIG_USB_USBNET=m |
152 | CONFIG_USB_NET_CDC_EEM=m | 154 | CONFIG_USB_NET_CDC_EEM=m |
153 | CONFIG_ATH_CARDS=y | 155 | CONFIG_BCMDHD=m |
154 | CONFIG_ATH6KL=m | 156 | CONFIG_BCMDHD_SDIO=y |
155 | CONFIG_ATH6KL_SDIO=m | 157 | CONFIG_BCMDHD_FW_PATH="/lib/firmware/bcm/fw_bcmdhd.bin" |
156 | CONFIG_BRCMFMAC=m | 158 | CONFIG_BCMDHD_NVRAM_PATH="/lib/firmware/bcm/bcmdhd.cal" |
159 | # CONFIG_RTL_CARDS is not set | ||
157 | # CONFIG_INPUT_MOUSEDEV_PSAUX is not set | 160 | # CONFIG_INPUT_MOUSEDEV_PSAUX is not set |
158 | CONFIG_INPUT_EVDEV=y | 161 | CONFIG_INPUT_EVDEV=y |
159 | CONFIG_INPUT_EVBUG=m | 162 | CONFIG_INPUT_EVBUG=m |
160 | CONFIG_KEYBOARD_GPIO=y | 163 | CONFIG_KEYBOARD_GPIO=y |
161 | CONFIG_KEYBOARD_SNVS_PWRKEY=y | ||
162 | CONFIG_KEYBOARD_IMX=y | 164 | CONFIG_KEYBOARD_IMX=y |
163 | CONFIG_MOUSE_PS2=m | 165 | CONFIG_MOUSE_PS2=m |
164 | CONFIG_MOUSE_PS2_ELANTECH=y | 166 | CONFIG_MOUSE_PS2_ELANTECH=y |
165 | CONFIG_INPUT_TOUCHSCREEN=y | 167 | CONFIG_INPUT_TOUCHSCREEN=y |
168 | CONFIG_TOUCHSCREEN_ADS7846=y | ||
166 | CONFIG_TOUCHSCREEN_EGALAX=y | 169 | CONFIG_TOUCHSCREEN_EGALAX=y |
167 | CONFIG_TOUCHSCREEN_ELAN=y | 170 | CONFIG_TOUCHSCREEN_ELAN=y |
168 | CONFIG_TOUCHSCREEN_MAX11801=y | 171 | CONFIG_TOUCHSCREEN_MAX11801=y |
172 | CONFIG_TOUCHSCREEN_IMX6UL_TSC=y | ||
169 | CONFIG_TOUCHSCREEN_MC13783=y | 173 | CONFIG_TOUCHSCREEN_MC13783=y |
170 | CONFIG_TOUCHSCREEN_TSC2007=y | 174 | CONFIG_TOUCHSCREEN_TSC2007=y |
171 | CONFIG_TOUCHSCREEN_STMPE=y | 175 | CONFIG_TOUCHSCREEN_STMPE=y |
172 | CONFIG_INPUT_MISC=y | 176 | CONFIG_INPUT_MISC=y |
173 | CONFIG_INPUT_MMA8450=y | 177 | CONFIG_INPUT_MMA8450=y |
174 | CONFIG_INPUT_ISL29023=y | 178 | CONFIG_INPUT_ISL29023=y |
179 | CONFIG_INPUT_MPL3115=y | ||
180 | CONFIG_SENSOR_FXLS8471=y | ||
175 | CONFIG_SERIO_SERPORT=m | 181 | CONFIG_SERIO_SERPORT=m |
176 | # CONFIG_LEGACY_PTYS is not set | 182 | # CONFIG_LEGACY_PTYS is not set |
177 | # CONFIG_DEVKMEM is not set | 183 | # CONFIG_DEVKMEM is not set |
@@ -194,7 +200,6 @@ CONFIG_GPIO_MAX732X=y | |||
194 | CONFIG_GPIO_74X164=y | 200 | CONFIG_GPIO_74X164=y |
195 | CONFIG_POWER_SUPPLY=y | 201 | CONFIG_POWER_SUPPLY=y |
196 | CONFIG_SABRESD_MAX8903=y | 202 | CONFIG_SABRESD_MAX8903=y |
197 | CONFIG_IMX6_USB_CHARGER=y | ||
198 | CONFIG_SENSORS_MAX17135=y | 203 | CONFIG_SENSORS_MAX17135=y |
199 | CONFIG_SENSORS_MAG3110=y | 204 | CONFIG_SENSORS_MAG3110=y |
200 | CONFIG_THERMAL=y | 205 | CONFIG_THERMAL=y |
@@ -213,6 +218,7 @@ CONFIG_REGULATOR=y | |||
213 | CONFIG_REGULATOR_FIXED_VOLTAGE=y | 218 | CONFIG_REGULATOR_FIXED_VOLTAGE=y |
214 | CONFIG_REGULATOR_ANATOP=y | 219 | CONFIG_REGULATOR_ANATOP=y |
215 | CONFIG_REGULATOR_DA9052=y | 220 | CONFIG_REGULATOR_DA9052=y |
221 | CONFIG_REGULATOR_GPIO=y | ||
216 | CONFIG_REGULATOR_MAX17135=y | 222 | CONFIG_REGULATOR_MAX17135=y |
217 | CONFIG_REGULATOR_MC13783=y | 223 | CONFIG_REGULATOR_MC13783=y |
218 | CONFIG_REGULATOR_MC13892=y | 224 | CONFIG_REGULATOR_MC13892=y |
@@ -237,6 +243,8 @@ CONFIG_VIDEO_MXC_IPU_OUTPUT=y | |||
237 | CONFIG_VIDEO_MXC_PXP_V4L2=y | 243 | CONFIG_VIDEO_MXC_PXP_V4L2=y |
238 | CONFIG_VIDEO_MXC_CSI_CAMERA=m | 244 | CONFIG_VIDEO_MXC_CSI_CAMERA=m |
239 | CONFIG_MXC_VADC=m | 245 | CONFIG_MXC_VADC=m |
246 | CONFIG_MXC_MIPI_CSI=m | ||
247 | CONFIG_MXC_CAMERA_OV5647_MIPI=m | ||
240 | CONFIG_SOC_CAMERA=y | 248 | CONFIG_SOC_CAMERA=y |
241 | CONFIG_VIDEO_MX3=y | 249 | CONFIG_VIDEO_MX3=y |
242 | CONFIG_V4L_MEM2MEM_DRIVERS=y | 250 | CONFIG_V4L_MEM2MEM_DRIVERS=y |
@@ -256,6 +264,7 @@ CONFIG_BACKLIGHT_PWM=y | |||
256 | CONFIG_FB_MXC_SYNC_PANEL=y | 264 | CONFIG_FB_MXC_SYNC_PANEL=y |
257 | CONFIG_FB_MXC_LDB=y | 265 | CONFIG_FB_MXC_LDB=y |
258 | CONFIG_FB_MXC_MIPI_DSI=y | 266 | CONFIG_FB_MXC_MIPI_DSI=y |
267 | CONFIG_FB_MXC_MIPI_DSI_SAMSUNG=y | ||
259 | CONFIG_FB_MXC_TRULY_WVGA_SYNC_PANEL=y | 268 | CONFIG_FB_MXC_TRULY_WVGA_SYNC_PANEL=y |
260 | CONFIG_FB_MXC_HDMI=y | 269 | CONFIG_FB_MXC_HDMI=y |
261 | CONFIG_FB_MXC_EINK_PANEL=y | 270 | CONFIG_FB_MXC_EINK_PANEL=y |
@@ -284,9 +293,11 @@ CONFIG_SND_SOC_IMX_MC13783=y | |||
284 | CONFIG_SND_SOC_IMX_HDMI=y | 293 | CONFIG_SND_SOC_IMX_HDMI=y |
285 | CONFIG_SND_SOC_IMX_SI476X=y | 294 | CONFIG_SND_SOC_IMX_SI476X=y |
286 | CONFIG_USB=y | 295 | CONFIG_USB=y |
296 | CONFIG_USB_OTG_WHITELIST=y | ||
287 | CONFIG_USB_OTG_FSM=y | 297 | CONFIG_USB_OTG_FSM=y |
288 | CONFIG_USB_EHCI_HCD=y | 298 | CONFIG_USB_EHCI_HCD=y |
289 | CONFIG_USB_EHCI_MXC=y | 299 | CONFIG_USB_EHCI_MXC=y |
300 | CONFIG_USB_HCD_TEST_MODE=y | ||
290 | CONFIG_USB_ACM=m | 301 | CONFIG_USB_ACM=m |
291 | CONFIG_USB_STORAGE=y | 302 | CONFIG_USB_STORAGE=y |
292 | CONFIG_USB_CHIPIDEA=y | 303 | CONFIG_USB_CHIPIDEA=y |
@@ -296,7 +307,7 @@ CONFIG_USB_SERIAL=m | |||
296 | CONFIG_USB_SERIAL_GENERIC=y | 307 | CONFIG_USB_SERIAL_GENERIC=y |
297 | CONFIG_USB_SERIAL_FTDI_SIO=m | 308 | CONFIG_USB_SERIAL_FTDI_SIO=m |
298 | CONFIG_USB_SERIAL_OPTION=m | 309 | CONFIG_USB_SERIAL_OPTION=m |
299 | CONFIG_USB_EHSET_TEST_FIXTURE=m | 310 | CONFIG_USB_EHSET_TEST_FIXTURE=y |
300 | CONFIG_NOP_USB_XCEIV=y | 311 | CONFIG_NOP_USB_XCEIV=y |
301 | CONFIG_USB_MXS_PHY=y | 312 | CONFIG_USB_MXS_PHY=y |
302 | CONFIG_USB_GADGET=y | 313 | CONFIG_USB_GADGET=y |
@@ -327,7 +338,6 @@ CONFIG_MXC_IPU=y | |||
327 | CONFIG_MXC_GPU_VIV=y | 338 | CONFIG_MXC_GPU_VIV=y |
328 | CONFIG_MXC_IPU_V3_PRE=y | 339 | CONFIG_MXC_IPU_V3_PRE=y |
329 | CONFIG_MXC_MIPI_CSI2=y | 340 | CONFIG_MXC_MIPI_CSI2=y |
330 | CONFIG_MXC_MLB150=m | ||
331 | CONFIG_MXC_SIM=y | 341 | CONFIG_MXC_SIM=y |
332 | CONFIG_NEW_LEDS=y | 342 | CONFIG_NEW_LEDS=y |
333 | CONFIG_LEDS_CLASS=y | 343 | CONFIG_LEDS_CLASS=y |
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_3.14.38.bb b/recipes-kernel/linux/linux-imx-mfgtool_3.14.52.bb index 825c94a..825c94a 100644 --- a/recipes-kernel/linux/linux-imx-mfgtool_3.14.38.bb +++ b/recipes-kernel/linux/linux-imx-mfgtool_3.14.52.bb | |||
diff --git a/recipes-kernel/linux/linux-imx_3.14.38.bb b/recipes-kernel/linux/linux-imx_3.14.38.bb deleted file mode 100644 index 886298f..0000000 --- a/recipes-kernel/linux/linux-imx_3.14.38.bb +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Linux Kernel provided and supported by Freescale" | ||
5 | DESCRIPTION = "Linux Kernel provided and supported by Freescale with focus on \ | ||
6 | i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU." | ||
7 | |||
8 | require recipes-kernel/linux/linux-imx.inc | ||
9 | require recipes-kernel/linux/linux-dtb.inc | ||
10 | |||
11 | DEPENDS += "lzop-native bc-native" | ||
12 | |||
13 | SRCBRANCH_mx6q = "imx_3.14.38_6qp_ga" | ||
14 | LOCALVERSION_mx6q = "-6QuadPlus" | ||
15 | SRCREV_mx6q = "75a01115a7f53d728e6abeb7b205676cc2a50bc0" | ||
16 | |||
17 | SRCBRANCH_mx6dl = "imx_3.14.38_6qp_ga" | ||
18 | LOCALVERSION_mx6dl = "-6DualLite" | ||
19 | SRCREV_mx6dl = "75a01115a7f53d728e6abeb7b205676cc2a50bc0" | ||
20 | |||
21 | SRCBRANCH_mx6sx = "imx_3.14.38_6qp_ga" | ||
22 | LOCALVERSION_mx6sx = "-6SoloX" | ||
23 | SRCREV_mx6sx = "75a01115a7f53d728e6abeb7b205676cc2a50bc0" | ||
24 | |||
25 | SRCBRANCH_mx6sl = "imx_3.14.38_6qp_ga" | ||
26 | LOCALVERSION_mx6sl = "-6SOloLite" | ||
27 | SRCREV_mx6sl = "75a01115a7f53d728e6abeb7b205676cc2a50bc0" | ||
28 | |||
29 | SRCBRANCH_mx6ul = "imx_3.14.38_6ul_ga" | ||
30 | LOCALVERSION_mx6ul = "-6UltraLite" | ||
31 | SRCREV_mx6ul = "e4944a51c4bb950a8f13e421eefc000a87350e23" | ||
32 | |||
33 | SRCBRANCH_mx7 = "imx_3.14.38_6ul_ga" | ||
34 | LOCALVERSION_mx7 = "-7Dual_beta" | ||
35 | SRCREV_mx7 = "e4944a51c4bb950a8f13e421eefc000a87350e23" | ||
36 | |||
37 | SRC_URI += " \ | ||
38 | file://0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch \ | ||
39 | file://0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline.patch \ | ||
40 | file://0001-ARM-8158-LLVMLinux-use-static-inline-in-ARM-ftrace.patch \ | ||
41 | " | ||
42 | |||
43 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | ||
diff --git a/recipes-kernel/linux/linux-imx_3.14.52.bb b/recipes-kernel/linux/linux-imx_3.14.52.bb new file mode 100644 index 0000000..bd54de2 --- /dev/null +++ b/recipes-kernel/linux/linux-imx_3.14.52.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Linux Kernel provided and supported by Freescale" | ||
5 | DESCRIPTION = "Linux Kernel provided and supported by Freescale with focus on \ | ||
6 | i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU." | ||
7 | |||
8 | require recipes-kernel/linux/linux-imx.inc | ||
9 | require recipes-kernel/linux/linux-dtb.inc | ||
10 | |||
11 | DEPENDS += "lzop-native bc-native" | ||
12 | |||
13 | SRCBRANCH = "imx_3.14.52_1.1.0_ga" | ||
14 | LOCALVERSION = "-1.1.0_ga" | ||
15 | SRCREV = "5f6f0a50e6039370078369ddf380179d59024789" | ||
16 | |||
17 | SRC_URI += " \ | ||
18 | file://0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch \ | ||
19 | " | ||
20 | |||
21 | DEFAULT_PREFERENCE = "1" | ||
22 | |||
23 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | ||