diff options
author | Carlos Rafael Giani <dv@pseudoterminal.org> | 2014-10-13 13:35:39 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2014-10-14 16:55:19 -0300 |
commit | 8e65d3798f5791d0e7e77ef3393c479f12167baf (patch) | |
tree | c75f5fe1712fa7795e9fe62b28037e63e00dd6a5 /browser-layer/recipes-browser/chromium | |
parent | 1c1d7045696abd02aaf58e311ffae467b34bc4c1 (diff) | |
download | meta-fsl-arm-8e65d3798f5791d0e7e77ef3393c479f12167baf.tar.gz |
chromium: Update bbappend to version 38.0.2125.101
In this update, the "component-build" packageconfig is no longer enabled
by default. Component builds do use much less RAM on build machines, but
according to Chromium developers, it is not recommended to use these for
anything other than developer builds.
Note that you should still enable component mode if you don't have a
64 bit build machine, or a machine with less than 8 GB RAM.
Reference:
https://groups.google.com/a/chromium.org/d/topic/chromium-dev/yqIHEbquIBg/discussion
Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'browser-layer/recipes-browser/chromium')
-rw-r--r-- | browser-layer/recipes-browser/chromium/chromium-imx.inc | 10 | ||||
-rw-r--r-- | browser-layer/recipes-browser/chromium/chromium_38.0.2125.101.bbappend (renamed from browser-layer/recipes-browser/chromium/chromium_37.0.2062.94.bbappend) | 4 |
2 files changed, 7 insertions, 7 deletions
diff --git a/browser-layer/recipes-browser/chromium/chromium-imx.inc b/browser-layer/recipes-browser/chromium/chromium-imx.inc index 02a027d..f955c80 100644 --- a/browser-layer/recipes-browser/chromium/chromium-imx.inc +++ b/browser-layer/recipes-browser/chromium/chromium-imx.inc | |||
@@ -4,9 +4,9 @@ DEPENDS_append = " libfslvpuwrap" | |||
4 | # The code below fetches this repository, copies the extra source over to the main | 4 | # The code below fetches this repository, copies the extra source over to the main |
5 | # chromium source directory, and applies the patches. | 5 | # chromium source directory, and applies the patches. |
6 | 6 | ||
7 | CHROMIUM_IMX_BRANCH = "master" | 7 | CHROMIUM_IMX_BRANCH ?= "master" |
8 | CHROMIUM_IMX_SRCREV = "5c5cadd40ad04e66ec9b14a7a29370b76ed5c4f4" | 8 | CHROMIUM_IMX_SRCREV ?= "HEAD" |
9 | CHROMIUM_IMX_DESTSUFFIX = "chromium-imx-git" | 9 | CHROMIUM_IMX_DESTSUFFIX ?= "chromium-imx-git" |
10 | 10 | ||
11 | PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches" | 11 | PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches" |
12 | 12 | ||
@@ -22,12 +22,10 @@ do_unpack[postfuncs] += "copy_chromium_imx_files" | |||
22 | # patches to the OZONE_WAYLAND_EXTRA_PATCHES variable | 22 | # patches to the OZONE_WAYLAND_EXTRA_PATCHES variable |
23 | do_patch[prefuncs] =+ "add_chromium_imx_patches" | 23 | do_patch[prefuncs] =+ "add_chromium_imx_patches" |
24 | 24 | ||
25 | # * component build is on by default to reduce memory usage while compiling and to | ||
26 | # make it easier to patch binaries on the targets if necessary | ||
27 | # * Lost context problems are not known to happen with Vivante GPUs, | 25 | # * Lost context problems are not known to happen with Vivante GPUs, |
28 | # so it is safe to use ignore-lost-context | 26 | # so it is safe to use ignore-lost-context |
29 | # * EGL is on by default due to the GPU on the i.MX6 | 27 | # * EGL is on by default due to the GPU on the i.MX6 |
30 | PACKAGECONFIG_append = " component-build use-egl ignore-lost-context" | 28 | PACKAGECONFIG_append = " use-egl ignore-lost-context" |
31 | 29 | ||
32 | copy_chromium_imx_files() { | 30 | copy_chromium_imx_files() { |
33 | # sources in src/ are already organized in a manner | 31 | # sources in src/ are already organized in a manner |
diff --git a/browser-layer/recipes-browser/chromium/chromium_37.0.2062.94.bbappend b/browser-layer/recipes-browser/chromium/chromium_38.0.2125.101.bbappend index 1eb6490..f4c857b 100644 --- a/browser-layer/recipes-browser/chromium/chromium_37.0.2062.94.bbappend +++ b/browser-layer/recipes-browser/chromium/chromium_38.0.2125.101.bbappend | |||
@@ -1,5 +1,7 @@ | |||
1 | include chromium-imx.inc | 1 | include chromium-imx.inc |
2 | 2 | ||
3 | CHROMIUM_IMX_BRANCH = "master" | ||
4 | CHROMIUM_IMX_SRCREV = "aff6dd45041340190e3742118200219a6d7f3e87" | ||
3 | CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch \ | 5 | CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch \ |
4 | file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-37-GPU-.patch" | 6 | file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-38-GPU-.patch" |
5 | CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch" | 7 | CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch" |