diff options
author | Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | 2014-05-12 11:23:55 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2014-05-12 13:40:32 -0300 |
commit | 3336ef362109eef14f9e73cdededb43caefedb2f (patch) | |
tree | 2d8bd64988f209e76b46b3a53349eab2b765cc78 /qt5-layer/recipes-qt/qt5 | |
parent | d00d4598f10e215e16d3757fa9615a12f42c7bb7 (diff) | |
download | meta-fsl-arm-1.6.tar.gz |
qtwebkit: Fix shader generation to be compliant to the specification1.6
QTWebkit generates shader which is not complaint to specification
causing error with Vivante shader compiler.
https://bugs.webkit.org/show_bug.cgi?id=124653#c9
Apply this patch till it get fixed in mainline.
Change-Id: I85cf1a2fcb7457807f43a763b011e0b5ad11e8e9
Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer/recipes-qt/qt5')
-rw-r--r-- | qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch | 42 | ||||
-rw-r--r-- | qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend | 4 |
2 files changed, 46 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch b/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch new file mode 100644 index 0000000..80e55c7 --- /dev/null +++ b/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 66dab98c3f42eb70a4c6761a8694e374b8578e99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
3 | Date: Thu, 8 May 2014 09:27:04 -0700 | ||
4 | Subject: [PATCH] Fix to match the uniform precision qualifiers in vertex and | ||
5 | fragment shaders | ||
6 | |||
7 | When the vertex and fragment shaders are linked together, then they will | ||
8 | share a single global uniform name space. Hence, types and precisions of | ||
9 | uniforms with the same name must match across all shaders that are linked | ||
10 | into a single executable. | ||
11 | |||
12 | As per GLSL_ES_Specification_3.00.3.pdf | ||
13 | Page 124 12.3 Numeric Precision | ||
14 | The fragment language has no default precision qualifier for floating point types. | ||
15 | Hence for float, floating point vector and matrix variable declarations, either | ||
16 | the declaration must include a precision qualifier or the default float | ||
17 | precision must have been previously declared. | ||
18 | |||
19 | Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=124653#c9] | ||
20 | |||
21 | Change-Id: I4eb3363b3bca8bc3c839212ec7c966201a3e65e2 | ||
22 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
23 | --- | ||
24 | Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | 2 +- | ||
25 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
26 | |||
27 | diff --git a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
28 | index f4b9a7e..7e991bf 100644 | ||
29 | --- a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
30 | +++ b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
31 | @@ -208,7 +208,7 @@ static const char* fragmentTemplate = | ||
32 | ANTIALIASING_TEX_COORD_DIRECTIVE | ||
33 | BLUR_CONSTANTS | ||
34 | STRINGIFY( | ||
35 | - precision mediump float; | ||
36 | + precision highp float; | ||
37 | uniform SamplerType s_sampler; | ||
38 | uniform sampler2D s_contentTexture; | ||
39 | uniform float u_opacity; | ||
40 | -- | ||
41 | 1.9.1 | ||
42 | |||
diff --git a/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend b/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend new file mode 100644 index 0000000..5d961e6 --- /dev/null +++ b/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += "file://0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch" | ||
4 | |||