diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2016-05-27 18:09:55 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-05-30 08:19:34 -0300 |
commit | 9e835760f0e85c8a486d6ef819d6c2459d9a0b00 (patch) | |
tree | 9187621f9ff0643496bdee091b8339053b3ae95a /recipes-graphics | |
parent | ea8b6dd8a2baea77af5a5ac846add2e3d6fed68d (diff) | |
download | meta-fsl-arm-9e835760f0e85c8a486d6ef819d6c2459d9a0b00.tar.gz |
weston: Fix g2d compositor startup failure
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/wayland/weston/0003-MGS-1192-xwld-g2d-compositor-dose-not-work.patch | 31 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_%.bbappend | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston/0003-MGS-1192-xwld-g2d-compositor-dose-not-work.patch b/recipes-graphics/wayland/weston/0003-MGS-1192-xwld-g2d-compositor-dose-not-work.patch new file mode 100644 index 0000000..b9dfbea --- /dev/null +++ b/recipes-graphics/wayland/weston/0003-MGS-1192-xwld-g2d-compositor-dose-not-work.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 9de82e2b39f839b5547308bf25d0d71f79936631 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yong Gan <b45748@freescale.com> | ||
3 | Date: Tue, 27 Oct 2015 15:07:02 +0800 | ||
4 | Subject: [PATCH] MGS-1192: xwld: g2d compositor dose not work | ||
5 | |||
6 | Initial the backend->use_gal2d by input parameters. | ||
7 | |||
8 | Upstream-Status: Inappropriate [i.MX specific] | ||
9 | |||
10 | Signed-off-by: Yong Gan <yong.gan@freescale.com> | ||
11 | --- | ||
12 | src/compositor-fbdev.c | 3 ++- | ||
13 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/compositor-fbdev.c b/src/compositor-fbdev.c | ||
16 | index c6f732e..ed25576 100644 | ||
17 | --- a/src/compositor-fbdev.c | ||
18 | +++ b/src/compositor-fbdev.c | ||
19 | @@ -900,7 +900,8 @@ fbdev_backend_create(struct weston_compositor *compositor, int *argc, char *argv | ||
20 | backend->base.restore = fbdev_restore; | ||
21 | |||
22 | backend->prev_state = WESTON_COMPOSITOR_ACTIVE; | ||
23 | - backend->use_pixman = !param->use_gl; | ||
24 | + backend->use_pixman = !(param->use_gl || param->use_gal2d); | ||
25 | + backend->use_gal2d = param->use_gal2d; | ||
26 | |||
27 | for (key = KEY_F1; key < KEY_F9; key++) | ||
28 | weston_compositor_add_key_binding(compositor, key, | ||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend index fae4286..b2f4466 100644 --- a/recipes-graphics/wayland/weston_%.bbappend +++ b/recipes-graphics/wayland/weston_%.bbappend | |||
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | SRC_URI_append_mx6 = " \ | 3 | SRC_URI_append_mx6 = " \ |
4 | file://0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch \ | 4 | file://0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch \ |
5 | file://0003-MGS-1192-xwld-g2d-compositor-dose-not-work.patch \ | ||
5 | file://0004-MGS-1235-Fix-setenv-and-clear-environments.patch \ | 6 | file://0004-MGS-1235-Fix-setenv-and-clear-environments.patch \ |
6 | file://0005-MGS-1252-Fix-for-Qt5_CinematicExperience-will-meet-s.patch \ | 7 | file://0005-MGS-1252-Fix-for-Qt5_CinematicExperience-will-meet-s.patch \ |
7 | file://0006-MGS-1236-imx6qp-imx6dl-First-frame-distored-when-som.patch \ | 8 | file://0006-MGS-1236-imx6qp-imx6dl-First-frame-distored-when-som.patch \ |