diff options
author | Javier Viguera <javier.viguera@digi.com> | 2015-11-02 19:12:53 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-11-03 10:16:49 -0200 |
commit | e6bcd54a5a0f634ed521f2e59ad51b944f72734d (patch) | |
tree | 43cf88e2dbc2f5756dca4b3c0c32b3f4aab840ac /recipes-multimedia | |
parent | c4458f089955d5039c577c106bbdf60a0dbacaf4 (diff) | |
download | meta-fsl-arm-e6bcd54a5a0f634ed521f2e59ad51b944f72734d.tar.gz |
gst1.0-fsl-plugin: fix FSL codecs, parser and vpuwrap detection
Patch gst1.0-fsl-plugin's configure script to add a trailing space in the
FSL_MM_CORE_CFLAGS and FSL_MM_CORE_LIBS variables between different
pkg-config executions.
These variables are used later to pass parameters to the compiler and
as they are not built correctly, the 'configure' script fails to detect
some of the functionality:
Disabled features:
plugin: imxmp3enc
plugin: vpu_wrap
plugin: aiur
plugin: beep
This was working well in previous versions of Yocto, because pkg-config
until v0.28 was adding that trailing space:
http://cgit.freedesktop.org/pkg-config/commit/?id=f26a505826acec6b1e1af8d1efdf959913421c3a
but this is no longer true, so the trailing space has to be added in the
configure script.
Signed-off-by: Javier Viguera <javier.viguera@digi.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.7/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch | 46 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb | 5 |
2 files changed, 50 insertions, 1 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.7/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.7/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch new file mode 100644 index 0000000..4f69c78 --- /dev/null +++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin-4.0.7/0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From: Javier Viguera <javier.viguera@digi.com> | ||
2 | Date: Mon, 2 Nov 2015 17:52:48 +0100 | ||
3 | Subject: [PATCH] gst1.0-fsl-plugins: fix appending data to variable | ||
4 | |||
5 | FSL_MM_CORE_CFLAGS and FSL_MM_CORE_LIBS where concatenating data at the | ||
6 | end without adding a blank space between additions. | ||
7 | |||
8 | As the appended data was a result of `pkg-config` expansion, this was | ||
9 | working correctly until pkg-config v0.28 because it was pkg-config who | ||
10 | was adding the trailing space. | ||
11 | |||
12 | But after pkg-config v0.28, specifically in this commit: | ||
13 | |||
14 | http://cgit.freedesktop.org/pkg-config/commit/?id=f26a505826acec6b1e1af8d1efdf959913421c3a | ||
15 | |||
16 | this is no longer true, so the configure script needs to add that space. | ||
17 | |||
18 | Signed-off-by: Javier Viguera <javier.viguera@digi.com> | ||
19 | --- | ||
20 | configure.ac | 10 +++++----- | ||
21 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
22 | |||
23 | diff --git a/configure.ac b/configure.ac | ||
24 | index 4da48867fafd..01bff6ca5348 100755 | ||
25 | --- a/configure.ac | ||
26 | +++ b/configure.ac | ||
27 | @@ -203,14 +203,14 @@ AC_SUBST(RT_CFLAGS) | ||
28 | AC_SUBST(RT_LIBS) | ||
29 | |||
30 | FSL_MM_CORE_CFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null` | ||
31 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null` | ||
32 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslparser 2>/dev/null` | ||
33 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null` | ||
34 | +FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null`" | ||
35 | +FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslparser 2>/dev/null`" | ||
36 | +FSL_MM_CORE_CFLAGS+=" `$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null`" | ||
37 | AC_SUBST(FSL_MM_CORE_CFLAGS) | ||
38 | |||
39 | FSL_MM_CORE_LIBS=`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null` | ||
40 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvideocodec 2>/dev/null` | ||
41 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslparser 2>/dev/null` | ||
42 | +FSL_MM_CORE_LIBS+=" `$PKG_CONFIG --libs libfslvideocodec 2>/dev/null`" | ||
43 | +FSL_MM_CORE_LIBS+=" `$PKG_CONFIG --libs libfslparser 2>/dev/null`" | ||
44 | AC_SUBST(FSL_MM_CORE_LIBS) | ||
45 | |||
46 | EXTRAPLATFORMCFLAGS="-DARM -D_GNUC_" | ||
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb index 7d8ef0a..62b38c7 100644 --- a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb +++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb | |||
@@ -18,7 +18,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | |||
18 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | 18 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
19 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | 19 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" |
20 | 20 | ||
21 | SRC_URI = "${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz" | 21 | SRC_URI = " \ |
22 | ${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz \ | ||
23 | file://0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch \ | ||
24 | " | ||
22 | SRC_URI[md5sum] = "81e2dbd702ea2cd7904fc54981ea3d19" | 25 | SRC_URI[md5sum] = "81e2dbd702ea2cd7904fc54981ea3d19" |
23 | SRC_URI[sha256sum] = "fc287a672e2f040c2697af618b2f6ed319202a6dfbb731cbfb7987b41de2d62b" | 26 | SRC_URI[sha256sum] = "fc287a672e2f040c2697af618b2f6ed319202a6dfbb731cbfb7987b41de2d62b" |
24 | 27 | ||