diff options
Diffstat (limited to 'browser-layer')
3 files changed, 57 insertions, 0 deletions
diff --git a/browser-layer/recipes-browser/chromium/chromium-imx.inc b/browser-layer/recipes-browser/chromium/chromium-imx.inc new file mode 100644 index 0000000..b204d0d --- /dev/null +++ b/browser-layer/recipes-browser/chromium/chromium-imx.inc | |||
@@ -0,0 +1,48 @@ | |||
1 | DEPENDS_append = " libfslvpuwrap" | ||
2 | |||
3 | # Additional imx code and patches are included in the chromium-imx git repository. | ||
4 | # The code below fetches this repository, copies the extra source over to the main | ||
5 | # chromium source directory, and applies the patches. | ||
6 | |||
7 | CHROMIUM_IMX_BRANCH = "master" | ||
8 | CHROMIUM_IMX_SRCREV = "0aacc892d0977f691d683db1c1f1f6f9e33da911" | ||
9 | CHROMIUM_IMX_DESTSUFFIX = "chromium-imx-git" | ||
10 | |||
11 | PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches" | ||
12 | |||
13 | CHROMIUM_IMX_COMMON_PATCHES ?= " " | ||
14 | CHROMIUM_IMX_WAYLAND_PATCHES ?= " " | ||
15 | |||
16 | SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV}" | ||
17 | |||
18 | do_unpack[postfuncs] += "copy_chromium_imx_files" | ||
19 | # using =+ instead of += to make sure add_chromium_imx_patches is | ||
20 | # executed before add_ozone_wayland_patches in the main recipe; | ||
21 | # this is necessary because add_chromium_imx_patches appends | ||
22 | # patches to the OZONE_WAYLAND_EXTRA_PATCHES variable | ||
23 | do_patch[prefuncs] =+ "add_chromium_imx_patches" | ||
24 | |||
25 | # * component build is on by default to reduce memory usage while compiling and to | ||
26 | # make it easier to patch binaries on the targets if necessary | ||
27 | # * Lost context problems are not known to happen with Vivante GPUs, | ||
28 | # so it is safe to use ignore-lost-context | ||
29 | # * EGL is on by default due to the GPU on the i.MX6 | ||
30 | PACKAGECONFIG_append = " component-build use-egl ignore-lost-context" | ||
31 | |||
32 | copy_chromium_imx_files() { | ||
33 | # sources in src/ are already organized in a manner | ||
34 | # that matches the subdirectories in the chromium | ||
35 | # source directory; just copy over the files in src/ | ||
36 | cp -r ${WORKDIR}/chromium-imx-git/src/* ${S}/ | ||
37 | } | ||
38 | |||
39 | python add_chromium_imx_patches() { | ||
40 | d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_COMMON_PATCHES', 1)) | ||
41 | d.appendVar('OZONE_WAYLAND_EXTRA_PATCHES', ' ' + d.getVar('CHROMIUM_IMX_WAYLAND_PATCHES', 1)) | ||
42 | } | ||
43 | |||
44 | # Necessary flags to enable support for h.264 and MP4 in Chromium | ||
45 | # (Parsing is done by ffmpeg) | ||
46 | EXTRA_OEGYP += "-Dproprietary_codecs=1 -Dffmpeg_branding=Chrome" | ||
47 | |||
48 | COMPATIBLE_MACHINE = "(mx6)" | ||
diff --git a/browser-layer/recipes-browser/chromium/chromium_35.0.1916.114.bbappend b/browser-layer/recipes-browser/chromium/chromium_35.0.1916.114.bbappend new file mode 100644 index 0000000..561aec2 --- /dev/null +++ b/browser-layer/recipes-browser/chromium/chromium_35.0.1916.114.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | include chromium-imx.inc | ||
2 | |||
3 | CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch \ | ||
4 | file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-35-GPU-.patch" | ||
diff --git a/browser-layer/recipes-browser/chromium/chromium_37.0.2062.0.bbappend b/browser-layer/recipes-browser/chromium/chromium_37.0.2062.0.bbappend new file mode 100644 index 0000000..1eb6490 --- /dev/null +++ b/browser-layer/recipes-browser/chromium/chromium_37.0.2062.0.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | include chromium-imx.inc | ||
2 | |||
3 | CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch \ | ||
4 | file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-37-GPU-.patch" | ||
5 | CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch" | ||