diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 13:59:10 +0200 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 14:13:09 +0200 |
commit | e064c208e2c78663b0be1316117d963798839d6e (patch) | |
tree | d5d7bb0e950e5d6960d464f96f82f8132b8225c8 /recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch | |
download | meta-fsl-ppc-daisy-enea.tar.gz |
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch')
-rw-r--r-- | recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch | 69 |
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch new file mode 100644 index 0000000..cb871f6 --- /dev/null +++ b/recipes-kernel/cryptodev/files/Add-the-compile-and-install-rules-for-cryptodev-test.patch | |||
@@ -0,0 +1,69 @@ | |||
1 | From 1980a8f4779a955e73285e7a0d86549b69bea5c8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yu Zongchun <b40527@freescale.com> | ||
3 | Date: Sun, 28 Apr 2013 14:39:22 +0800 | ||
4 | Subject: [PATCH] Add the compile and install rules for cryptodev tests folder | ||
5 | |||
6 | This is required to install the cryptodev tests folder to rootfs | ||
7 | |||
8 | Signed-off-by: Yu Zongchun <b40527@freescale.com> | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | --- | ||
13 | Makefile | 6 ++++++ | ||
14 | tests/Makefile | 8 ++++++++ | ||
15 | 2 files changed, 14 insertions(+), 0 deletions(-) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index 2be8825..4cbb865 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -17,6 +17,9 @@ install: | ||
22 | @echo "Installing cryptodev.h in /usr/include/crypto ..." | ||
23 | @install -D crypto/cryptodev.h /usr/include/crypto/cryptodev.h | ||
24 | |||
25 | +install_tests: | ||
26 | + make -C tests install DESTDIR=$(PREFIX) | ||
27 | + | ||
28 | clean: | ||
29 | make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean | ||
30 | rm -f $(hostprogs) *~ | ||
31 | @@ -25,6 +28,9 @@ clean: | ||
32 | check: | ||
33 | KERNEL_DIR=$(KERNEL_DIR) make -C tests check | ||
34 | |||
35 | +testprogs: | ||
36 | + KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs | ||
37 | + | ||
38 | FILEBASE = cryptodev-linux-$(VERSION) | ||
39 | TMPDIR ?= /tmp | ||
40 | OUTPUT = $(FILEBASE).tar.gz | ||
41 | diff --git a/tests/Makefile b/tests/Makefile | ||
42 | index 87ca3c7..0488cf6 100644 | ||
43 | --- a/tests/Makefile | ||
44 | +++ b/tests/Makefile | ||
45 | @@ -19,6 +19,12 @@ example-async-hmac-objs := async_hmac.o | ||
46 | example-async-speed-objs := async_speed.o | ||
47 | example-hashcrypt-speed-objs := hashcrypt_speed.c | ||
48 | |||
49 | +install: | ||
50 | + install -d $(DESTDIR)/usr/bin/tests_cryptodev | ||
51 | + for bin in $(hostprogs); do \ | ||
52 | + install -m 755 $${bin} $(DESTDIR)/usr/bin/tests_cryptodev/; \ | ||
53 | + done | ||
54 | + | ||
55 | check: $(hostprogs) | ||
56 | ./cipher | ||
57 | ./hmac | ||
58 | @@ -28,6 +34,8 @@ check: $(hostprogs) | ||
59 | ./cipher-gcm | ||
60 | ./cipher-aead | ||
61 | |||
62 | +testprogs: $(hostprogs) | ||
63 | + | ||
64 | clean: | ||
65 | rm -f *.o *~ $(hostprogs) | ||
66 | |||
67 | -- | ||
68 | 1.7.5.4 | ||
69 | |||