diff options
author | Cristian Stoica <cristian.stoica@nxp.com> | 2016-01-25 11:19:43 +0200 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-06-23 10:58:51 +0800 |
commit | 41d1478e1294d06f0cce58fe847c0b0f1706b808 (patch) | |
tree | 8c6c5e2887cc30435ee40e764bb2ede58278d0ac /recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch | |
parent | e3956ffbc217e468e26c9ce2e8932d3720fabca4 (diff) | |
download | meta-fsl-ppc-41d1478e1294d06f0cce58fe847c0b0f1706b808.tar.gz |
cryptodev-qoriq: upgrade to 1.8 plus fsl patches
upstream commit: 87b56e04b24c6d4be145483477eff7d3153290e9
Also:
- move all fsl patches on top of cryptodev-1.8
- add CIOCHASH ioctl
- fix incorrect tests initializations
- modify yocto patches to match updated Makefiles
Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch | 73 |
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch b/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch new file mode 100644 index 0000000..756ca33 --- /dev/null +++ b/recipes-kernel/cryptodev/sdk_patches/0028-for-consistency-use-.-instead-of-.-in-makefiles.patch | |||
@@ -0,0 +1,73 @@ | |||
1 | From 22b63631de17507c12355c30e408dbd88350bb3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Thu, 10 Dec 2015 12:42:20 +0200 | ||
4 | Subject: [PATCH 28/38] for consistency, use $(...) instead of ${...} in | ||
5 | makefiles | ||
6 | |||
7 | Both syntax rules are equaly valid and mixing them is permitted but | ||
8 | looks inconsistent. | ||
9 | |||
10 | See section "6.1 Basics of Variable References" of GNU make manual | ||
11 | |||
12 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
13 | --- | ||
14 | Makefile | 16 ++++++++-------- | ||
15 | tests/Makefile | 2 +- | ||
16 | 2 files changed, 9 insertions(+), 9 deletions(-) | ||
17 | |||
18 | diff --git a/Makefile b/Makefile | ||
19 | index 7c7e193..7f8df37 100644 | ||
20 | --- a/Makefile | ||
21 | +++ b/Makefile | ||
22 | @@ -14,11 +14,11 @@ cryptodev-objs = ioctl.o main.o cryptlib.o authenc.o zc.o util.o | ||
23 | obj-m += cryptodev.o | ||
24 | |||
25 | KERNEL_MAKE_OPTS := -C $(KERNEL_DIR) M=$(PWD) | ||
26 | -ifneq (${ARCH},) | ||
27 | -KERNEL_MAKE_OPTS += ARCH=${ARCH} | ||
28 | +ifneq ($(ARCH),) | ||
29 | +KERNEL_MAKE_OPTS += ARCH=$(ARCH) | ||
30 | endif | ||
31 | -ifneq (${CROSS_COMPILE},) | ||
32 | -KERNEL_MAKE_OPTS += CROSS_COMPILE=${CROSS_COMPILE} | ||
33 | +ifneq ($(CROSS_COMPILE),) | ||
34 | +KERNEL_MAKE_OPTS += CROSS_COMPILE=$(CROSS_COMPILE) | ||
35 | endif | ||
36 | |||
37 | build: version.h | ||
38 | @@ -43,15 +43,15 @@ check: | ||
39 | CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check | ||
40 | |||
41 | CPOPTS = | ||
42 | -ifneq (${SHOW_TYPES},) | ||
43 | +ifneq ($(SHOW_TYPES),) | ||
44 | CPOPTS += --show-types | ||
45 | endif | ||
46 | -ifneq (${IGNORE_TYPES},) | ||
47 | -CPOPTS += --ignore ${IGNORE_TYPES} | ||
48 | +ifneq ($(IGNORE_TYPES),) | ||
49 | +CPOPTS += --ignore $(IGNORE_TYPES) | ||
50 | endif | ||
51 | |||
52 | checkpatch: | ||
53 | - $(KERNEL_DIR)/scripts/checkpatch.pl ${CPOPTS} --file *.c *.h | ||
54 | + $(KERNEL_DIR)/scripts/checkpatch.pl $(CPOPTS) --file *.c *.h | ||
55 | |||
56 | VERSIONTAG = refs/tags/cryptodev-linux-$(VERSION) | ||
57 | FILEBASE = cryptodev-linux-$(VERSION) | ||
58 | diff --git a/tests/Makefile b/tests/Makefile | ||
59 | index 20c52ba..3155da9 100644 | ||
60 | --- a/tests/Makefile | ||
61 | +++ b/tests/Makefile | ||
62 | @@ -6,7 +6,7 @@ comp_progs := cipher_comp hash_comp hmac_comp | ||
63 | |||
64 | hostprogs := cipher cipher-aead hmac speed async_cipher async_hmac \ | ||
65 | async_speed sha_speed hashcrypt_speed fullspeed cipher-gcm \ | ||
66 | - cipher-aead-srtp ${comp_progs} | ||
67 | + cipher-aead-srtp $(comp_progs) | ||
68 | |||
69 | example-cipher-objs := cipher.o | ||
70 | example-cipher-aead-objs := cipher-aead.o | ||
71 | -- | ||
72 | 2.7.0 | ||
73 | |||