diff options
author | Cristian Stoica <cristian.stoica@nxp.com> | 2016-01-25 11:19:43 +0200 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-06-23 10:58:51 +0800 |
commit | 41d1478e1294d06f0cce58fe847c0b0f1706b808 (patch) | |
tree | 8c6c5e2887cc30435ee40e764bb2ede58278d0ac /recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch | |
parent | e3956ffbc217e468e26c9ce2e8932d3720fabca4 (diff) | |
download | meta-fsl-ppc-41d1478e1294d06f0cce58fe847c0b0f1706b808.tar.gz |
cryptodev-qoriq: upgrade to 1.8 plus fsl patches
upstream commit: 87b56e04b24c6d4be145483477eff7d3153290e9
Also:
- move all fsl patches on top of cryptodev-1.8
- add CIOCHASH ioctl
- fix incorrect tests initializations
- modify yocto patches to match updated Makefiles
Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch b/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch new file mode 100644 index 0000000..ff73825 --- /dev/null +++ b/recipes-kernel/cryptodev/sdk_patches/0041-add-separate-target-for-building-tests.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 0d58530f5c5970db9787a23aef4227c68f941fcc Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Wed, 10 Feb 2016 16:22:05 +0200 | ||
4 | Subject: [PATCH 41/43] add separate target for building tests | ||
5 | |||
6 | A separate target for build is useful with cross-compilation. In this | ||
7 | case it makes sense to build the tests without running them on the host | ||
8 | machine. | ||
9 | |||
10 | The default target is now 'all' and only builds the tests | ||
11 | |||
12 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
13 | --- | ||
14 | tests/Makefile | 4 ++++ | ||
15 | 1 file changed, 4 insertions(+) | ||
16 | |||
17 | diff --git a/tests/Makefile b/tests/Makefile | ||
18 | index 3155da9..89f88fe 100644 | ||
19 | --- a/tests/Makefile | ||
20 | +++ b/tests/Makefile | ||
21 | @@ -19,6 +19,8 @@ example-async-hmac-objs := async_hmac.o | ||
22 | example-async-speed-objs := async_speed.o | ||
23 | example-hashcrypt-speed-objs := hashcrypt_speed.c | ||
24 | |||
25 | +all: $(hostprogs) | ||
26 | + | ||
27 | check: $(hostprogs) | ||
28 | ./cipher | ||
29 | ./hmac | ||
30 | @@ -33,3 +35,5 @@ clean: | ||
31 | |||
32 | ${comp_progs}: LDLIBS += -lssl -lcrypto | ||
33 | ${comp_progs}: %: %.o openssl_wrapper.o | ||
34 | + | ||
35 | +.PHONY: all clean check | ||
36 | -- | ||
37 | 2.7.0 | ||
38 | |||