diff options
author | Cristian Stoica <cristian.stoica@nxp.com> | 2016-01-25 11:19:43 +0200 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-06-23 10:58:51 +0800 |
commit | 41d1478e1294d06f0cce58fe847c0b0f1706b808 (patch) | |
tree | 8c6c5e2887cc30435ee40e764bb2ede58278d0ac /recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch | |
parent | e3956ffbc217e468e26c9ce2e8932d3720fabca4 (diff) | |
download | meta-fsl-ppc-41d1478e1294d06f0cce58fe847c0b0f1706b808.tar.gz |
cryptodev-qoriq: upgrade to 1.8 plus fsl patches
upstream commit: 87b56e04b24c6d4be145483477eff7d3153290e9
Also:
- move all fsl patches on top of cryptodev-1.8
- add CIOCHASH ioctl
- fix incorrect tests initializations
- modify yocto patches to match updated Makefiles
Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch')
-rw-r--r-- | recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch b/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch new file mode 100644 index 0000000..f3b7022 --- /dev/null +++ b/recipes-kernel/cryptodev/sdk_patches/0043-add-install-target-for-tests.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 44629033d47543d106299b6c8bed9e5c9fed1513 Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristian Stoica <cristian.stoica@nxp.com> | ||
3 | Date: Thu, 11 Feb 2016 16:48:53 +0200 | ||
4 | Subject: [PATCH 43/43] add install target for tests | ||
5 | |||
6 | Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com> | ||
7 | --- | ||
8 | tests/Makefile | 12 +++++++++++- | ||
9 | 1 file changed, 11 insertions(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/tests/Makefile b/tests/Makefile | ||
12 | index 89f88fe..5e3111d 100644 | ||
13 | --- a/tests/Makefile | ||
14 | +++ b/tests/Makefile | ||
15 | @@ -19,6 +19,10 @@ example-async-hmac-objs := async_hmac.o | ||
16 | example-async-speed-objs := async_speed.o | ||
17 | example-hashcrypt-speed-objs := hashcrypt_speed.c | ||
18 | |||
19 | +prefix ?= /usr/local | ||
20 | +execprefix ?= $(prefix) | ||
21 | +bindir = $(execprefix)/bin | ||
22 | + | ||
23 | all: $(hostprogs) | ||
24 | |||
25 | check: $(hostprogs) | ||
26 | @@ -30,10 +34,16 @@ check: $(hostprogs) | ||
27 | ./cipher-gcm | ||
28 | ./cipher-aead | ||
29 | |||
30 | +install: | ||
31 | + install -d $(DESTDIR)/$(bindir) | ||
32 | + for prog in $(hostprogs); do \ | ||
33 | + install -m 755 $$prog $(DESTDIR)/$(bindir); \ | ||
34 | + done | ||
35 | + | ||
36 | clean: | ||
37 | rm -f *.o *~ $(hostprogs) | ||
38 | |||
39 | ${comp_progs}: LDLIBS += -lssl -lcrypto | ||
40 | ${comp_progs}: %: %.o openssl_wrapper.o | ||
41 | |||
42 | -.PHONY: all clean check | ||
43 | +.PHONY: all clean check install | ||
44 | -- | ||
45 | 2.7.0 | ||
46 | |||