diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2013-12-12 13:41:56 +0100 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2013-12-12 13:41:56 +0100 |
commit | 177ef53047019757b70b5ca87171b2c88e26ba07 (patch) | |
tree | 70e3284e64755ae93c130e00f810ba5c501801b9 /recipes-virtualization/hypervisor/hypervisor_git.bb | |
download | meta-fsl-ppc-enea_linux_3.tar.gz |
initial commit of Enea Linux 3.1enea_linux_3
Migrated from the internal git server on the dora-enea branch
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-virtualization/hypervisor/hypervisor_git.bb')
-rw-r--r-- | recipes-virtualization/hypervisor/hypervisor_git.bb | 91 |
1 files changed, 91 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb new file mode 100644 index 0000000..ff89bfa --- /dev/null +++ b/recipes-virtualization/hypervisor/hypervisor_git.bb | |||
@@ -0,0 +1,91 @@ | |||
1 | DESCRIPTION = "Freescale embedded hypervisor" | ||
2 | SECTION = "embedded-hv" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0" | ||
5 | |||
6 | PR = "r3" | ||
7 | |||
8 | DEPENDS = "u-boot-mkimage-native" | ||
9 | |||
10 | inherit deploy | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | # TODO: fix dtc to use the already built package | ||
15 | SRC_URI = " \ | ||
16 | git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor \ | ||
17 | git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig \ | ||
18 | git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \ | ||
19 | git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \ | ||
20 | git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \ | ||
21 | file://0001-fix-sizeof-pointer-memaccess-error.patch \ | ||
22 | file://81-fsl-embedded-hv.rules \ | ||
23 | " | ||
24 | |||
25 | SRCREV_FORMAT="hypervisor" | ||
26 | SRCREV = "e6092cdf2a225c66c1ea46b1151eb828da29d139" | ||
27 | SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac" | ||
28 | SRCREV_libos = "5268371581f3ef3959be2a53235edfa6a8c6aa7c" | ||
29 | SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0" | ||
30 | SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533" | ||
31 | |||
32 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' | ||
33 | |||
34 | DEFCONFIG = "defconfig" | ||
35 | DEFCONFIG_powerpc64 = "64bit_defconfig" | ||
36 | |||
37 | COMPATIBLE_HOST_fslmachine = ".*" | ||
38 | COMPATIBLE_HOST ?= "(none)" | ||
39 | |||
40 | inherit cml1 | ||
41 | do_configure () { | ||
42 | oe_runmake ${DEFCONFIG} | ||
43 | } | ||
44 | |||
45 | PKG_HV_HYPERTRK_SUPPORT = "n" | ||
46 | do_compile () { | ||
47 | if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ] | ||
48 | then | ||
49 | oe_runmake silentoldconfig | ||
50 | export HV_DIR=$PWD | ||
51 | cd hypertrk | ||
52 | oe_runmake deploy | ||
53 | cd .. | ||
54 | fi | ||
55 | |||
56 | oe_runmake | ||
57 | oe_runmake partman | ||
58 | } | ||
59 | |||
60 | do_install () { | ||
61 | install -d ${D}/${bindir} | ||
62 | install ${S}/output/bin/linux/partman ${D}/${bindir}/partman | ||
63 | |||
64 | install -d ${D}${sysconfdir}/udev/rules.d | ||
65 | install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d | ||
66 | |||
67 | install -d ${D}/boot/hv | ||
68 | install ${S}/output/.config ${D}/boot/hv/hypervisor.config | ||
69 | install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \ | ||
70 | ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \ | ||
71 | ${D}/boot/hv/ | ||
72 | } | ||
73 | |||
74 | do_deploy () { | ||
75 | install -d ${DEPLOYDIR}/hv/ | ||
76 | install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config | ||
77 | install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \ | ||
78 | ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \ | ||
79 | ${DEPLOYDIR}/hv/ | ||
80 | } | ||
81 | addtask deploy before do_build after do_install | ||
82 | |||
83 | do_deploy_append() { | ||
84 | rm -f ${S}/../hv | ||
85 | } | ||
86 | |||
87 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
88 | ALLOW_EMPTY_${PN} = "1" | ||
89 | PACKAGES_prepend = "${PN}-image ${PN}-partman " | ||
90 | FILES_${PN}-image = "/boot/" | ||
91 | FILES_${PN}-partman = "${bindir}/partman" | ||