diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:24:31 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:30:01 +0000 |
commit | 8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch) | |
tree | 0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-core/readline | |
download | meta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz |
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-core/readline')
-rw-r--r-- | recipes-core/readline/readline-5.2/configure-fix.patch | 26 | ||||
-rw-r--r-- | recipes-core/readline/readline-5.2/fix-redundant-rpath.patch | 21 | ||||
-rw-r--r-- | recipes-core/readline/readline_5.2.bb | 84 |
3 files changed, 131 insertions, 0 deletions
diff --git a/recipes-core/readline/readline-5.2/configure-fix.patch b/recipes-core/readline/readline-5.2/configure-fix.patch new file mode 100644 index 0000000..be60a98 --- /dev/null +++ b/recipes-core/readline/readline-5.2/configure-fix.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | Without this it fails to link against libtermcap causing various missing symbols | ||
4 | issues. | ||
5 | |||
6 | RP - 8/10/08 | ||
7 | |||
8 | Index: readline-5.2/configure.in | ||
9 | =================================================================== | ||
10 | --- readline-5.2.orig/configure.in 2008-10-08 09:58:52.000000000 +0100 | ||
11 | +++ readline-5.2/configure.in 2008-10-08 09:59:03.000000000 +0100 | ||
12 | @@ -211,10 +211,10 @@ | ||
13 | AC_MSG_CHECKING(configuration for building shared libraries) | ||
14 | eval `TERMCAP_LIB=$TERMCAP_LIB ${CONFIG_SHELL-/bin/sh} ${srcdir}/support/shobj-conf -C "${CC}" -c ${host_cpu} -o ${host_os} -v ${host_vendor}` | ||
15 | |||
16 | -# case "$SHLIB_LIBS" in | ||
17 | -# *curses*|*termcap*|*termlib*) ;; | ||
18 | -# *) SHLIB_LIBS="$SHLIB_LIBS $TERMCAP_LIB" ;; | ||
19 | -# esac | ||
20 | + case "$SHLIB_LIBS" in | ||
21 | + *curses*|*termcap*|*termlib*) ;; | ||
22 | + *) SHLIB_LIBS="$SHLIB_LIBS $TERMCAP_LIB" ;; | ||
23 | + esac | ||
24 | |||
25 | AC_SUBST(SHOBJ_CC) | ||
26 | AC_SUBST(SHOBJ_CFLAGS) | ||
diff --git a/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch b/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch new file mode 100644 index 0000000..3166b47 --- /dev/null +++ b/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | This support script ends up hardcoding unnecessary rpaths into the libraries. We | ||
2 | will search $libdir automatically so this is just wastes space. There may be some | ||
3 | cases this is necessary but our use cases aren't one of them. | ||
4 | |||
5 | Upstream-Status: Inappropriate | ||
6 | |||
7 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
8 | |||
9 | Index: readline-5.2/support/shobj-conf | ||
10 | =================================================================== | ||
11 | --- readline-5.2.orig/support/shobj-conf | ||
12 | +++ readline-5.2/support/shobj-conf | ||
13 | @@ -110,7 +110,7 @@ linux*-*|gnu*-*|k*bsd*-gnu-*) | ||
14 | SHOBJ_LD='${CC}' | ||
15 | SHOBJ_LDFLAGS='-shared -Wl,-soname,$@' | ||
16 | |||
17 | - SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`' | ||
18 | + SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`' | ||
19 | SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)' | ||
20 | ;; | ||
21 | |||
diff --git a/recipes-core/readline/readline_5.2.bb b/recipes-core/readline/readline_5.2.bb new file mode 100644 index 0000000..c1007a2 --- /dev/null +++ b/recipes-core/readline/readline_5.2.bb | |||
@@ -0,0 +1,84 @@ | |||
1 | SUMMARY = "Library for editing typed command lines" | ||
2 | DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \ | ||
3 | command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \ | ||
4 | additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \ | ||
5 | lines, and perform csh-like history expansion on previous commands." | ||
6 | SECTION = "libs" | ||
7 | |||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f" | ||
10 | |||
11 | DEPENDS += "ncurses" | ||
12 | |||
13 | PR = "r9" | ||
14 | |||
15 | SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz;name=archive \ | ||
16 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-001;name=patch1;apply=yes;striplevel=0 \ | ||
17 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-002;name=patch2;apply=yes;striplevel=0 \ | ||
18 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-003;name=patch3;apply=yes;striplevel=0 \ | ||
19 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-004;name=patch4;apply=yes;striplevel=0 \ | ||
20 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-005;name=patch5;apply=yes;striplevel=0 \ | ||
21 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-006;name=patch6;apply=yes;striplevel=0 \ | ||
22 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-007;name=patch7;apply=yes;striplevel=0 \ | ||
23 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-008;name=patch8;apply=yes;striplevel=0 \ | ||
24 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-009;name=patch9;apply=yes;striplevel=0 \ | ||
25 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-010;name=patch10;apply=yes;striplevel=0 \ | ||
26 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-011;name=patch11;apply=yes;striplevel=0 \ | ||
27 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-012;name=patch12;apply=yes;striplevel=0 \ | ||
28 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-013;name=patch13;apply=yes;striplevel=0 \ | ||
29 | ${GNU_MIRROR}/readline/readline-5.2-patches/readline52-014;name=patch14;apply=yes;striplevel=0 \ | ||
30 | file://configure-fix.patch \ | ||
31 | file://config-dirent-symbols.patch \ | ||
32 | file://fix-redundant-rpath.patch" | ||
33 | |||
34 | SRC_URI[archive.md5sum] = "e39331f32ad14009b9ff49cc10c5e751" | ||
35 | SRC_URI[archive.sha256sum] = "12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45" | ||
36 | |||
37 | SRC_URI[patch1.md5sum] = "9d4d41622aa9b230c57f68548ce87d8f" | ||
38 | SRC_URI[patch1.sha256sum] = "eac304c369154059f93049ada328739faaf40338d3cb1fb4b544c93d5ce3f8d5" | ||
39 | SRC_URI[patch2.md5sum] = "f03e512d14206e37f7d6a748b56b9476" | ||
40 | SRC_URI[patch2.sha256sum] = "9deacaef25507a0c2ae0b661bf9342559b59a2954d66ea3c5f5bcd900fdfcf78" | ||
41 | SRC_URI[patch3.md5sum] = "252b42d8750f1a94b6bdf086612dceb2" | ||
42 | SRC_URI[patch3.sha256sum] = "2a55d2ecb1c9b0147aeb193a6323616ab31c1c525a83b2db3a994b15594ba934" | ||
43 | SRC_URI[patch4.md5sum] = "a32333c2e603a3ed250514e91050e552" | ||
44 | SRC_URI[patch4.sha256sum] = "a03b65633781efa7c3aae5d57162985e7b7a3c10acf0f2621be610e16f27e5f2" | ||
45 | SRC_URI[patch5.md5sum] = "8106796c09b789523a3a78ab69c04b6d" | ||
46 | SRC_URI[patch5.sha256sum] = "06001896514148a757ea6edbbd40c4fc4331dc653847244386c37b138b150f64" | ||
47 | SRC_URI[patch6.md5sum] = "512188e2bf0837f7eca19dbf71f182ae" | ||
48 | SRC_URI[patch6.sha256sum] = "dfef3e982c0adf8bb5a9b7d0468ec8f5f18138b325e28759437464de5be71013" | ||
49 | SRC_URI[patch7.md5sum] = "ac17aca62eb6fb398c9f2fe9de540aff" | ||
50 | SRC_URI[patch7.sha256sum] = "775b028c7b761397ac6ae1bdfbac7e896dc3b9b3adc2f91312499180ca13bdd1" | ||
51 | SRC_URI[patch8.md5sum] = "2484c392db021905f112cf97a94dfd4c" | ||
52 | SRC_URI[patch8.sha256sum] = "a21b4e0bf0530b878bad24d5be23d18a9e03a75a31ae30844dc0933bb3d77ecd" | ||
53 | SRC_URI[patch9.md5sum] = "fc6eb35d07914fae5c57d49c12483ff7" | ||
54 | SRC_URI[patch9.sha256sum] = "138d5e0f0709a47a2d1621295a3dd5e3cc73b63b5cc28dab03abc4e94fe95ecf" | ||
55 | SRC_URI[patch10.md5sum] = "7a2bf3dc7ac7680b1461a5701100e91b" | ||
56 | SRC_URI[patch10.sha256sum] = "83f8c1aadb86b1a2fad8821a9c6be72a8de5afd7fd9fde58a30b3b57d939693e" | ||
57 | SRC_URI[patch11.md5sum] = "ef6cef6822663470f6ac8c517c5a7ec6" | ||
58 | SRC_URI[patch11.sha256sum] = "08ad3384ab0906e6fa4cc417eb8c43ff59375bcead15fd5c8e31730f0413b3d6" | ||
59 | SRC_URI[patch12.md5sum] = "e3e9f441c8111589855bc363e5640f6c" | ||
60 | SRC_URI[patch12.sha256sum] = "20f0243be2299c23213492cc2c19cfd15cc528d2b566a76a2de58306bb9e4c9e" | ||
61 | SRC_URI[patch13.md5sum] = "3e2e5f543ed268a68fd1fa839faade1a" | ||
62 | SRC_URI[patch13.sha256sum] = "0cc649516a5bdfa61c5e56937407570288b6972d75aa1bd060ad30ebe98144d5" | ||
63 | SRC_URI[patch14.md5sum] = "a1be30e1c6f1099bb5fcef00a2631fb8" | ||
64 | SRC_URI[patch14.sha256sum] = "6f1a68320d01522ca1ea5a737124ecc8739f3dcbfea2dee21e3ccf839a21a817" | ||
65 | |||
66 | inherit autotools | ||
67 | |||
68 | EXTRA_AUTORECONF += "--exclude=autoheader" | ||
69 | |||
70 | LEAD_SONAME = "libreadline.so" | ||
71 | |||
72 | do_configure_prepend () { | ||
73 | if [ ! -e ${S}/acinclude.m4 ]; then | ||
74 | cat ${S}/aclocal.m4 > ${S}/acinclude.m4 | ||
75 | fi | ||
76 | } | ||
77 | |||
78 | do_install_append () { | ||
79 | # Make install doesn't properly install these | ||
80 | oe_libinstall -so -C shlib libhistory ${D}${libdir} | ||
81 | oe_libinstall -so -C shlib libreadline ${D}${libdir} | ||
82 | } | ||
83 | |||
84 | BBCLASSEXTEND = "native nativesdk" | ||