diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:24:31 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:30:01 +0000 |
commit | 8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch) | |
tree | 0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-extended/diffutils/diffutils-2.8.1 | |
download | meta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz |
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/diffutils/diffutils-2.8.1')
-rw-r--r-- | recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch | 27 | ||||
-rw-r--r-- | recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch | 31 |
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch b/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch new file mode 100644 index 0000000..f8638bb --- /dev/null +++ b/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | automake 1.12 has depricated automatic de-ANSI-fication support | ||
4 | |||
5 | this patch avoids these kinds of errors: | ||
6 | |||
7 | | configure.ac:90: error: automatic de-ANSI-fication support has been removed | ||
8 | | /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/aclocal-1.12/protos.m4:12: AM_C_PROTOTYPES is expanded from... | ||
9 | | /srv/home/nitin/builds/build-gcc47/tmp/work/i586-poky-linux/diffutils-2.8.1-r4/diffutils-2.8.1/m4/prereq.m4:110: jm_PREREQ_QUOTEARG is expanded from... | ||
10 | | configure.ac:90: the top level | ||
11 | | autom4te: m4 failed with exit status: 1 | ||
12 | |||
13 | Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> | ||
14 | 2012/05/04 | ||
15 | |||
16 | Index: diffutils-2.8.1/m4/prereq.m4 | ||
17 | =================================================================== | ||
18 | --- diffutils-2.8.1.orig/m4/prereq.m4 | ||
19 | +++ diffutils-2.8.1/m4/prereq.m4 | ||
20 | @@ -115,7 +115,6 @@ AC_DEFUN([jm_PREREQ_QUOTEARG], | ||
21 | AC_HEADER_STDC | ||
22 | AC_C_BACKSLASH_A | ||
23 | AC_MBSTATE_T | ||
24 | - AM_C_PROTOTYPES | ||
25 | ]) | ||
26 | |||
27 | AC_DEFUN([jm_PREREQ_REGEX], | ||
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch b/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch new file mode 100644 index 0000000..f915287 --- /dev/null +++ b/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Fixes to allow diffutils to build with gcc v6. | ||
2 | |||
3 | RP | ||
4 | 2016/5/25 | ||
5 | |||
6 | Index: diffutils-2.8.1/lib/posix/regex.h | ||
7 | =================================================================== | ||
8 | --- diffutils-2.8.1.orig/lib/posix/regex.h | ||
9 | +++ diffutils-2.8.1/lib/posix/regex.h | ||
10 | @@ -529,7 +529,9 @@ extern int re_exec _RE_ARGS ((const char | ||
11 | /* For now unconditionally define __restrict_arr to expand to nothing. | ||
12 | Ideally we would have a test for the compiler which allows defining | ||
13 | it to restrict. */ | ||
14 | +#ifndef __restrict_arr | ||
15 | #define __restrict_arr | ||
16 | +#endif | ||
17 | |||
18 | /* POSIX compatibility. */ | ||
19 | extern int regcomp _RE_ARGS ((regex_t *__restrict __preg, | ||
20 | Index: diffutils-2.8.1/src/diff.c | ||
21 | =================================================================== | ||
22 | --- diffutils-2.8.1.orig/src/diff.c | ||
23 | +++ diffutils-2.8.1/src/diff.c | ||
24 | @@ -71,6 +71,7 @@ static void usage (void); | ||
25 | static bool recursive; | ||
26 | |||
27 | /* In context diffs, show previous lines that match these regexps. */ | ||
28 | +struct re_pattern_buffer function_regexp; | ||
29 | static struct regexp_list function_regexp_list; | ||
30 | |||
31 | /* Ignore changes affecting only lines that match these regexps. */ | ||