diff options
Diffstat (limited to 'recipes-extended/qat/files/0001-qat-fix-for-cross-compilation-issue.patch')
-rw-r--r-- | recipes-extended/qat/files/0001-qat-fix-for-cross-compilation-issue.patch | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-extended/qat/files/0001-qat-fix-for-cross-compilation-issue.patch b/recipes-extended/qat/files/0001-qat-fix-for-cross-compilation-issue.patch new file mode 100644 index 0000000..45689a9 --- /dev/null +++ b/recipes-extended/qat/files/0001-qat-fix-for-cross-compilation-issue.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | From 563cc2fc8d1b120a63aa9d157effed04d39bd58f Mon Sep 17 00:00:00 2001 | ||
2 | From: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com> | ||
3 | Date: Mon, 6 Jul 2015 15:57:20 +0800 | ||
4 | Subject: [PATCH 01/11] qat: fix for cross-compilation issue | ||
5 | |||
6 | Upstream-Status: Inappropriate [Configuration] | ||
7 | |||
8 | Ensure that we are not using host compiler. | ||
9 | |||
10 | Signed-off-by: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com> | ||
11 | Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> | ||
12 | [YL: modified for patching to qat17_4.12.0-00011] | ||
13 | Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> | ||
14 | --- | ||
15 | quickassist/lookaside/access_layer/src/sample_code/functional/common.mk | 2 +- | ||
16 | .../access_layer/src/sample_code/functional/dc/dc_dp_sample/Makefile | 2 +- | ||
17 | quickassist/lookaside/access_layer/src/sample_code/performance/Makefile | 2 +- | ||
18 | 3 files changed, 3 insertions(+), 3 deletions(-) | ||
19 | |||
20 | diff --git a/quickassist/lookaside/access_layer/src/sample_code/functional/common.mk b/quickassist/lookaside/access_layer/src/sample_code/functional/common.mk | ||
21 | index 8c2fa3c..9402873 100644 | ||
22 | --- a/quickassist/lookaside/access_layer/src/sample_code/functional/common.mk | ||
23 | +++ b/quickassist/lookaside/access_layer/src/sample_code/functional/common.mk | ||
24 | @@ -150,7 +150,7 @@ ifeq ($(ICP_OS_LEVEL),user_space) | ||
25 | ############################################################ | ||
26 | |||
27 | ifneq ($(PREBUILD_BINS),0) | ||
28 | - ADDITIONAL_OBJECTS += -L/usr/Lib -L$(ICP_BUILD_OUTPUT) | ||
29 | + ADDITIONAL_OBJECTS += -L$(ICP_BUILD_OUTPUT) | ||
30 | |||
31 | ifeq ($(WITH_UPSTREAM),1) | ||
32 | ifeq ($(WITH_ICP_TARGET),1) | ||
33 | diff --git a/quickassist/lookaside/access_layer/src/sample_code/functional/dc/dc_dp_sample/Makefile b/quickassist/lookaside/access_layer/src/sample_code/functional/dc/dc_dp_sample/Makefile | ||
34 | index 7a4d593..06cbc3d 100644 | ||
35 | --- a/quickassist/lookaside/access_layer/src/sample_code/functional/dc/dc_dp_sample/Makefile | ||
36 | +++ b/quickassist/lookaside/access_layer/src/sample_code/functional/dc/dc_dp_sample/Makefile | ||
37 | @@ -70,7 +70,7 @@ ifeq ($(ICP_OS_LEVEL),user_space) | ||
38 | # Build user space executible | ||
39 | # | ||
40 | ############################################################ | ||
41 | -ADDITIONAL_OBJECTS += -L/usr/Lib -lpthread -lcrypto | ||
42 | +ADDITIONAL_OBJECTS += -lpthread -lcrypto | ||
43 | |||
44 | USER_SOURCE_FILES += ../../common/cpa_sample_utils.c cpa_dc_dp_sample.c | ||
45 | USER_SOURCE_FILES += cpa_dc_dp_sample_user.c | ||
46 | diff --git a/quickassist/lookaside/access_layer/src/sample_code/performance/Makefile b/quickassist/lookaside/access_layer/src/sample_code/performance/Makefile | ||
47 | index 4b6857f..3914c1b 100644 | ||
48 | --- a/quickassist/lookaside/access_layer/src/sample_code/performance/Makefile | ||
49 | +++ b/quickassist/lookaside/access_layer/src/sample_code/performance/Makefile | ||
50 | @@ -341,7 +341,7 @@ endif | ||
51 | |||
52 | |||
53 | |||
54 | -ADDITIONAL_OBJECTS += -L/Lib -lpthread | ||
55 | +ADDITIONAL_OBJECTS += -lpthread | ||
56 | ADDITIONAL_OBJECTS += -lcrypto | ||
57 | ifeq ($(WITH_UPSTREAM),1) | ||
58 | ifeq ($(OS),linux) | ||
59 | -- | ||
60 | 2.14.5 | ||
61 | |||