diff options
author | Lim Siew Hoon <siew.hoon.lim@intel.com> | 2024-11-27 10:41:47 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-11-27 15:27:56 +0800 |
commit | 31ebf1b3469dd2cf2d45fc8f9eea5e0c449a0b09 (patch) | |
tree | 965de33c6d155b987c7889fc1b7c8bd48c9ae04a | |
parent | cf1f250ae73294f682bb6570d13c53d55f5e14a3 (diff) | |
download | meta-intel-31ebf1b3469dd2cf2d45fc8f9eea5e0c449a0b09.tar.gz |
gmmlib: upgrade 22.5.1 -> 22.5.2
Add bug fixed on BMG platform:
- 0001-Extend-helper-Macros-219.patch
Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | recipes-graphics/gmmlib/files/0001-Extend-helper-Macros-219.patch | 74 | ||||
-rw-r--r-- | recipes-graphics/gmmlib/gmmlib_22.5.2.bb (renamed from recipes-graphics/gmmlib/gmmlib_22.5.1.bb) | 3 |
2 files changed, 76 insertions, 1 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Extend-helper-Macros-219.patch b/recipes-graphics/gmmlib/files/0001-Extend-helper-Macros-219.patch new file mode 100644 index 00000000..d6be11f4 --- /dev/null +++ b/recipes-graphics/gmmlib/files/0001-Extend-helper-Macros-219.patch | |||
@@ -0,0 +1,74 @@ | |||
1 | From a025de4d83066f1ddf0890a0c7d87044f8723777 Mon Sep 17 00:00:00 2001 | ||
2 | From: John Machado <john.machado@intel.com> | ||
3 | Date: Mon, 18 Nov 2024 16:14:08 +0530 | ||
4 | Subject: [PATCH] Extend helper Macros (#219) | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/31ee7e6d48a98a2cb8afb87f0d4f2afc97fe06a0] | ||
7 | Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> | ||
8 | |||
9 | --- | ||
10 | Source/inc/common/igfxfmid.h | 13 +++++++------ | ||
11 | 1 file changed, 7 insertions(+), 6 deletions(-) | ||
12 | |||
13 | diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h | ||
14 | index a9176de..8d831e4 100644 | ||
15 | --- a/Source/inc/common/igfxfmid.h | ||
16 | +++ b/Source/inc/common/igfxfmid.h | ||
17 | @@ -399,7 +399,7 @@ typedef enum __NATIVEGTTYPE | ||
18 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
19 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
20 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
21 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
22 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
23 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
24 | |||
25 | #define GFX_IS_GEN_8_OR_LATER(p) ( ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN8_CORE ) || \ | ||
26 | @@ -409,7 +409,7 @@ typedef enum __NATIVEGTTYPE | ||
27 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
28 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
29 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
30 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
31 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
32 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
33 | |||
34 | #define GFX_IS_GEN_8_CHV_OR_LATER(p) ( ( GFX_GET_CURRENT_PRODUCT(p) == IGFX_CHERRYVIEW ) || \ | ||
35 | @@ -419,7 +419,7 @@ typedef enum __NATIVEGTTYPE | ||
36 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
37 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
38 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
39 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
40 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
41 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
42 | |||
43 | #define GFX_IS_GEN_9_OR_LATER(p) ( ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN9_CORE ) || \ | ||
44 | @@ -428,7 +428,7 @@ typedef enum __NATIVEGTTYPE | ||
45 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
46 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
47 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
48 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
49 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
50 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
51 | |||
52 | #define GFX_IS_GEN_10_OR_LATER(p) (( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN10_CORE ) || \ | ||
53 | @@ -436,15 +436,16 @@ typedef enum __NATIVEGTTYPE | ||
54 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
55 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
56 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
57 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
58 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
59 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
60 | |||
61 | #define GFX_IS_GEN_11_OR_LATER(p) (( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN11_CORE ) || \ | ||
62 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GEN12_CORE ) || \ | ||
63 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HP_CORE ) || \ | ||
64 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPG_CORE ) || \ | ||
65 | - ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_XE_HPC_CORE ) || \ | ||
66 | + ( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_XE_HPC_CORE ) || \ | ||
67 | ( GFX_GET_CURRENT_RENDERCORE(p) == IGFX_GENNEXT_CORE ) ) | ||
68 | + | ||
69 | #define GFX_IS_GEN_12_OR_LATER(p) (( GFX_GET_CURRENT_RENDERCORE(p) >= IGFX_GEN12_CORE )) | ||
70 | #define GFX_IS_ATOM_PRODUCT_FAMILY(p) ( GFX_IS_PRODUCT(p, IGFX_VALLEYVIEW) || \ | ||
71 | GFX_IS_PRODUCT(p, IGFX_CHERRYVIEW) || \ | ||
72 | -- | ||
73 | 2.43.2 | ||
74 | |||
diff --git a/recipes-graphics/gmmlib/gmmlib_22.5.1.bb b/recipes-graphics/gmmlib/gmmlib_22.5.2.bb index 93567f52..c380d449 100644 --- a/recipes-graphics/gmmlib/gmmlib_22.5.1.bb +++ b/recipes-graphics/gmmlib/gmmlib_22.5.2.bb | |||
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654" | |||
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | git://github.com/intel/gmmlib.git;protocol=https;branch=master \ | 10 | git://github.com/intel/gmmlib.git;protocol=https;branch=master \ |
11 | file://0001-Extend-helper-Macros-219.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRCREV = "06c05158f5d9d55906271feda50b161d743aee9b" | 14 | SRCREV = "567dc09fd3859de3d9c09456ee7b366c0d327eb6" |
14 | 15 | ||
15 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
16 | 17 | ||