summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2024-08-28 09:55:06 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2024-08-29 09:49:18 +0800
commit740eed7a7d5b70d20dc7e1c3a374fdc22b0e63fd (patch)
tree098f90583ae2805e81379a6416395fdb04253433
parent25debfe314d1997091650fa44b230e820e9de6d3 (diff)
downloadmeta-intel-740eed7a7d5b70d20dc7e1c3a374fdc22b0e63fd.tar.gz
linux-intel/6.10 : update to tag mainline-tracking-v6.10-linux-240717T063713Z
* Drop recipe for 6.8 kernel * Add recipe for 6.10 kernel * Move the patches specific to kernel 6.10 to the recipe Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch48
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch58
-rw-r--r--recipes-kernel/linux/linux-intel_6.10.bb (renamed from recipes-kernel/linux/linux-intel_6.8.bb)13
3 files changed, 114 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch
new file mode 100644
index 00000000..df2a4139
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch
@@ -0,0 +1,48 @@
1From 4881d0f985aab70c685bd63b56a2d6ad5e790abc Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Sun, 10 Jul 2022 22:56:53 -0400
4Subject: [PATCH] lib/build_OID_registry: fix reproducibility issues
5
6The script build_OID_registry captures the full path of itself
7in the generated data. This causes reproduciblity issues as the
8path is captured and packaged.
9
10We use the basename of the script instead, and that allows us
11to be reprodicible, with slightly less information captured in
12the output data (but the generating script can still easily
13be found).
14
15Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
16Upstream-Status: Inappropriate
17
18Taken from linux-yocto, v5.15/standard/base.
19
20Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
21---
22 lib/build_OID_registry | 3 ++-
23 1 file changed, 2 insertions(+), 1 deletion(-)
24
25diff --git a/lib/build_OID_registry b/lib/build_OID_registry
26index 8267e8d71338..755dd33a8b04 100755
27--- a/lib/build_OID_registry
28+++ b/lib/build_OID_registry
29@@ -9,6 +9,7 @@
30
31 use strict;
32 use Cwd qw(abs_path);
33+use File::Basename;
34
35 my @names = ();
36 my @oids = ();
37@@ -40,7 +41,7 @@ open C_FILE, ">$ARGV[1]" or die;
38 print C_FILE "/*\n";
39 my $scriptname = $0;
40 $scriptname =~ s#^\Q$abs_srctree/\E##;
41-print C_FILE " * Automatically generated by ", $scriptname, ". Do not edit\n";
42+print C_FILE " * Automatically generated by ", basename $0, ". Do not edit\n";
43 print C_FILE " */\n";
44
45 #
46--
472.34.1
48
diff --git a/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch b/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch
new file mode 100644
index 00000000..fd89af6c
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch
@@ -0,0 +1,58 @@
1From 5635e0677692bc502588b09d04f138394e02669b Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Sun, 10 Jul 2022 21:37:07 -0400
4Subject: [PATCH] vt/conmakehash: improve reproducibility
5
6The file generated by conmakehash capture the application
7path used to generate the file. While that can be informative,
8it varies based on where the kernel was built, as the full
9path is captured.
10
11We tweak the application to use a second input as the "capture
12name", and then modify the Makefile to pass the basename of
13the source, making it reproducible.
14
15This could be improved by using some sort of path mapping,
16or the application manipualing argv[1] itself, but for now
17this solves the reprodicibility issue.
18
19Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
20
21Upstream-Status: Inappropriate
22
23Taken from linux-yocto, v5.15/standard/base
24Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
25---
26 drivers/tty/vt/Makefile | 2 +-
27 drivers/tty/vt/conmakehash.c | 2 +-
28 2 files changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile
31index 2c8ce8b592ed..8532077ed3bb 100644
32--- a/drivers/tty/vt/Makefile
33+++ b/drivers/tty/vt/Makefile
34@@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c
35 hostprogs += conmakehash
36
37 quiet_cmd_conmk = CONMK $@
38- cmd_conmk = $(obj)/conmakehash $< > $@
39+ cmd_conmk = $(obj)/conmakehash $< $(shell basename $<) > $@
40
41 $(obj)/consolemap_deftbl.c: $(src)/$(FONTMAPFILE) $(obj)/conmakehash
42 $(call cmd,conmk)
43diff --git a/drivers/tty/vt/conmakehash.c b/drivers/tty/vt/conmakehash.c
44index dc2177fec715..9df2198c459b 100644
45--- a/drivers/tty/vt/conmakehash.c
46+++ b/drivers/tty/vt/conmakehash.c
47@@ -264,7 +264,7 @@ int main(int argc, char *argv[])
48 #include <linux/types.h>\n\
49 \n\
50 u8 dfont_unicount[%d] = \n\
51-{\n\t", rel_tblname, fontlen);
52+{\n\t", argv[2], fontlen);
53
54 for ( i = 0 ; i < fontlen ; i++ )
55 {
56--
572.34.1
58
diff --git a/recipes-kernel/linux/linux-intel_6.8.bb b/recipes-kernel/linux/linux-intel_6.10.bb
index 30343357..69ee742a 100644
--- a/recipes-kernel/linux/linux-intel_6.8.bb
+++ b/recipes-kernel/linux/linux-intel_6.10.bb
@@ -2,7 +2,10 @@ require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
4 " 4 "
5KMETA_BRANCH = "master" 5SRC_URI:append = "file://0001-6.10-vt-conmakehash-improve-reproducibility.patch \
6 file://0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch \
7 "
8KMETA_BRANCH = "yocto-6.10"
6 9
7LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
8 11
@@ -10,13 +13,13 @@ DEPENDS += "elfutils-native openssl-native util-linux-native"
10 13
11LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 14LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
12 15
13LINUX_VERSION ?= "6.8" 16LINUX_VERSION ?= "6.10"
14SRCREV_machine ?= "4b78f19d1c451c3738b10d489e67977e97036a7f" 17SRCREV_machine ?= "37b6bf1243b894e0da6e640e589d479f3208f5ae"
15SRCREV_meta ?= "d6379f226f25136d9292f09cd7c11921f0bbcd9b" 18SRCREV_meta ?= "e4d2ade39f231ea279f19298c008ba48f4a202e5"
16 19
17# Functionality flags 20# Functionality flags
18KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ 21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \
19 features/security/security.scc \ 22 features/security/security.scc \
20 features/intel-npu/intel-npu.scc" 23 features/intel-npu/intel-npu.scc"
21 24
22UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v6.7-rc3-linux-(?P<pver>(\d+)T(\d+)Z)$" 25UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v6.10-linux-(?P<pver>(\d+)T(\d+)Z)$"